You are not logged in.

#1 2021-03-20 05:19:32

m4ttj
Member
Registered: 2020-07-26
Posts: 10

[SOLVED] plasma core dumping when enabling a second screen

My plasmashell seems to be crashing when I enable my second screen. When I enable in system settings and apply, it briefly works then my programs crash, then plasma crashes, plasma restarts, and then resets to its original configuration with the single monitor.
The automated stack trace can be found here: https://pastebin.com/mfeZ9aRs and systemd logs here: https://pastebin.com/Et7wey7r

Last edited by m4ttj (2021-04-04 18:34:18)

Offline

#2 2021-03-20 09:31:10

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,780

Re: [SOLVED] plasma core dumping when enabling a second screen

m4ttj wrote:

#6  0x00007fee0c1a89ac in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/libQt5Core.so.5

This means the process threw some error to stderr. Please post the full journal output for the plasmashell process (not just the coredump)

Offline

#3 2021-03-20 10:44:16

m4ttj
Member
Registered: 2020-07-26
Posts: 10

Re: [SOLVED] plasma core dumping when enabling a second screen

I'm not sure exactly what is being outputted to stderr that is helpful. Running journalctl gives a rather large output but the top (where I assume the major error is) looks like this https://pastebin.com/bKr7AQYc. I'm not sure what's helpful there but systemd seems to detect (start?) the display configuration change and kscreen.kwayland starts loading the wayland backend and then kwin_wayland immediately dies. Please let me know if I can get more logging data or anything smile

Offline

#4 2021-03-22 02:16:26

m4ttj
Member
Registered: 2020-07-26
Posts: 10

Re: [SOLVED] plasma core dumping when enabling a second screen

After some more debugging it seems this is the journalctl -xe output at the time of the crash https://pastebin.com/npMPyaax (I applied the display changes at 02:14). Additionally here is the crash message on boot https://pastebin.com/f3Q6wuip and the SDDM logs https://pastebin.com/8eqHnnE9. From the SDDM logs, is

wl_registry@26: error 0: invalid global wl_output (36)

relevant?

Last edited by m4ttj (2021-03-22 03:01:48)

Offline

#5 2021-03-22 16:02:48

zpg443
Member
Registered: 2016-12-03
Posts: 160

Re: [SOLVED] plasma core dumping when enabling a second screen

Are you using an external monitor with your laptop? Are you using Gnome as your DE?

Offline

#6 2021-03-22 16:34:03

m4ttj
Member
Registered: 2020-07-26
Posts: 10

Re: [SOLVED] plasma core dumping when enabling a second screen

zpg443 wrote:

Are you using an external monitor with your laptop? Are you using Gnome as your DE?

Yes external monitor (and it worked fine until recently) and no, not gnome, I'm running KDE Plasma.

Offline

#7 2021-03-24 06:53:40

m4ttj
Member
Registered: 2020-07-26
Posts: 10

Re: [SOLVED] plasma core dumping when enabling a second screen

Adding that creating a new user doesn't seem to help (in fact, it just lead to a black screen booting) and launching directly via tty (not sddm) also gives the same result as above.

Offline

#8 2021-04-01 20:08:43

m4ttj
Member
Registered: 2020-07-26
Posts: 10

Re: [SOLVED] plasma core dumping when enabling a second screen

Any ideas on how to further debug this?

Offline

#9 2021-04-04 18:33:37

m4ttj
Member
Registered: 2020-07-26
Posts: 10

Re: [SOLVED] plasma core dumping when enabling a second screen

Turns out it must be a configuration issue - I restored all the relevant kde/plasma config folders I could find from a backup and it magically started working! Not sure exactly what I changed (I don't remember changing anything?) but it seems to work now!

Offline

Board footer

Powered by FluxBB