You are not logged in.

#1 2021-04-05 07:19:46

Skunky
Member
Registered: 2018-01-25
Posts: 198

Prevent AMD RX 570 fans from going 0 RPM

Seems like newer kernels implemented the "0 RPM" feature for AMD cards, this means that my GPU fans will keep going on/off (at reboot and depending on workload), my question is very simple, how do i disable that? This doesn't happen on LTS kernel.
As soon as i boot the system 0RPM kick in and stops the fan so any system service/cronjob will start too late to prevent this, what can i do about it? I've been reading https://wiki.archlinux.org/index.php/Fa … an_control and found out that i can use

echo 1 > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1_enable ;
echo 32 > /sys/class/drm/card0/device/hwmon/hwmon0/pwm1

To take manual control over fans and set the desired minimum speed, but as i said, creating a system service containing this would be pointless because 0RPM kicks in too early at boot.

EDIT: FWIW i'm on linux-zen 5.11.11

Last edited by Skunky (2021-04-05 07:20:20)

Offline

#2 2021-04-09 17:47:33

HurricanePootis
Member
Registered: 2020-10-16
Posts: 1

Re: Prevent AMD RX 570 fans from going 0 RPM

Personally, I always used `corectrl` to set my own manual fancurve, disable the 0RPM future. This should allow you to use any kernel of your choice. You can set corectrl to start on boot, and you can read at the corectrl wiki at their gitlab on how to make it get auto-root privileges with pam so you don't have to type in your root password. https://gitlab.com/corectrl/corectrl

If you want a non-gui service, you can use `amdgpu-fan` too. https://github.com/chestm007/amdgpu-fan

Offline

Board footer

Powered by FluxBB