You are not logged in.

#1 2021-04-01 15:33:06

ackerleytng
Member
Registered: 2019-08-18
Posts: 12

[SOLVED] chrome and llpp freezing

Recently, chrome has been freezing for me, I use i3 on arch.

chrome would suddenly stop responding, and then if i switch workspaces and switch back, the chrome window will be completely black inside, but the i3 frame (the blue strip with the webpage title - Google Chrome) would still be active. After a while (~30s) chrome would unfreeze and continue as if nothing happened.

This happens to llpp too, and at the same time - when chrome or llpp freeze, it would affect the other program. llpp goes dark, but unlike chrome, llpp never recovers and has to be restarted.

Interestingly chrome has been freezing on my mac as well. I've tried uninstalling some extensions that I don't use. That seems to help on Mac, but not on my Thinkpad x1c6 (arch).

Any ideas on where to start debugging?

Last edited by ackerleytng (2021-04-05 15:45:33)

Offline

#2 2021-04-01 15:37:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED] chrome and llpp freezing

Which hardware? Symptom wise this sounds like the kind of issues that can happen with xf86-video-intel which you could try to remove (... don't forget confguration files for xorg using the "intel" driver if that is the case)

Offline

#3 2021-04-01 16:01:09

ackerleytng
Member
Registered: 2019-08-18
Posts: 12

Re: [SOLVED] chrome and llpp freezing

I'm using a Thinkpad x1c6 and the Intel UHD 620 with a 2560x1440 screen.

If I remove xf86-video-intel, what do I replace it with? Or do I not need it at all?

Offline

#4 2021-04-01 16:02:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED] chrome and llpp freezing

Xorg has a built-in "modesetting" driver that will be used instead and it often tends to work better on newer HW.

Last edited by V1del (2021-04-01 16:03:37)

Offline

#5 2021-04-01 16:13:41

ackerleytng
Member
Registered: 2019-08-18
Posts: 12

Re: [SOLVED] chrome and llpp freezing

Thanks! I've uninstalled it. Will report back if it improves!

I just uninstall that package (pacman -R xf86-video-intel) and reboot, right? Are there any required config changes?

Last edited by ackerleytng (2021-04-01 16:14:43)

Offline

#6 2021-04-01 16:16:51

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED] chrome and llpp freezing

If you haven't manually created a config for xf86-video-intel no. If you were using xbacklight for display brightness you might want to switch that out for something else, acpilight has a drop-in that does the correct thing without unnecessarily relying on xf86-video-intel

Last edited by V1del (2021-04-01 16:17:55)

Offline

#7 2021-04-03 14:01:44

ackerleytng
Member
Registered: 2019-08-18
Posts: 12

Re: [SOLVED] chrome and llpp freezing

Thank you so much for the tip!! I was using xbacklight, and I did need to replace that with acpilight. I found that I already had the udev rules set up, but had to add myself to the video group for acpilight to work.

Offline

#8 2021-04-05 14:31:43

ackerleytng
Member
Registered: 2019-08-18
Posts: 12

Re: [SOLVED] chrome and llpp freezing

@V1del your suggestion seems to have solved the freezing! Thanks!

Offline

#9 2021-04-05 14:54:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED] chrome and llpp freezing

Glad to hear, please mark as [SOLVED] by editing the title in your first post.

Offline

Board footer

Powered by FluxBB