You are not logged in.

#1 2021-04-05 14:17:28

Tar3k Hasan
Member
Registered: 2021-03-19
Posts: 14

[Solved]Problems with external mouse and touchpad.

Hello,
I'm facing some weird problems with my mouse. I'm using Arch with KDE in my laptop. So in general I use touchpad. But today I wanted to try out a game so I plugged in my mouse. It's an old A4tech mouse. When I plugged in the mouse it doesn't detect suddenly. But after 20-30 seconds it gets detected. But then I can't use my mouse neither my touchpad. Courser moves but not a single buttons in the mouse or in the touchpad works properly. After recognizing the mouse a sticky note appears in the desktop as you all know it's a feature for touchpad 3 finger gesture. Then I can click for the first time then nothing works. Sometimes I can click and move window here and there but it freezes there. I mean courser freezer in the moving window mode. I have to press Esc to be able to move the courser. At that time my touchpad clicks doesn't work. I can move the courser with touchapd but clicks doesn't work. I've unchecked the option "Disable touchpad when mouse is plugged in" in KDE settings. After unplugging mouse touchpad starts working. Long story short I can't do anything after plugging in my mouse. It's annoying tbh. I hope someone can help.

Sorry for my bad English smile.

Last edited by Tar3k Hasan (2021-04-10 08:52:48)

Offline

#2 2021-04-05 15:02:45

icar
Member
Registered: 2020-07-31
Posts: 111

Re: [Solved]Problems with external mouse and touchpad.

I have a similar issue with my laptop, but on boot. Long story short, try the following after inserting the mouse:

modprobe -r i2c_hid && modprobe i2c_hid

Online

#3 2021-04-05 19:39:29

Tar3k Hasan
Member
Registered: 2021-03-19
Posts: 14

Re: [Solved]Problems with external mouse and touchpad.

The command literally removes my touchpad. I had timeshift enabled. I didn't verify what this command is about lol.

icar wrote:

I have a similar issue with my laptop, but on boot. Long story short, try the following after inserting the mouse:

modprobe -r i2c_hid && modprobe i2c_hid

Offline

#4 2021-04-06 08:43:16

schef
Member
Registered: 2009-04-16
Posts: 68

Re: [Solved]Problems with external mouse and touchpad.

Hi guys. I have the same issue. Here is my dmesg output when i connect the mouse:

[  403.463956] usb 3-4: new full-speed USB device number 6 using xhci_hcd
[  403.606606] usb 3-4: New USB device found, idVendor=046d, idProduct=c52f, bcdDevice=30.00
[  403.606612] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  403.606614] usb 3-4: Product: USB Receiver
[  403.606615] usb 3-4: Manufacturer: Logitech
[  403.609370] logitech-djreceiver 0003:046D:C52F.0005: hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:14.0-4/input0
[  403.665481] logitech-djreceiver 0003:046D:C52F.0006: hiddev97,hidraw2: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-4/input1
[  403.721627] logitech-djreceiver 0003:046D:C52F.0006: device of type eQUAD step 4 DJ (0x04) connected on slot 1
[  403.729761] input: Logitech M280/320/275 as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.1/0003:046D:C52F.0006/0003:046D:4057.0007/input/input36
[  403.729945] logitech-hidpp-device 0003:046D:4057.0007: input,hidraw3: USB HID v1.11 Mouse [Logitech M280/320/275] on usb-0000:00:14.0-4/input1:1
[  425.705639] logitech-hidpp-device 0003:046D:4057.0007: HID++ 4.5 device connected.

When the

HID++

line appears the both trachpad and usb mouse stop working. When i plug out the usb mouse and restart the

i2c_hid

it works again.

Offline

Board footer

Powered by FluxBB