You are not logged in.

#1 2021-04-06 16:33:34

freaks
Member
Registered: 2010-11-10
Posts: 57

fresh install with nvidia RTX3060 black screen after reboot

hello
i try a fresh install of archlinux with RXT3060 ( MSI ) and MSI motherboard

root@archiso ~ #  lspci -k | grep -A 2 -E "(VGA|3D)"
01:00.0 VGA compatible controller: NVIDIA Corporation Device 2503 (rev a1)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device 3976
   

when i reboot i just have an underscore on the top left of the screen but not grub

this is my commands to install :

type "gdisk /dev/nvme0n1" then "n"

Partition number (3-128, default 1):

First sector : default

Last sector :
taper "+1024MiB"
Current type is ’Linux filesystem’
Hex code or GUID (L to show codes, Enter = 8300):
type "EF00"
Changed type of partition to ’EFI System’



second partition for home :

type "n"
First sector : default:
Last sector : default:

type "w" then "Y"



1. Create filesystems
For all partitions except /boot we will use the ext4 file system.


format FAT32 boot:
"mkfs.fat -F32 /dev/nvme0n1p1"


format ext4 second partition :
"mkfs.ext4 /dev/nvme0n1p2" then "y"



2. Mounting partitions

mount /dev/nvme0n1p2 /mnt
mkdir -p /mnt/boot/efi
mount /dev/nvme0n1p1 /mnt/boot/efi
pacstrap -i /mnt base linux linux-firmware
genfstab -U -p /mnt >> /mnt/etc/fstab
arch-chroot /mnt
pacman -S efibootmgr grub puis Y
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck
grub-mkconfig -o /boot/grub/grub.cfg
passwd
pacman -S networkmanager vim nano net-tools

pacman -S nvidia nvidia-utils

ctrl + A + D
umount /mnt/boot/efi
umount /mnt
reboot

lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0         7:0    0 571.4M  1 loop 
sda           8:0    1  58.4G  0 disk 
|-sda1        8:1    1   634M  0 part 
|-sda2        8:2    1    61M  0 part 
`-sda3        8:3    1   300K  0 part 
nvme0n1     259:0    0 465.8G  0 disk 
|-nvme0n1p1 259:3    0     1G  0 part /boot/efi
`-nvme0n1p2 259:4    0 464.8G  0 part /
[root@archiso /]# efibootmgr
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0000,0003,0001,0002
Boot0000* arch_grub
Boot0001* Hard Drive
Boot0002* USB HDD
Boot0003* UEFI: SanDisk, Partition 2

thanks for your help

Last edited by freaks (2021-04-06 16:36:58)

Offline

#2 2021-04-06 16:39:49

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: fresh install with nvidia RTX3060 black screen after reboot

MSI boards are notorious for a broken UEFI implementation that doesn't allow proper access to NVRAM. chroot in and rerun the grub-install command with the --removable flag.

Offline

#3 2021-04-06 16:43:24

freaks
Member
Registered: 2010-11-10
Posts: 57

Re: fresh install with nvidia RTX3060 black screen after reboot

V1del wrote:

MSI boards are notorious for a broken UEFI implementation that doesn't allow proper access to NVRAM. chroot in and rerun the grub-install command with the --removable flag.

ok thanks !!

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck --removable

Last edited by freaks (2021-04-06 16:46:08)

Offline

Board footer

Powered by FluxBB