You are not logged in.

#1 2021-03-10 03:49:14

dom64
Member
Registered: 2021-03-10
Posts: 2

Stuttering and tearing in windowed games

Hello.

There is an issue where most games I play on steam will either screen stutter or screen tear when playing in windowed mode. The only way this would go away for me is to enable "Allow Flipping" in the nvidia-settings OpenGL Settings page and going fullscreen.

I have tried https://wiki.archlinux.org/index.php/NV … en_tearing and it works for screen tearing but it also results in screen stuttering. I have tried switching settings in OpenGL Settings but it doesn't result in any change. I have tried using picom and changing the variables "backend" and "vsync" but it results in some games not having any issues and other games having tearing/stuttering. I have tried to use DRM kernel mode but it resulted in no change. I tried switching desktop environments and it resulted some games not having any issues and other games having tearing/stuttering.

My graphics card is a GTX 1050 Ti.

Is there a fix for this or do I have to play all my games in fullscreen?

Offline

#2 2021-03-11 19:18:11

bjornp_
Member
Registered: 2020-12-31
Posts: 17

Re: Stuttering and tearing in windowed games

I have had similar issues on i3wm. For me it was solved by disabling my compositor when running games. If you're running a window manager or desktop environment which has a separate compositor, try turning it off and see if it helps.


Fun fact: I actually have no clue what I'm doing

Offline

#3 2021-04-06 19:39:23

dom64
Member
Registered: 2021-03-10
Posts: 2

Re: Stuttering and tearing in windowed games

Ok after a lot of messing around I found the best solution for this is to have picom on with vsync and glx backend turned on and to have force composition pipeline turned off in nvidia-settings.

The force composition pipeline is what causes games to stutter but turning it off just makes the tearing come back instead.

This is the full picom.conf

backend = "glx";
vsync = true;

The command I used to start picom is "picom -CGb" and it was placed in my .xinitrc.

There are still some issues with this. Games with vsync on have a lot of delay for my mouse for some reason and it doesn't fix stuttering for all games. But the games that I have issues with I can just disable or enable vsync depending on what the issue is. This issue does not happen with nouveau drivers but using it will just cause bad performance. I have also tried to use fedora and pop os to see if it was an os issue and they both had the same issue with the mouse. Unless someone else can find a better solution this is what I'm going to use for now.

Edit: The delay also affected my keyboard and mouse. Turning off vsync fixes the issue

Last edited by dom64 (2021-04-06 20:48:11)

Offline

Board footer

Powered by FluxBB