You are not logged in.

#1 2021-02-24 13:55:58

lviggiani
Member
Registered: 2014-02-28
Posts: 127

[SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

Hello,
I've been successfully sharing my screen in Chrome (eg. google meet) on Wayland for long time by setting thing up like stated here:

https://wiki.archlinux.org/index.php/Pi … en_sharing

Especially by installing libpipewire02 required for compatibility.
Unfortunately since yesterday, that stopped working and shows a black screen to other users in call.
If I uninstall libpipewire02 and restart pipewire.service and try to share the screen, Chrome crashes.
I downgraded pipewire to 0.3.21 and restarted my system (restarting the service is not enough) and screen sharing is now working again. I think 0.3.22 breaks some compatibility with 0.2
Any idea?
Thanks!

Last edited by lviggiani (2021-03-05 08:00:44)

Offline

#2 2021-03-03 09:54:10

jvalecillos
Member
Registered: 2009-02-25
Posts: 24

Re: [SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

I can confirm the problem. Also happening using Firefox 86.0.

Screen sharing works correctly using Pipewire version 1:0.3.21-2, while version 1:0.3.22-2 is broken (at least for screen sharing in the aforementioned browsers).

The workaround is to downgrade to Pipewire version 1:0.3.21-2.

Offline

#3 2021-03-03 10:03:26

progandy
Member
Registered: 2012-05-17
Posts: 4,236

Re: [SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

The real fix/workaround is to enable the "metadata" module in. /etc/pipewire/media-session.d/media-session.conf
https://gitlab.freedesktop.org/pipewire … ote_812588


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#4 2021-03-05 08:00:24

lviggiani
Member
Registered: 2014-02-28
Posts: 127

Re: [SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

progandy wrote:

The real fix/workaround is to enable the "metadata" module in. /etc/pipewire/media-session.d/media-session.conf
https://gitlab.freedesktop.org/pipewire … ote_812588

Thanks!
BTW after receiving pipewire 0.3.22-2, screen sharing is working again

Offline

#5 2021-04-06 16:40:50

jvalecillos
Member
Registered: 2009-02-25
Posts: 24

Re: [SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

It seems that it broke again after I updated the system last week. Nothing in the journal. I'm still trying to figure out what is the issue.

Offline

#6 2021-04-06 16:49:24

Morn
Member
Registered: 2012-09-02
Posts: 711

Re: [SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

jvalecillos wrote:

It seems that it broke again after I updated the system last week. Nothing in the journal. I'm still trying to figure out what is the issue.

Make sure to integrate any .pacnew files that appear in /etc/pipewire/media-session.d/.

Offline

#7 2021-04-07 10:16:23

jvalecillos
Member
Registered: 2009-02-25
Posts: 24

Re: [SOLVED] Screen Sharing in Chrome(ium) + Wayland via pipewire broken

Thank you that solved the issue.

Morn wrote:
jvalecillos wrote:

It seems that it broke again after I updated the system last week. Nothing in the journal. I'm still trying to figure out what is the issue.

Make sure to integrate any .pacnew files that appear in /etc/pipewire/media-session.d/.

I'm not sure what the difference is and in fact the metadata option is now commented in the new /etc/pipewire/media-session.d/media-session.conf (previous workaround mentioned in the GitLab issue).

Now, everything works just using pipewire and xdg-desktop-portal-gtk (for GNOME) as described in the Arch Linux Wiki

Last edited by jvalecillos (2021-04-07 10:17:21)

Offline

Board footer

Powered by FluxBB