You are not logged in.

#1 2021-04-08 07:23:49

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 800

Error when setting up Mattermost with Docker

I'm trying to setup a Mattermost server using Docker as described in the wiki. I get an error when running docker-compose build:

$ docker-compose build

. . .

Step 3/10 : RUN echo "azure<5.0.0" > pip-constraints.txt
 ---> Running in 9ed7b9ae4878
OCI runtime create failed: container_linux.go:367: starting container process caused: process_linux.go:495: container init caused: process_linux.go:458: setting cgroup config for procHooks process caused: can't load program: invalid argument: unknown
ERROR: Service 'db' failed to build

I guess I'm missing something in my setup but I can't figure out what (probably I made some stupid error in setting up docker); I found related but different issues on the web, and no solution for this specific one. Any help would be greatly appreciated.
Thanks in advance.

Offline

#2 2021-04-08 13:47:56

dhax
Member
Registered: 2020-12-03
Posts: 2

Re: Error when setting up Mattermost with Docker

I am getting the exactly same error now out of a sudden after successfully running two containers for more than a year. The only thing that changed on my armv7 odroid was a pacman upgrade of Docker to the latest version 20.10.5. The error then first occured when I pulled a newer image and tried to run docker-compose up -d --build for both containers (syncthing and pihole in my case).

Now I can't even start the hello-world container anymore, getting the same error message. So far I tried reinstalling docker through pacman, but that didn't fix it.

What program can it not load? Something to do with cgroup changing to v2 maybe? Here's my "docker info" output:

Client:
Context:    default
Debug Mode: false
Plugins:
  app: Docker App (Docker Inc., v0.9.1-beta3)
  buildx: Build with BuildKit (Docker Inc., v0.5.1-tp-docker)

Server:
Containers: 1
  Running: 0
  Paused: 0
  Stopped: 1
Images: 3
Server Version: 20.10.5
Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: systemd
Cgroup Version: 2
Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 05f951a3781f4f2c1911b05e61c160e9c30eaa8e.m
runc version: 12644e614e25b05da6fd08a38ffa0cfe1903fdec
init version: de40ad0
Security Options:
  seccomp
   Profile: default
  cgroupns
Kernel Version: 4.14.180-1-ARCH
Operating System: Arch Linux ARM
OSType: linux
Architecture: armv7l
CPUs: 8
Total Memory: 1.947GiB
Name: odroid
ID: D6GG:retracted:YG
Docker Root Dir: /var/lib/docker
Debug Mode: false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
  127.0.0.0/8
Live Restore Enabled: false

WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
WARNING: No cpu shares support
WARNING: No cpuset support
WARNING: Support for cgroup v2 is experimental

Last edited by dhax (2021-04-08 13:50:08)

Offline

#3 2021-04-09 07:31:02

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 800

Re: Error when setting up Mattermost with Docker

@dhax I don't  know which program fails to be loaded, I tried to investigate but didn't succeed. I'm not an expert of these things and I had little time to invest, in fact I was trying Mattermost with Docker since it is assumed to be the quickest way (barring any error, of course..). If it can help, here's my docker info output:

$ docker info
Client:
 Context:    default
 Debug Mode: false
 Plugins:
  app: Docker App (Docker Inc., v0.9.1-beta3)
  buildx: Build with BuildKit (Docker Inc., v0.5.1-tp-docker)

Server:
 Containers: 2
  Running: 0
  Paused: 0
  Stopped: 2
 Images: 2
 Server Version: 20.10.5
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: false
 Logging Driver: json-file
 Cgroup Driver: systemd
 Cgroup Version: 2
 Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 05f951a3781f4f2c1911b05e61c160e9c30eaa8e.m
 runc version: 12644e614e25b05da6fd08a38ffa0cfe1903fdec
 init version: de40ad0
 Security Options:
  seccomp
   Profile: default
  cgroupns
 Kernel Version: 5.11.11-2-ck-skylake
 Operating System: Arch Linux
 OSType: linux
 Architecture: x86_64
 CPUs: 12
 Total Memory: 15.29GiB
 Name: stryke
 ID: OHL4:IDY5:WK3N:NG5F:V7SZ:G4BN:R7GI:5AD2:MZHK:BZEW:PEKF:DA2O
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
  127.0.0.0/8
 Live Restore Enabled: false

WARNING: Support for cgroup v2 is experimental

Offline

#4 2021-04-09 08:00:27

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 800

Re: Error when setting up Mattermost with Docker

I found my problem. The error happens when using the CK-pathced kernel (I was running linux-ck-skylake 5.11.12-1). When usiong the default Arch kernel (5.11.12-arch1-1) everything works fine.

@dhax I don't know what to say about your issue since you seem to be running 4.14.180-1-ARCH.

Offline

#5 2021-04-09 13:24:11

dhax
Member
Registered: 2020-12-03
Posts: 2

Re: Error when setting up Mattermost with Docker

thanks for the info @snax. Guess my problem then is also due to an old kernel, as the latest docker version seems to require newer kernel features. Maybe someone can confirm...

Offline

#6 Yesterday 17:35:29

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 800

Re: Error when setting up Mattermost with Docker

Using the Arch kernel the procedure works up to the last step, when trying to open http://localhost:8000/ results in a "Unable to connect  Firefox can’t establish a connection to the server at localhost:8000." error. I modified the docker-compose.yml in this way:

diff --git a/docker-compose.yml b/docker-compose.yml
index d119245..7f82c5d 100755
--- a/docker-compose.yml
+++ b/docker-compose.yml
@@ -23,11 +23,13 @@ services:
     build:
       context: app
       # uncomment following lines for team edition or change UID/GID
-      # args:
-      #   - edition=team
-      #   - PUID=1000
-      #   - PGID=1000
+      args:
+        - edition=team
+        - PUID=10085
+        - PGID=1014
       #   - MM_VERSION=5.31
+    ports:
+      - "127.0.0.1:8065:8000"
     restart: unless-stopped
     volumes:
       - ./volumes/app/mattermost/config:/mattermost/config:rw

before the build step, where uid and gid are those of my user. I don't know if I'm doing some error or if the wiki instructions are missing something.
Thanks in advance for any help.

Offline

Board footer

Powered by FluxBB