You are not logged in.

#1 2021-04-16 22:03:08

Registered: 2021-04-16
Posts: 1

Backlight doesn't work at all

Hi! A few days ago I installed arch linux in my laptop, model SF20PA2, made by ECS (probably nobody know about it, it's a chinese company and it makes the computers for schools in my country), specs: CPU: Intel Celeron N3350 , GPU: Intel HD Graphics 500.

Since I've installed arch the brightness controls don't work, i tried xbacklight, some other backlight utilities, modifying kernel parameters in boot (GRUB: acpi_osi=Linux, acpi_osi="!Windows2012",acpi_backlight=video, acpi_backlight=vendor, acpi_backlight=native, acpi_backlight=none),

In /sys/class/backlight/ folder there is one folder called "intel_backlight", some of it's files and values:
"max_brightness"    = 96000
"brightness"             = 19200
"actual_brightness" = 19200
"type"                      = raw
These values change when using xbacklight, but they do not really change anything, when I modified the "acpi_backlight=video" kernel parameter, it also created the folder
/sys/class/backlight/acpi_video0/, it also had the same files as "intel_backlight", but the max bright was 96 and again they really didn't do anything.

I've read the wiki and many many other posts and didn't find a solution, I've used Ubuntu in the past and it worked (also in Windows) even with the key bindings (Fn+F2/F3),
if anyone has something that can help solving this problem, I'd be very happy.

EDIT: I have the last kernel: 5.11.14-arch1-1

Last edited by masiv_ (2021-04-16 22:04:36)


#2 2021-04-17 20:54:31

From: UK
Registered: 2013-08-17
Posts: 4

Re: Backlight doesn't work at all

I have the same issue. This is a regression with the upgrade of the linux and nvidia packages,

linux 5.11.13.arch1-1 -> 5.11.14.arch1-1
nvidia 460.67-7 -> 465.24.02-1
nvidia-settings 460.67-1 -> 465.24.02-1
nvidia-utils 460.67-1 -> 465.24.02-1

I have the same issue with linux-lts and nvidia-lts

linux-lts 5.10.29-1 -> 5.10.30-1
nvidia-lts 1:460.67-6 -> 1:465.24.02-1

Initially downgrading these packages fixed the issue but this is no longer viable as holding back these packages stops the machine from booting.

Setting the brightness using the keyboard or desktop settings updates the value in /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0/brightness but does not alter the brightness.

The value in /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/nvidia_0/brightness does not get updated. Writing values directly to this location does not alter the brightness.

acpi_backlight=video had always worked for me before the upgrade. Setting it to vendor or native has no effect.

Also tried including 'Option "RegistryDwords" "EnableBrightnessControl=1"' in /etc/X11/xorg.conf.d/20-nvidia.conf as specified on the Nvidia wiki page using the device section from an nvidia settings generated xorg.conf file but to no effect.

Latest packages linux 5.11.15.arch1-2 and nvidia 465.24.02-3 do not fix the issue.

OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8700 CPU @ 3.20GHz
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1080/PCIe/SSE2


#3 2021-04-27 19:56:20

From: UK
Registered: 2013-08-17
Posts: 4

Re: Backlight doesn't work at all

I've narrowed this down to the nvidia 465.24.02 packages.

The workaround following suggestions from this thread is to uninstall the nvidia and nvidia-lts packages, install nvidia-dkms 460.67-1 and hold nvidia-settings, nvidia-utils, nvidia-dkms, libxnvctrl and lib32-nvidia-utils at 460.67-1. nvidia-dkms will generate the modules to match each kernel.

The backlight still works with the latest kernels using this method.


#4 2021-04-30 15:23:43

Registered: 2021-04-30
Posts: 1

Re: Backlight doesn't work at all

Same issue with Lenovo Legion R9000P2021H laptop(AMD 5800H, NVIDIA GeForce 3060), rullger's solution work for me.


#5 2021-05-02 14:00:06

Registered: 2020-11-11
Posts: 94

Re: Backlight doesn't work at all

The following message always appear on my dmesg, though my backlight kind of works:
Panel advertises DPCD backlight support, but VBT disagrees. If your backlight controls don't work try booting with i915.enable_dpcd_backlight=1. If your machine needs this, please file a _new_ bug report on drm/i915, see … -i915-bugs for details

Off course I use intel, not sure about how it  applies to you all. Anyway, worth looking over:
Backlight here in the wiki
Intel backlight issue

Always backup important files when editing it.


Board footer

Powered by FluxBB