You are not logged in.

#1 2021-04-18 23:20:43

SailReal
Member
Registered: 2021-04-18
Posts: 3

java-environment=16 isn't resolvable in PKGBUILD's dependency

Hey smile,

This is quiet a noob question and hopefully not asked a few times but I didn't find something using the search.

Together with ajgraves I'm currently moving the cryptomator package to cryptomator-bin and creating a new package which builds the app from source.
Here is new PKGBUILD file: https://github.com/SailReal/cryptomator … n/PKGBUILD

The problem is that as stated in https://wiki.archlinux.org/index.php/Ja … guidelines or better https://wiki.archlinux.org/index.php/Java, java 16 doesn't seem to be available yet but is required to build this package.
In any case the dependency 'java-environment=16' isn't resolvable (however 'java-environment=15' does). Will that change soon?

If I install e.g. 'jdk-adoptopenjdk' which provides 'java-environment=16', I can build and install (makepkg and makepkg -si) this package without any problem but using 'jdk-adoptopenjdk' as dependency (depends=(...)) doesn't work too so this is not really a solution...

Thank you smile

Edit: the correct error message is "error: target not found: java-environment=16"

Last edited by SailReal (2021-04-18 23:43:14)

Offline

#2 2021-04-18 23:44:36

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,341

Re: java-environment=16 isn't resolvable in PKGBUILD's dependency

SailReal wrote:

In any case the dependency 'java-environment=16' isn't resolvable (however 'java-environment=15' does). Will that change soon?

It resolves fine, there's just currently nothing for it to resolve to in the main repos. This will change as soon as v16 is available.

If I install e.g. 'jdk-adoptopenjdk' which provides 'java-environment=16', I can build and install (makepkg and makepkg -si) this package without any problem.

Then everything is working as expected. I don't see what the problem is?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2021-04-18 23:48:53

loqs
Member
Registered: 2014-03-06
Posts: 13,296

Re: java-environment=16 isn't resolvable in PKGBUILD's dependency

If cryptomator was in the official repositories then it would be be an issue as those packages must build using dependencies supplied by those repositories.
AUR PKGBUILDs can declare and require dependencies irrespective of what the official repositories supply.
Edit:
As an aside I would suggest using the the .tar.gz version of the source so you do not need to use unzip which I thought makepkg / bsdtar would extract itself.

Last edited by loqs (2021-04-18 23:53:21)

Offline

#4 2021-04-18 23:54:05

SailReal
Member
Registered: 2021-04-18
Posts: 3

Re: java-environment=16 isn't resolvable in PKGBUILD's dependency

Thanks for the fast response smile

Slithery wrote:

Then everything is working as expected. I don't see what the problem is?

If you don't have java 16 already installed locally it just fails with the message "error: target not found: java-environment=16"...so yes, you know you have to provide java 16 locally but I thought maybe someone have an idea to workaround this until v16 is available...

loqs wrote:

If cryptomator was in the official repositories then it would be be an issue as those packages must build using dependencies supplied by those repositories.
AUR PKGBUILDs can declare and require dependencies irrespective of what the official repositories supply.

Thanks for the hint!

loqs wrote:

As an aside I would suggest using the the .tar.gz version of the source so you do not need to use unzip which I thought makepkg / bsdtar would extract itself.

...and this one too, will apply it!

Last edited by SailReal (2021-04-18 23:57:07)

Offline

#5 2021-04-19 00:13:20

loqs
Member
Registered: 2014-03-06
Posts: 13,296

Re: java-environment=16 isn't resolvable in PKGBUILD's dependency

One other minor issue after I built the package using https://aur.archlinux.org/pkgbase/jdk/ to supply java-environment=16 namcap detected no ELF files in the package which is expected for a java package so the arch should probably be changed to 'any'.
Edit:
Is maven used by cryptomator? If not it should be moved to makedepends.

Last edited by loqs (2021-04-19 00:15:26)

Offline

#6 2021-04-19 00:18:42

SailReal
Member
Registered: 2021-04-18
Posts: 3

Re: java-environment=16 isn't resolvable in PKGBUILD's dependency

loqs wrote:

namcap detected no ELF files in the package which is expected for a java package so the arch should probably be changed to 'any'

thanks for the input, will change it smile

Is maven used by cryptomator? If not it should be moved to makedepends.

No, just for building the project, thanks will change it smile

Offline

Board footer

Powered by FluxBB