You are not logged in.

#1 2021-04-22 20:23:59

hexdsl
Member
Registered: 2015-02-08
Posts: 11

[solved] updated, now I have crazy artifacting

Hey all.

I just ran an update and now i have CRAZY artifacting in most desktop applications. like all sorts of blocky popping. I do not enjoy it.

I am running an AMD GPU.
2 screens both via DP.

Anyone else having this?

Last edited by hexdsl (2021-04-23 20:03:15)

Offline

#2 2021-04-22 21:19:21

swathe
Member
From: au
Registered: 2010-10-01
Posts: 147

Re: [solved] updated, now I have crazy artifacting

I saw the mesa update this morning when I updated. No issues for me as yet. 5700XT GPU.

Offline

#3 2021-04-22 21:38:16

hexdsl
Member
Registered: 2015-02-08
Posts: 11

Re: [solved] updated, now I have crazy artifacting

yeah its not hardware, i get no issues if i boot a live distro (tried like 3, all good) so i assume its a mesa update. I think ill go to bed and worry about this tomorrow night

Last edited by hexdsl (2021-04-22 21:38:23)

Offline

#4 2021-04-22 23:35:57

ts
Member
Registered: 2021-04-22
Posts: 2

Re: [solved] updated, now I have crazy artifacting

I have the same thing.  I am a new user so any recommendations welcome. Wait until the morning is one I can accept.


AMD 5600XT

Offline

#5 2021-04-23 01:20:01

ts
Member
Registered: 2021-04-22
Posts: 2

Re: [solved] updated, now I have crazy artifacting

Downgrading all mesa-related packages to 21.0.2-1 has eliminated the graphical artifacts, so this appears to be mesa related.

cd /var/cache/pacman/pkg && sudo pacman -U *mesa*21.0.2-1*

System specs:

System:    Kernel: 5.11.16-arch1-1 x86_64 bits: 64 Desktop: KDE Plasma 5.21.4 Distro: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 3602 date: 03/06/2021 
CPU:       Info: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP cache: L2: 4 MiB 
           Speed: 4193 MHz min/max: 2200/3900 MHz Core speeds (MHz): 1: 4193 2: 3983 3: 4095 4: 4246 5: 3636 6: 2196 7: 2195 
           8: 2196 9: 3861 10: 2757 11: 2196 12: 2195 13: 2196 14: 2196 15: 4326 16: 4297 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.40.0 5.11.16-arch1-1 LLVM 11.1.0) v: 4.6 Mesa 21.0.2 

Offline

#6 2021-04-23 10:56:38

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,132

Re: [solved] updated, now I have crazy artifacting


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#7 2021-04-23 17:37:47

croyleje
Member
Registered: 2020-05-05
Posts: 1

Re: [solved] updated, now I have crazy artifacting

hexdsl wrote:

Hey all.

I just ran an update and now i have CRAZY artifacting in most desktop applications. like all sorts of blocky popping. I do not enjoy it.

I am running an AMD GPU.
2 screens both via DP.

Anyone else having this?

Yes hexdsl,  I can verify the same issue started getting artifacts after the last mesa upgrade I can confirm that downgrading to mesa-21.0.2
did fix the issue.  I can also confirm there are reports in other sections of the forum and on other forums of people having similar issues.

I looked around for a place to submit a bug report but I have been unable to locate an appropriate place to do so if you come acorss one
please let me know.

Jason C.

Offline

#8 2021-04-23 18:30:37

draggingsnow
Member
Registered: 2020-09-16
Posts: 2

Re: [solved] updated, now I have crazy artifacting

It seems this update effected the 5600 to me, as I had the same issue.
mesa-git in the AUR fixed this issue for me, and haven't seen other cards get effected.

Offline

#9 2021-04-23 19:41:44

hexdsl
Member
Registered: 2015-02-08
Posts: 11

Re: [solved] updated, now I have crazy artifacting

thanks for feedback!

Downgraded and problem seems to have gone away. also looking to file bug report.

Thank you for answers! you were all GREAT! big_smile

Offline

#10 2021-04-24 10:04:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,132

Re: [solved] updated, now I have crazy artifacting

For those that don't realise it :

There are already bug reports in archlinux bug tracker and mesa issue tracker .
See post #6 for links to them.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB