You are not logged in.

#1 2021-05-02 05:43:09

hiraki01
Member
Registered: 2021-03-08
Posts: 4

Trackpad not working on ThinkPad T14 AMD after shutdown

Hello everyone,
I am encountering an issue that causes my trackpad to freeze after I shutdown and boot up again from Arch, although it is still working fine in Windows. However, when I boot Arch after having shutdown my laptop from Windows, the trackpad works again flawlessly. My trackpoint and external USB mouse are still working fine.
The freeze happens right after I start GDM (since I use GNOME). Starting any other window manager or DM doesn't help at all. Both Xorg and Wayland suffer from the same symptom.
The trackpad is still showing in libinput:

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event11
Group:            9
Seat:             seat0, default
Size:             100x68mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   flat *adaptive
Rotation:         n/a

I also tried upgrading the system as well as adding i8042.kbdreset=1 to /etc/default/grub but it still not working.
I installed Manjaro (just to check) and this issue is still happening there.

The specs of my laptop:

Model: ThinkPad T14 AMD 20UD0001CD
CPU: AMD Ryzen 5 PRO 4650U
Kernel: 5.11.6
BIOS: R1BET61W (1.30), 2020-12-21

Offline

#2 2021-05-11 18:47:18

drishal
Member
Registered: 2020-10-25
Posts: 15

Re: Trackpad not working on ThinkPad T14 AMD after shutdown

similar issue with my (Thinkpad) P14s, but slightly different way to replicate it:
1. shutdown the laptop, wait for a few mins
2. start it up again
the touchpad COMPLETELY stops working, even in the BIOS Itself after rebooting it to the BIOS
but if I again power down completely and then start it up the touchpad begins to work again
idk what is happening here

Last edited by drishal (2021-05-11 18:48:00)

Offline

Board footer

Powered by FluxBB