You are not logged in.

#1 2021-05-02 20:46:21

lu6fer
Member
Registered: 2020-01-18
Posts: 7

[solved] deepin pulseaudio

Hello,
Since last deepin update, I can't use it.

Desktop launch, but flicker and i'm unable to load any app.
From log I found an error related to pulseaudio, but pulseaudio has been replaced by pipewire from past update.

mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]: <warning> audio.go:198: failed to start pulseaudio via systemd: err: exit status 5, stderr: Failed to start pulseaudio.service: Unit pulseaudio.service not found.
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]: <warning> audio.go:212: failed to start pulseaudio via `pulseaudio --start`: err: exec: "pulseaudio": executable file not found in $PATH, stderr:
mai 02 22:31:54 maupiti daemon/audio[8244]: audio.go:198: failed to start pulseaudio via systemd: err: exit status 5, stderr: Failed to start pulseaudio.service: Unit pulseaudio.service not found.
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]: <warning> module.go:85: failed to start pulseaudio: cmd `pulseaudio --start` error: exec: "pulseaudio": executable file not found in $PATH
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]: <error> loader.go:155: enable module audio failed: failed to start pulseaudio: cmd `pulseaudio --start` error: exec: "pulseaudio": executable file not found in $PATH, cost 14.969>
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]:   ->  global.go:71
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]:   ->  daemon.go:206
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]:   ->  main.go:227
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]:   ->  proc.go:225
mai 02 22:31:54 maupiti com.deepin.dde.daemon.Dock[8244]:   ->  asm_amd64.s:1371
mai 02 22:31:54 maupiti daemon/audio[8244]: audio.go:212: failed to start pulseaudio via `pulseaudio --start`: err: exec: "pulseaudio": executable file not found in $PATH, stderr:
mai 02 22:31:54 maupiti daemon/audio[8244]: module.go:85: failed to start pulseaudio: cmd `pulseaudio --start` error: exec: "pulseaudio": executable file not found in $PATH
mai 02 22:31:54 maupiti daemon/loader[8244]: loader.go:155: enable module audio failed: failed to start pulseaudio: cmd `pulseaudio --start` error: exec: "pulseaudio": executable file not found in $PATH, cost 14.969823ms
                                               ->  global.go:71
                                               ->  daemon.go:206
                                               ->  main.go:227
                                               ->  proc.go:225
                                               ->  asm_amd64.s:1371

if someone have any idea why ?
Thank in advance

Last edited by lu6fer (2021-05-02 21:50:59)

Offline

#2 2021-05-02 21:05:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,021

Re: [solved] deepin pulseaudio

pipewire is only a hard requirement for pulseeffects, if deepin hard requires pulseaudio, then remove pulseeffects and the pipewire-{pulse,media-session,alsa} packages and install pulseaudio again. If you want to reuse pulseeffects install https://aur.archlinux.org/packages/pulseeffects-legacy/

Last edited by V1del (2021-05-02 21:06:39)

Offline

#3 2021-05-02 21:50:32

lu6fer
Member
Registered: 2020-01-18
Posts: 7

Re: [solved] deepin pulseaudio

Thanks, that's work.
But the thing I don't explain is, pulseeffect was never install on this computer.,and the migration to pipewire was an arch update.

Offline

Board footer

Powered by FluxBB