You are not logged in.

#1 2021-05-03 05:36:19

Registered: 2021-05-03
Posts: 1

Dual boot Arch + Windows 10, GRUB does not load

Hello, I am new to using Arch and this is my first time attempting dual boot for Windows 10 and Arch.

I am trying to set up Arch dual boot with Windows 10. I am currently using a ThinkPad Carbon X1 6th Gen.

I followed the installation instructions as per the general installation guide + the GRUB installation guide on the Wiki exactly, and everything for the general installation went smoothly, except for the GRUB installation.

After following the instructions on the Wiki, for some reason, after reboot, the system skips GRUB and goes directly into Windows 10.

Right now I am only able to access the partitions I created for Arch via the USB I flashed with the iso.

I mounted the EFI System partition onto /mnt/efi, and did the GRUB installation after chroot-ing into /mnt.

Right now my lsblk looks like this after chroot-ing into /mnt (I have shortened the output as I'm using another computer to type this)

nvme0n1          ... disk
 | - nvme0n1p1 ... part /efi
 | - nvme0n1p2 ... part
 | - nvme0n1p3 ... part
 | - nvme0n1p4 ... part /
 ` - nvme0n1p5 ... part

/dev/nvme0n1p1 is the EFI system partition, /dev/nvme0n1p4 is the main partition containing the file system which I have mounted at /mnt, and /dev/nvme0n1p5 is the swap.

This is what is inside my /mnt/efi

  | - Boot
  | - GRUB
  `-  Microsoft
'System Volume Information'

This is what is inside my /mnt/boot


I have tried moving the GRUB folder from esp/EFI to the root of the partition as per suggested in the troubleshooting section of GRUB in the Arch wiki, however this did not work.

I really am not sure why this is happening, I have tried purging and reinstalling GRUB onto the EFI system part and on the arch partition I created but no matter what I do, the system always skips and goes directly to Windows 10. Did I accidentally miss something during installation?

Edit: Just adding cause I missed this out, I did use efibootmgr to switch the boot order to have GRUB ahead of windows, but for some reason the system still goes straight to Windows 10

Last edited by ricenice99 (2021-05-03 06:22:29)


#2 2021-05-03 06:54:53

Registered: 2015-03-17
Posts: 134

Re: Dual boot Arch + Windows 10, GRUB does not load

Its a windows 10 issue: … boot_order
But as always described in the wonderful Arch wiki


Board footer

Powered by FluxBB