You are not logged in.

#1 2021-05-03 19:53:03

JustSomeGeek
Member
From: Scotland
Registered: 2018-08-13
Posts: 38

Wrong UUID on EFI partition?

Hey folks,

No Idea how I managed this, but I re-installed Arch (for practice, learning, fun, and to remove all crap in one hit). Now I have a system that does not boot automatically, and the EFI partition isn't recognised.

It's FAT32, has ESP and BOOT flags set, and is 100M. Filesystem tree seems OK too, and if I use the machine's built-in EFI Shell, I can navigate to grub manually and start it with no issues.

The partition isn't showing up in the system's UEFI boot menu, or listed in the "BIOS" as an option either.
The only thing I can see is that the UUID is not C12A7328-F81F-11D2-BA4B-00A0C93EC93B

# /dev/sde1
UUID=37AE-C96A                              /boot/efi           vfat    rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro   0 2

grub-install seems to have work ok, and I dont recall any errors from efibootmgr

Is there an easy way to change the UUID and/or partition type manually, without data loss, or have I missed something?

Offline

#2 2021-05-03 20:39:57

loqs
Member
Registered: 2014-03-06
Posts: 13,292

Re: Wrong UUID on EFI partition?

C12A7328-F81F-11D2-BA4B-00A0C93EC93B is the UUID assigned to the EFI system Partition under GPT.
the following will show the difference:

# lsblk -o +UUID,PARTUUID,PTUUID

Offline

#3 2021-05-03 21:08:12

JustSomeGeek
Member
From: Scotland
Registered: 2018-08-13
Posts: 38

Re: Wrong UUID on EFI partition?

loqs wrote:

C12A7328-F81F-11D2-BA4B-00A0C93EC93B is the UUID assigned to the EFI system Partition under GPT.
the following will show the difference:

# lsblk -o +UUID,PARTUUID,PTUUID

Definitely the wrong UUID. fdsisk does show it as an EFI System partition though

Offline

#4 2021-05-03 21:19:58

JustSomeGeek
Member
From: Scotland
Registered: 2018-08-13
Posts: 38

Re: Wrong UUID on EFI partition?

Ah, gotcha! I see what you mean. The GUID is what it should be. Looks like I misunderstood, sorry! Still no close to working out why I can't boot though. But thanks for highlighting my stupidity! :-D

Offline

Board footer

Powered by FluxBB