You are not logged in.

#1 2021-05-03 20:47:51

embmicro
Member
Registered: 2014-07-30
Posts: 23

[Solved] gnome-terminal doesn't work after upgrade

After doing an upgrade, gnome-terminal won't launch anymore.

Running it in xterm tells me it can't find the shared library libicuuc.so.68.

This makes sense as I have version 69 installed.

I have version 3.40.1-1 of gnome-terminal and 69.1-1 of icu and lib32-icu.

I've updated my mirror list and tried updating everything again but with the same result.

I've also checked my locale is properly set still to en_US.UTF-8

Is the gnome-terminal package just lagging behind or did I mess something up?

Thanks for any help!

Last edited by embmicro (2021-05-06 14:24:52)

Offline

#2 2021-05-03 21:36:58

loqs
Member
Registered: 2014-03-06
Posts: 13,681

Re: [Solved] gnome-terminal doesn't work after upgrade

See the Links to so-names section of of https://archlinux.org/packages/extra/x8 … -terminal/ 3.40.1-1 does not link to libicuuc.so.68.
Try using lddtree from pax-utils to find what is linking to libicuuc.so.68.

Offline

#3 2021-05-06 14:24:35

embmicro
Member
Registered: 2014-07-30
Posts: 23

Re: [Solved] gnome-terminal doesn't work after upgrade

Thanks! I realized it wasn't being used directly from the package page but didn't know about lddtree to figure out more.

I was able to track it down to having vte-git installed instead of vte3 and vte-common. Installing the non-AUR packages fixed the problem.

Thanks for the help!

Offline

Board footer

Powered by FluxBB