You are not logged in.

#1 2021-05-04 11:21:54

Marvix
Member
Registered: 2013-10-08
Posts: 117

[SOLVED] Setting default application

These days I made some maintenance and some changes occurred, which I cannot understand how to repair.

With desktop search software like catfish, calling to open folders from them, starts another software instead my file manager, PCManFM.

I searched to Arch Wiki, but I can't understand what to do.

Desktop Environment: None
Window Manager: OpenBox
File Manager: PCManFM

Last edited by Marvix (2021-05-04 11:59:01)

Offline

#2 2021-05-04 11:32:18

SzzS
Member
From: Hungary
Registered: 2020-08-14
Posts: 4

Re: [SOLVED] Setting default application

Take a look for this:

~/.config/mimeapps.list

Offline

#3 2021-05-04 11:58:01

Marvix
Member
Registered: 2013-10-08
Posts: 117

Re: [SOLVED] Setting default application

The solution came lately in the article File manager functionality#Directories are not opened in the file manager.

I used the following command to query which software is used.

$ xdg-mime query default inode/directory

and I got the below

org.xfce.Catfish.desktop

which is catfish, the same software I mentioned and starts when I open I directory.

Solution

Setting PCManFM as the directory file manager

$ xdg-mime default pcmanfm.desktop inode/directory

Offline

#4 2021-05-04 12:29:05

Flemur
Member
Registered: 2012-05-24
Posts: 47

Re: [SOLVED] Setting default application

Another way to fix that is, in pcmanfm, rt-click on a directory -> open with pcmanfm, set it as default, then you get a line like the below in ~/..config/mimeapps.list:

inode/directory=pcmanfm.desktop;

"If you do not change direction, you may end up where you are heading." -- L.T.

Offline

Board footer

Powered by FluxBB