You are not logged in.

#1 2021-05-04 01:17:54

keiichiiownsu12
Member
Registered: 2019-04-16
Posts: 41

AX200 wifi no longer detected by system

During a recent session, my internet connection abruptly terminated. After a quick reboot, connection is not being established. It turns out, ip addr is only showing the lo (loopback) device.

The AX200 card is not listed under lspci (it was previously).

$ lspci | grep -i ax200

Returns nothing

Neither systemctl nor dmesg are returning messages related to wireless devices or iwlwifi (the firmware for the intel AX200).

In order to confirm if the card was working or not, I booted into Windows (I have a linux dual boot). No networks were reachable (I am within range of many access points). I checked Window's Device Manager, under wireless devices to see if the card was listed. The AX200 was not listed.

Does this confirm that the component is "dead"?

Last edited by keiichiiownsu12 (2021-05-04 11:14:48)


I, uh, nevermind

Offline

#2 2021-05-04 06:01:27

seth
Member
Registered: 2012-09-03
Posts: 20,525

Re: AX200 wifi no longer detected by system

lspci confirms the card

device is not even detectable in windows device manager

…?

Checking systemctl and dmesg gives no error

Please post the dmesg and the output of "lspci -k"

Also see the 3rd link in my signature. Wireless chip issues because uf an undetermined state because of an ongoing S4 are kinda common.

Offline

#3 2021-05-04 14:40:22

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,728

Re: AX200 wifi no longer detected by system

Compare the version numbers reported by pacman -Q linux  and by uname -a

Do they match?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#4 2021-05-09 00:28:11

keiichiiownsu12
Member
Registered: 2019-04-16
Posts: 41

Re: AX200 wifi no longer detected by system

ewaller wrote:

Compare the version numbers reported by pacman -Q linux  and by uname -a

Do they match?

When I checked, both were version 5.11.16.arch1-1. Unfortunately I have already updated to 5.12.1.

The AX200 is now working: (1) lspci lists the card, (2) Microsoft Windows Device Manager lists the card, and (3) Wifi/bluetooth is working in both OSes. The problem "fixed itself" without any intervention of mine...which makes me think the hardware may be faulty...

Last edited by keiichiiownsu12 (2021-05-09 01:25:58)


I, uh, nevermind

Offline

#5 2021-05-09 00:33:31

loqs
Member
Registered: 2014-03-06
Posts: 13,303

Re: AX200 wifi no longer detected by system

Offline

#6 2021-05-09 01:28:17

keiichiiownsu12
Member
Registered: 2019-04-16
Posts: 41

Re: AX200 wifi no longer detected by system

Thanks! It seems the most recent kernel update might of fixed the issue.

What I don't understand is, if this was an issue with the kernel, why was it affecting the device in Windows? (i.e. if it was a linux kernel issue, why wasn't the device working in windows...)


I, uh, nevermind

Offline

#7 2021-05-09 06:20:23

seth
Member
Registered: 2012-09-03
Posts: 20,525

Re: AX200 wifi no longer detected by system

why was it affecting the device in Windows? (i.e. if it was a linux kernel issue, why wasn't the device working in windows...)

3rd link in my signature…

Offline

#8 2021-05-10 07:56:05

nunopenim
Member
From: Portugal
Registered: 2021-03-06
Posts: 19

Re: AX200 wifi no longer detected by system

Interestingly enough, as I own the same exact card, the only issues I had was when I ran Windows on my machine (I have never ran windows as dual boot, as I am not a dual boot fan, so it was single boot). It would bluescreen sometimes if I was downloading a game on steam or just watching a 1080p video, and I never understood why. Looks like windows is messing up again.


Check my GitHub here: github.com/nunopenim

I apologize in advance if some of my comments or replies don't make any sense. I am currently dealing with a bit of an alcohol problem, and I might be drunk at the time! Sorry and thank you for understanding!

Offline

Board footer

Powered by FluxBB