You are not logged in.

#1 2021-05-04 00:02:54

joecool169
Member
Registered: 2021-05-03
Posts: 9

[SOLVED] Having Trouble Setting Nvidia Fan Speed

Edit- see how I fixed everything at the bottom - marked solved

I saw a post or 2 that indicate this might be a bug? If I open my terminal and type nvidia-settings -a "[gpu:0]/GPUFanControlState=1" then the output is:

Attribute 'GPUFanControlState' (archvm:0[gpu:0]) assigned value 1.

But when I run nvidia-settings -a "[fan:0]/GPUTargetFanSpeed=50" I get:

ERROR: Error assigning value 50 to attribute 'GPUTargetFanSpeed' (archvm:0[fan:0]) as specified in assignment '[fan:0]/GPUTargetFanSpeed=50' (Unknown Error).

If I try to set the fan speed in the nvidia-settings gui I get: Failed to set new Fan Speed!

I'm using Arch in a VM and the GPU is an RTX3090. The nvidia driver version is 465.27

I read in a place or 2 that downgrading the driver might fix this?

Also I wondered if this is the sort of problem that can be avoided by running the LTS kernal?

Last edited by joecool169 (2021-05-08 16:31:56)

Offline

#2 2021-05-04 05:41:34

waliworld
Member
Registered: 2015-12-16
Posts: 12

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

I think this issue is more about nvidia's 465.27 driver. I was able to downgrade it and I got fan control back.

get the packages from the Arch Linux Archive

You could store them in /var/cache/pacman/pkg/ but anyway just make sure you're in the same directory and run something like this:

 pacman -U lib32-nvidia-utils-460.67-1-x86_64.pkg.tar.zst nvidia-utils-460.67-1-x86_64.pkg.tar.zst nvidia-dkms-460.67-1-x86_64.pkg.tar.zst

I was using nvidia-dkms but the procedure is basically the same for the non-dkms package.

this worked for me on 2 different machines with both the current standard and zen kernels.

Offline

#3 2021-05-04 06:06:21

seth
Member
Registered: 2012-09-03
Posts: 20,418

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

I'm using Arch in a VM

PCI passthrough, https://wiki.archlinux.org/title/PCI_pa … h_via_OVMF ?
If not, do you seriously expect a virtual client to be able to control thermal settings that will affect the host and all other VMs?
If yes, did you flash the VBIOS? (And please DO NOT jump to the conclusion that you somehow should)

I read in a place or 2

I particular?

Online

#4 2021-05-04 10:09:03

sunaurus
Member
Registered: 2016-12-22
Posts: 3

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

I've seen this issue reported at a few places:

https://forums.developer.nvidia.com/t/4 … set/175640
https://github.com/NVIDIA/nvidia-settings/issues/63

Sorry if this is a dumb question, but does anybody know if it makes sense to report a clearly upstream bug like this in the arch bug tracker for the nvidia package as well?

Edit: I see now that an issue was already opened and closed: https://bugs.archlinux.org/task/70515

Last edited by sunaurus (2021-05-04 10:12:57)

Offline

#5 2021-05-04 13:12:13

joecool169
Member
Registered: 2021-05-03
Posts: 9

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

waliworld wrote:

I think this issue is more about nvidia's 465.27 driver. I was able to downgrade it and I got fan control back.

get the packages from the Arch Linux Archive

You could store them in /var/cache/pacman/pkg/ but anyway just make sure you're in the same directory and run something like this:

 pacman -U lib32-nvidia-utils-460.67-1-x86_64.pkg.tar.zst nvidia-utils-460.67-1-x86_64.pkg.tar.zst nvidia-dkms-460.67-1-x86_64.pkg.tar.zst

I was using nvidia-dkms but the procedure is basically the same for the non-dkms package.

this worked for me on 2 different machines with both the current standard and zen kernels.

Once I downgrade the package will it try to update again when I update the system? Or how does that work?

Offline

#6 2021-05-04 13:13:38

joecool169
Member
Registered: 2021-05-03
Posts: 9

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

seth wrote:

I'm using Arch in a VM

PCI passthrough, https://wiki.archlinux.org/title/PCI_pa … h_via_OVMF ?
If not, do you seriously expect a virtual client to be able to control thermal settings that will affect the host and all other VMs?
If yes, did you flash the VBIOS? (And please DO NOT jump to the conclusion that you somehow should)

I read in a place or 2

I particular?

PCI Passthrough - yes

Flash vbios? - I dumped the vbios and passed the file through using the xml code?

Offline

#7 2021-05-04 13:45:53

seth
Member
Registered: 2012-09-03
Posts: 20,418

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

No, that'd actually be flashing the BIOS on the GPU - but do not do that
It's far more likely the 465 driver which causes quite a lot of problems.

Online

#8 2021-05-04 23:12:40

joecool169
Member
Registered: 2021-05-03
Posts: 9

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

So after the downgrade I am unable to startx

NVIDIA: Failed to initialize the NVIDIA kernel module

Edit to add that the message is in the xorg log file and I'm using bspwm if that matters.

Last edited by joecool169 (2021-05-04 23:13:37)

Offline

#9 2021-05-05 06:22:12

seth
Member
Registered: 2012-09-03
Posts: 20,418

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

If you didn't switch to dkms, the kernel module doesn't match your kernel.

Online

#10 2021-05-05 06:31:13

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,698

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

When downgrading you will want to use nvidia-dkms instead of the normal nvidia package so that the necessary module rebuild can happen on a newer kernel and make sure to have linux-headers for your current kernel installed.

Edit: Shit.

Last edited by V1del (2021-05-05 06:32:16)

Offline

#11 2021-05-05 22:47:44

joecool169
Member
Registered: 2021-05-03
Posts: 9

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

sudo pacman -U lib32-nvidia-utils-460.67-1-x86_64.pkg.tar.zst

loading packages...
resolving dependencies...
warning: cannot resolve "lib32-zlib", a dependency of "lib32-nvidia-utils"
warning: cannot resolve "lib32-libglvnd", a dependency of "lib32-nvidia-utils"
:: The following package cannot be upgraded due to unresolvable dependencies:
      lib32-nvidia-utils


Edit, oh, maybe I just need to install the dependencies like normal with -S?
If that's the case idk what dependencies are needed - still reading

Last edited by joecool169 (2021-05-05 22:50:57)

Offline

#12 2021-05-05 23:45:06

joecool169
Member
Registered: 2021-05-03
Posts: 9

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

It seems like the lib32-nvidia-utils was not needed since I already had nvidia-utils

Offline

#13 2021-05-06 06:59:06

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,698

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

IT will be needed as soon as you launch a 32bit program but if it can't resolve these packages you likely never had multilib enabled in the first place.

Offline

#14 2021-05-06 06:59:23

seth
Member
Registered: 2012-09-03
Posts: 20,418

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

lib32-nvidia-utils will be required for 32bit binaries, notably steam.

Edit: fuck. the word is "fuck" … tongue

Last edited by seth (2021-05-06 07:00:30)

Online

#15 2021-05-06 08:03:40

sunaurus
Member
Registered: 2016-12-22
Posts: 3

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

Another workaround instead of downgrading nvidia is to run Xorg as root: https://github.com/NVIDIA/nvidia-settin … -832921061

Offline

#16 2021-05-08 16:30:50

joecool169
Member
Registered: 2021-05-03
Posts: 9

Re: [SOLVED] Having Trouble Setting Nvidia Fan Speed

I want to thank everyone for the help and the suggestions. I learned a few things here and got my issue resolved. I would also like to list the exact steps I took to get nvidia fan speed to work properly. Keep in mind I am a newbie and the exact steps I took may not have been the exact right steps but it did work for me, so maybe this will help someone else.

1 - I decided to go with waliworld's suggestion and downgrade the packages.

2 - I read the Arch Wiki about package downgrades.

3 - after trying the NVIDIA packages I took seth's advice and downloaded the nvidia-dkms-460.67-1-x86_64.pkg.tar.zst , nvidia-settings-460.67-1-x86_64.pkg.tar.zst , and nvidia-utils-460.67-1-x86_64.pkg.tar.zst from https://archive.archlinux.org/ and moved them to: /var/cache/pacman/pkg

4 - maybe not required but I removed my old nvidia package "sudo pacman -R nvidia" I think the command was.

5 - from the directory /var/cache/pacman/pkg I ran "sudo pacman -U nvidia-dkms-460.67-1-x86_64.pkg.tar.zst" and the other 2 packages as well

6 reboot and all worked

7 added the packages to the ignore list - for me vim /etc/pacman.conf ...
un-comment IgnorePkg  = and add nvidia-dkms nvidia-settings nvidia-utils  so my line looks like this:

IgnorePkg  = nvidia-dkms nvidia-settings nvidia-utils

After saving I ran a sudo pacman -Syu to make sure the packages were ignored.

Side note - since then occasionally my system will hang with a flashing cursor on shutdown or reboot. The problem is intermittent and I am not sure if it is related to what I did here. But after doing some reading and watching a couple YouTube videos I think I may try to downgrade my kernel

I will mark this thread [SOLVED]

Thanks again everyone!!!

Offline

Board footer

Powered by FluxBB