You are not logged in.

#1 2021-05-10 08:02:04

osahinoglu
Member
Registered: 2021-05-10
Posts: 4

python2-gimp is broken

Hi,

python2-gimp (2.10.24-1) AUR package is trying to download perl-libwww-6.53-1-any.pkg.tar.zst and get 404 Not Found. perl-libwww-6.54-1-any.pkg.tar.zst is the package in the repo right now.

Offline

#2 2021-05-10 08:23:10

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,067

Re: python2-gimp is broken

That means your sync database is out of date, update your system before attempting to install AUR packages.

Offline

#3 2021-05-11 09:39:37

osahinoglu
Member
Registered: 2021-05-10
Posts: 4

Re: python2-gimp is broken

Thank you very much for your quick response.

I did db update. Now I'm getting the following after run "paru -S python2-gimp"

:: Resolving dependencies...
error: could not find all required packages:
    libglade (wanted by: python2-gimp -> pygtk)

Offline

#4 2021-05-11 10:28:23

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,507

Re: python2-gimp is broken

Looks like libglade was removed from repos (maybe in the recent spring cleaning ?) and not yet uploaded to AUR.

See https://aur.archlinux.org/packages/pygt … ent-806768


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#5 2021-05-11 11:37:39

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 223

Re: python2-gimp is broken

Why do you need python2-gimp? I recently found myself on the same situation regarding libglade and I ended up realizing that I don't need it. You can check what depends on it with `pacman -Qi python2-gimp`

Offline

#6 2021-05-11 12:03:42

osahinoglu
Member
Registered: 2021-05-10
Posts: 4

Re: python2-gimp is broken

I installed resynthesizer plugin to Gimp. But I couldn't see it in the menu. When I searched the internet, I found that python3 deployed with linux default may not be compatible with the plugin, python2-gimp package is for that and solves the problem. Because of that I tried to install python2-gimp and ended up here. smile

Offline

#7 2021-05-11 12:27:11

progandy
Member
Registered: 2012-05-17
Posts: 4,560

Re: python2-gimp is broken

According to https://github.com/bootchk/resynthesizer/issues/88 you can try an alpha/beta quality port:
Edit: That might not work with 2.10, only the 3.0 dev version (2.99)

https://github.com/bootchk/resynthesize … precations with https://github.com/bootchk/GimpFu-v3

Edit: At this moment you can still install the missing packages from the arch linux archive and use python2-gimp. (I just tested it) There is no guarantee that won't break in the future and you might have to add the packages to the AUR and recompile them.

Last edited by progandy (2021-05-11 12:35:27)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#8 2021-05-12 07:49:25

osahinoglu
Member
Registered: 2021-05-10
Posts: 4

Re: python2-gimp is broken

Thank you very much for your support

Offline

Board footer

Powered by FluxBB