You are not logged in.

#1 2021-05-13 15:15:44

Phydoux65
Member
Registered: 2020-04-03
Posts: 15

3 errors during update

I tried running pacman -Syu last night. It downladed the files but after the integrity check I get these 3 errors.

error: runc: signature from "Morten Linderud <morten@linderud.pw>" is marginal trust
:: File /var/cache/pacman/pkg/runc-1.0.0rc94-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: containerd: signature from "Morten Linderud <morten@linderud.pw>" is marginal trust
:: File /var/cache/pacman/pkg/containerd-1.5.0-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: remmina: signature from "Sergej Pupykin <arch@sergej.pp.ru>" is marginal trust
:: File /var/cache/pacman/pkg/remmina-1:1.4.14-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

I looked at some of the solutions at https://bbs.archlinux.org/viewtopic.php?id=233480 and was unable to correct the issue.
Any ideas how to fix this?

Offline

#2 2021-05-13 15:20:32

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,872

Re: 3 errors during update

If you use [testing] you're expected to subscribe and read the arch-dev-public mailing list

Offline

#3 2021-05-13 16:03:00

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,498
Website

Re: 3 errors during update

I'm going to assume arojas is correct, and these issues are due to the pulled gnupg update. However, if you're not using testing, and your gnupg package is at 2.2.27-1, please file a report to have the topic moved back.

Mod note: Moving to testing.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2021-05-13 18:56:56

Phydoux65
Member
Registered: 2020-04-03
Posts: 15

Re: 3 errors during update

WorMzy wrote:

I'm going to assume arojas is correct, and these issues are due to the pulled gnupg update. However, if you're not using testing, and your gnupg package is at 2.2.27-1, please file a report to have the topic moved back.

Mod note: Moving to testing.

In case anyone else is looking for an answer to this problem, I had to boot the ISO, mount the appropriate partitions and then run

pacman -S gpgme gnupg

. This fixed my updating issues. At arojas' suggestion, I've subscribed to the arch-dev-public mailing list as well.

Thanks for the pointers arojas and WorMzy.

Offline

Board footer

Powered by FluxBB