You are not logged in.

#1 2021-05-14 23:14:34

Registered: 2021-05-14
Posts: 2

dual boot : can't boot into arch after first reboot

I'm using Lenovo ideaPad s940-14WL. I've installed arch along side windwos using the arch wiki guide but after I reboot the system for the first time it boots straight to windows and the grub boot entry is gone. I can't boot back to my arch installation,
this also happend when I tried to dual boot with Manjaro and when I used a diffrent bootloader other than grub.
I installed grub using the following line:

grub-install --target=x86_64-efi --efi-directory=/efi/ --bootloader-id=GRUB

I have the following partitions:
dev/nvme0n1p1  - efi System for windows and arch
dev/nvme0n1p2  - Microsoft reserved
dev/nvme0n1p3  - Microsoft basic data
/dev/nvme0n1p4- windwos recovery environment
dev/nvme0n1p5 - linux swap
dev/nvme0n1p6 - linux file system

efibootmgr -v


BootCurrent: 0094
Timeout: 0 seconds 
BootOrder : 0094 , 0014 , 0017 , 0095 , 0097 , 0096 
Boot0010 Setup FvFile
Boot0011  Boot Menu 
Boot 0012 Diagnostic splash
Boot0013 Regulartory Information 
Boot014* USB FDD:
Boot0017 USB CD:
Boot0096* NVMe venMSg
Boot0098* USB HDD:
Boot0099* USB LAN:

thanks in advance smile


#2 2021-05-14 23:17:20

Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,746

Re: dual boot : can't boot into arch after first reboot

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles


#3 2021-05-16 21:09:00

Registered: 2021-05-14
Posts: 2

Re: dual boot : can't boot into arch after first reboot

I've tried to run the following grub-install:

grub-install --target=x86_64-efi --efi-directory=/efi --bootloader-id=GRUB --removable

and than I created a grub-config file using the following command :

 grub-mkconfig -o /boot/grub/grub.cfg

it does'nt seem to even create  a boot entry in the first place.
Am I doing something wrong?

Last edited by dht2003 (2021-05-17 16:19:59)


Board footer

Powered by FluxBB