You are not logged in.

#1 2021-03-27 14:19:57

ledbettj
Member
From: Atlanta
Registered: 2012-10-14
Posts: 34
Website

[Solved] ffmpeg Failed to initialize encoder: ABI version mismatch

ffmpeg is not able to produce a webm file using libvpx.  Here's what I see:

$ ffmpeg -loglevel debug -i source.mp4 temp.webm
# ... normal stuff
[libvpx-vp9 @ 0x5621adaedec0] v1.10.0
[libvpx-vp9 @ 0x5621adaedec0] --prefix=/usr --disable-install-docs --disable-install-srcs --enable-pic --enable-postproc --enable-runtime-cpu-detect --enable-shared --enable-vp8 --enable-vp9 --enable-vp9-highbitdepth --enable-vp9-temporal-denoising
[libvpx-vp9 @ 0x5621adaedec0] vpx_codec_enc_cfg
[libvpx-vp9 @ 0x5621adaedec0] generic settings
  g_usage:                      0
  g_threads:                    8
  g_profile:                    0
  g_w:                          320
  g_h:                          240
  g_bit_depth:                  8
  g_input_bit_depth:            8
  g_timebase:                   {1/30}
  g_error_resilient:            0
  g_pass:                       0
  g_lag_in_frames:              25
[libvpx-vp9 @ 0x5621adaedec0] rate control settings
  rc_dropframe_thresh:          0
  rc_resize_allowed:            0
  rc_resize_up_thresh:          60
  rc_resize_down_thresh:        30
  rc_end_usage:                 0
  rc_twopass_stats_in:          (nil)(0)
  rc_target_bitrate:            256
[libvpx-vp9 @ 0x5621adaedec0] quantizer settings
  rc_min_quantizer:             0
  rc_max_quantizer:             63
[libvpx-vp9 @ 0x5621adaedec0] bitrate tolerance
  rc_undershoot_pct:            25
  rc_overshoot_pct:             25
[libvpx-vp9 @ 0x5621adaedec0] temporal layering settings
  ts_number_layers:             1
[libvpx-vp9 @ 0x5621adaedec0] 
  layer_target_bitrate:         0 0 0 0 0 
[libvpx-vp9 @ 0x5621adaedec0] 
  ts_rate_decimator:            0 0 0 0 0 
[libvpx-vp9 @ 0x5621adaedec0] 
  ts_periodicity:               0
[libvpx-vp9 @ 0x5621adaedec0] 
  ts_layer_id:                  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
[libvpx-vp9 @ 0x5621adaedec0] decoder buffer model
  rc_buf_sz:                    6000
  rc_buf_initial_sz:            4000
  rc_buf_optimal_sz:            5000
[libvpx-vp9 @ 0x5621adaedec0] 2 pass rate control settings
  rc_2pass_vbr_bias_pct:        50
  rc_2pass_vbr_minsection_pct:  0
  rc_2pass_vbr_maxsection_pct:  2000
[libvpx-vp9 @ 0x5621adaedec0]   rc_2pass_vbr_corpus_complexity:0
[libvpx-vp9 @ 0x5621adaedec0] keyframing settings
  kf_mode:                      1
  kf_min_dist:                  0
  kf_max_dist:                  128
[libvpx-vp9 @ 0x5621adaedec0] 
[libvpx-vp9 @ 0x5621adaedec0] Neither bitrate nor constrained quality specified, using default CRF of 32
[libvpx-vp9 @ 0x5621adaedec0] vpx_codec_enc_cfg
[libvpx-vp9 @ 0x5621adaedec0] generic settings
  g_usage:                      0
  g_threads:                    16
  g_profile:                    0
  g_w:                          720
  g_h:                          720
  g_bit_depth:                  8
  g_input_bit_depth:            8
  g_timebase:                   {1/24}
  g_error_resilient:            0
  g_pass:                       0
  g_lag_in_frames:              25
[libvpx-vp9 @ 0x5621adaedec0] rate control settings
  rc_dropframe_thresh:          0
  rc_resize_allowed:            0
  rc_resize_up_thresh:          60
  rc_resize_down_thresh:        30
  rc_end_usage:                 3
  rc_twopass_stats_in:          (nil)(0)
  rc_target_bitrate:            256
[libvpx-vp9 @ 0x5621adaedec0] quantizer settings
  rc_min_quantizer:             0
  rc_max_quantizer:             63
[libvpx-vp9 @ 0x5621adaedec0] bitrate tolerance
  rc_undershoot_pct:            25
  rc_overshoot_pct:             25
[libvpx-vp9 @ 0x5621adaedec0] temporal layering settings
  ts_number_layers:             1
[libvpx-vp9 @ 0x5621adaedec0] 
  layer_target_bitrate:         0 0 0 0 0 
[libvpx-vp9 @ 0x5621adaedec0] 
  ts_rate_decimator:            0 0 0 0 0 
[libvpx-vp9 @ 0x5621adaedec0] 
  ts_periodicity:               0
[libvpx-vp9 @ 0x5621adaedec0] 
  ts_layer_id:                  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
[libvpx-vp9 @ 0x5621adaedec0] decoder buffer model
  rc_buf_sz:                    6000
  rc_buf_initial_sz:            4000
  rc_buf_optimal_sz:            5000
[libvpx-vp9 @ 0x5621adaedec0] 2 pass rate control settings
  rc_2pass_vbr_bias_pct:        50
  rc_2pass_vbr_minsection_pct:  0
  rc_2pass_vbr_maxsection_pct:  2000
[libvpx-vp9 @ 0x5621adaedec0]   rc_2pass_vbr_corpus_complexity:0
[libvpx-vp9 @ 0x5621adaedec0] keyframing settings
  kf_mode:                      1
  kf_min_dist:                  0
  kf_max_dist:                  128
[libvpx-vp9 @ 0x5621adaedec0] 
[libvpx-vp9 @ 0x5621adaedec0] Failed to initialize encoder: ABI version mismatch
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
[AVIOContext @ 0x5621adb09e80] Statistics: 0 seeks, 0 writeouts
[libopus @ 0x5621adb09680] 1 frames left in the queue on closing
[AVIOContext @ 0x5621adae2600] Statistics: 1842727 bytes read, 1 seeks
Conversion failed!

It has no problem generating a mkv, mov, mp4 or any other type of output.

Here's what I think are the related packages that are installed

$ pacman -Q | grep -E '(ffmpeg|libvpx|gst)'
clutter-gst 3.0.27-3
ffmpeg 2:4.3.2-3
gst-editing-services 1.18.4-1
gst-libav 1.18.4-1
gst-plugin-gtk 1.18.4-1
gst-plugin-pipewire 1:0.3.24-1
gst-plugins-bad 1.18.4-3
gst-plugins-bad-libs 1.18.4-3
gst-plugins-base 1.18.4-1
gst-plugins-base-libs 1.18.4-1
gst-plugins-good 1.18.4-1
gstreamer 1.18.4-1
gstreamer-vaapi 1.18.4-1
lib32-gst-plugins-base-libs 1.18.4-1
lib32-gstreamer 1.18.4-1
lib32-libvpx1.3 1.3.0-2
libvpx 1.10.0-1
libvpx1.3 1.3.0-3

I've tried reinstalling all of the above, but no luck.  Any suggestions on how to debug further?

Last edited by ledbettj (2021-03-27 15:17:12)

Offline

#2 2021-03-27 14:40:45

progandy
Member
Registered: 2012-05-17
Posts: 4,333

Re: [Solved] ffmpeg Failed to initialize encoder: ABI version mismatch

ffmpeg might have to be recompiled with the new libvpx.

$ CUTF pacman -Si ffmpeg libvpx | grep -e Name -e Date
Name            : ffmpeg
Build Date      : 2021-03-18 W11-4 11:48:43 +0100
Name            : libvpx
Build Date      : 2021-03-25 W12-4 08:41:05 +0100

Last edited by progandy (2021-03-27 14:42:03)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2021-03-27 15:16:28

ledbettj
Member
From: Atlanta
Registered: 2012-10-14
Posts: 34
Website

Re: [Solved] ffmpeg Failed to initialize encoder: ABI version mismatch

Sounds like it should be reported to the ffmpeg packager, then?  I confirmed downgrading libvpx to 1.9 from August 2020 works.

Thank you!

Offline

#4 2021-06-05 23:45:58

Hubro
Member
Registered: 2019-03-09
Posts: 16

Re: [Solved] ffmpeg Failed to initialize encoder: ABI version mismatch

I'm still getting this error: "ABI version mismatch"

Did anybody report this anywhere? If so I would love a link to the issue so I can follow it.

Offline

#5 2021-06-06 00:56:46

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,582

Re: [Solved] ffmpeg Failed to initialize encoder: ABI version mismatch

This was fixed long ago. What version of the ffmpeg package do you have?

Offline

Board footer

Powered by FluxBB