You are not logged in.

#1 2021-06-07 16:16:15

z0mb1e_kgd
Member
Registered: 2020-11-10
Posts: 10

[SOLVED] Pacman not installing / updating packages (404 error)

The whole thing started like a half a year ago, when pacman started throwing 404 errors on random package downloads, thus halting the whole package installation / update process. Executing pacman -Syyu, changing the mirrors in the /etc/pacman.d/mirrorlist never solved it, though it eventually went off in a couple of days, emerging on random other packages here and there.

Digging the issue, I've realized the requested package file was always version-wise older than its updated counterpart on the server (mirror): i.e. pacman requested mesa-21.1.1-1-x86_64.pkg.tar.zst as per recently updated official extra repository (pacman -Syy mesa) vs. mesa-21.1.2-1-x86_64.pkg.tar.zst located on the mirror, so the problem is that the repo is out-of-date rather than mirrors (vice versa would be totally understandable, as official repos are more or less centralized contrary to the decentralized mirror network), thus requesting the older version (already removed from the mirror in lieu of the more recent version) expectedly throws an 404 File Not Found error.

Is there any explanation to this issue, and is there any way to fix it?

UPDATE:
Solution: comment out the top evowise server, it is the cause.

Last edited by z0mb1e_kgd (2021-06-07 17:50:21)

Offline

#2 2021-06-07 16:21:15

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,781

Re: [SOLVED] Pacman not installing / updating packages (404 error)

Do not use -Syyu unless there is a very good reason.  Use -Syu. 

Post your /etc/pacman.conf


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2021-06-07 16:26:21

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,582

Re: [SOLVED] Pacman not installing / updating packages (404 error)

And your current mirrorlist

Offline

#4 2021-06-07 16:43:56

z0mb1e_kgd
Member
Registered: 2020-11-10
Posts: 10

Re: [SOLVED] Pacman not installing / updating packages (404 error)

Offline

#5 2021-06-07 16:46:01

z0mb1e_kgd
Member
Registered: 2020-11-10
Posts: 10

Re: [SOLVED] Pacman not installing / updating packages (404 error)

/etc/pacman.d/mirrorlist

https://pastebin.com/BhSvMAaJ

Offline

#6 2021-06-07 16:49:12

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,582

Re: [SOLVED] Pacman not installing / updating packages (404 error)

So you're using the evowise mirror, which has come up a few times as having problems. That's likely the root of your issue.

Offline

#7 2021-06-07 16:57:30

z0mb1e_kgd
Member
Registered: 2020-11-10
Posts: 10

Re: [SOLVED] Pacman not installing / updating packages (404 error)

Here is the pacman error output (in Russian though, but I hope the patterns are still recognizable):

pacman -S xf86-video-nouveau xf86-video-intel
разрешение зависимостей...
проверка конфликтов...
предупреждение: обнаружена циклическая зависимость:
предупреждение: libglvnd будет установлен перед mesa, как зависимость

Пакеты (27) libdrm-2.4.106-1  libedit-20210419_3.1-1  libglvnd-1.3.3-1  libomxil-bellagio-0.9.3-3  libpciaccess-0.16-2  libunwind-1.5.0-1  libx11-1.7.1-1
            libxau-1.0.9-3  libxcb-1.14-1  libxdamage-1.1.5-3  libxdmcp-1.1.3-3  libxext-1.3.4-3  libxfixes-6.0.0-1  libxshmfence-1.3-2  libxvmc-1.0.12-3
            libxxf86vm-1.1.4-4  llvm-libs-11.1.0-1  lm_sensors-1:3.6.0.r41.g31d1f125-1  mesa-21.1.1-1  pixman-0.40.0-1  vulkan-icd-loader-1.2.176-1
            wayland-1.19.0-1  xcb-proto-1.14.1-3  xcb-util-0.4.0-3  xorgproto-2021.4-1  xf86-video-intel-1:2.99.917+916+g31486f40-1
            xf86-video-nouveau-1.0.17-1

Будет загружено:     19,53 MiB
Будет установлено:  215,62 MiB

:: Приступить к установке? [Y/n]
:: Получение пакетов...
libx11-1.7.1-1-x86_64.pkg.tar.zst failed to download
mesa-21.1.1-1-x86_64.pkg.tar.zst failed to download
Total (2/2)                                                        19,5 MiB  4,78 MiB/s 00:04 [########################################################] 100%
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirrors.evowise.com : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirrors.evowise.com : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirror.rackspace.com : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirror.rackspace.com : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirror.rackspace.com : HTTP server doesn't seem to support byte ranges. Cannot resume.
предупреждение: too many errors from mirror.rackspace.com, skipping for the remainder of this transaction
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirror.rackspace.com : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirror.rol.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirror.rol.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirror.rol.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
предупреждение: too many errors from mirror.rol.ru, skipping for the remainder of this transaction
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirror.rol.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirror.yandex.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirror.yandex.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
ошибка: не удалось получить файл 'mesa-21.1.1-1-x86_64.pkg.tar.zst' из mirror.yandex.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
предупреждение: too many errors from mirror.yandex.ru, skipping for the remainder of this transaction
ошибка: не удалось получить файл 'libx11-1.7.1-1-x86_64.pkg.tar.zst' из mirror.yandex.ru : HTTP server doesn't seem to support byte ranges. Cannot resume.
предупреждение: не удалось получить некоторые файлы
ошибка: не удалось завершить транзакцию (ошибка в библиотеке загрузки)
Обнаружены ошибки, пакеты не обновлены.

The "HTTP server doesn't seem to support byte ranges. Cannot resume." error is erroneously thrown due to the recent pacman version requesting files with the initial offset for some reason, but it is still 404 under the hood (seen via changing Xferd to curl or wget).

Offline

#8 2021-06-07 17:04:21

z0mb1e_kgd
Member
Registered: 2020-11-10
Posts: 10

Re: [SOLVED] Pacman not installing / updating packages (404 error)

Scimmia wrote:

So you're using the evowise mirror, which has come up a few times as having problems. That's likely the root of your issue.

The majority of other mirrors output the same result, regardless of country and update status. Exploring the file tree on each mirror shows the issue I mentioned in the post - the package version on the mirror is newer than specified in the repo. Maybe there is a way to change official repo sync servers?

Offline

#9 2021-06-07 17:05:47

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,582

Re: [SOLVED] Pacman not installing / updating packages (404 error)

The top mirror is the only one that matters

Offline

#10 2021-06-07 17:46:20

z0mb1e_kgd
Member
Registered: 2020-11-10
Posts: 10

Re: [SOLVED] Pacman not installing / updating packages (404 error)

Scimmia wrote:

The top mirror is the only one that matters

Guess you were right! I've commented out the top evowise server, updated the repos db, and the packages got downloaded.
Many thanks. Will mark thread as solved.

Offline

Board footer

Powered by FluxBB