You are not logged in.

#1 2021-02-28 00:12:52

Shino
Member
Registered: 2015-02-01
Posts: 61

PC doesn't power-off after shutdown. Fans keep spinning

Hi,

I've got a PC with an AsRock Fatal1ty Z170 K6 Mainboard and an i7-6700K CPU.
I've been using this PC for many years now. Arch is the onyl system installed on my machine.

I have 2 NVMe SSDs and 1 HDD connected. That's all. I use the internal GPU in the i7.

Today my PC started with a weird behavior: When I power down Arch, everything goes as it should. I hear the familiar "click" of the HDD shutting down and the last message on the screen is "Reached system power off" (or something similar). After that, video output blanks.
However, the Fans and LEDs on the mainboard stay on. I tried pressing the reset button and the power button but they had no effect. The only way to power off the system is to cut the electricity.

Restarting my system behaves as it should.

Next, I tried booting the Arch Linux Live stick using UEFI boot as this is the boot mode I use for my regular system. After the stick has booted, I type: "poweroff" and it shuts down and completely powers off.
Currently I don't have another system at hand to test the PC.

Does anyone have an idea what could be the problem?
I haven't done any changes to the BIOS or kernel recently.

After my tests, I reset my UEFI using the on board CMOS clear button. After that, my EFI bootloader wasn't found and I had to reinstall it using the live stick (grub-install). Now I'm back where I started: My system works, however after shutdown, the power isn't switched off.
"poweroff" on the live stick still works.

Any ideas?

EDIT:
I've put in the SSD of my Laptop and it had no problems powering off the PC. After an upgrade (pacman -Syu), this installation won't shutdown either.

Last edited by Shino (2021-03-01 18:06:47)

Offline

#2 2021-03-01 21:16:55

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 578

Re: PC doesn't power-off after shutdown. Fans keep spinning

You've not really mentioned what you are running normally and how you are shutting down.
For instance you may be logging in graphically, logging out to a login screen and shutting down from there, or shutting down directly from a desktop session, or logging in as root on the console tty and shutting down.

A few things come to mind...
- as you say "Today my PC started with a weird behavior", then a package upgrade might be causing the issue if it worked correctly beforehand: check your pacman.log to see what has been recently upgraded
- make sure your system is fully up to date
- try the linux-lts kernel
- https://wiki.archlinux.org/index.php/Sy … ribly_long
- https://wiki.archlinux.org/index.php/Sy … management

Cheers
Paul

Offline

#3 2021-03-01 22:02:03

Shino
Member
Registered: 2015-02-01
Posts: 61

Re: PC doesn't power-off after shutdown. Fans keep spinning

Thanks for your answer,

It doesn't matter, how I shut down my pc. I tried "poweroff", "systemctl poweroff" from console. Also I tried the poweroff button in Gnome3. All lead to the same effect: The system is shut down properly, but the power is not cut. Even the reset switch is not working in this state.

As you've suggested, I installed the LTS kernel and updated my grub config.
With the LTS kernel, the problem is gone smile

I wonder how I can somehow get to the root of this problem, so I can file a bug report. I googled a lot and so far I haven't found anyone with the same problem with the current kernel version. Do you know how to get more detailed information about this problem? The logs don't show anything. The system powers down normally.

Offline

#4 2021-03-02 16:01:26

paulkerry
Member
From: Sheffield, UK
Registered: 2014-10-02
Posts: 578

Re: PC doesn't power-off after shutdown. Fans keep spinning

So it's a kernel issue and you will have recently updated your kernel package.
Some options...
1 - search the kernel changelogs for anything relevant to your situation
2 - you could try finding a kernel version that works and the next version up that doesn't, maybe using locally saved cached kernel package files or failing that, packages from the ALA - https://wiki.archlinux.org/index.php/Arch_Linux_Archive
3 - kernel bisect - https://wiki.archlinux.org/index.php/Bi … s_with_Git
4 - keep using the linux-lts kernel and hope someone else reports and fixes it

For options 1-3, if you work out what causes the issue you can report it upstream.

Good luck!
Regards
Paul.

Last edited by paulkerry (2021-03-02 16:02:58)

Offline

#5 2021-06-10 02:34:23

crazyquark
Member
Registered: 2021-06-10
Posts: 1

Re: PC doesn't power-off after shutdown. Fans keep spinning

I have the same issue, but on Manjaro, mind you. I am running kernel 5.12.
I should say that Windows is able to power off everything fine smile.

Going back to kernel 5.11 and 5.10(LTS) did not help.
I am thinking it must be something userspace related, because I used to run 5.10 without problems a while back. Or it might be a module.

Last edited by crazyquark (2021-06-10 03:12:06)

Offline

#6 2021-06-10 05:58:14

zegkljan
Member
Registered: 2017-12-30
Posts: 47

Re: PC doesn't power-off after shutdown. Fans keep spinning

Hello, I'd like to chip in my experience as well. I have the same problem - the system almost shuts down but does not power off, a cursor keeps blinking in the top left corner. However, I can reboot using the Alt+SysRq+B shortcut. When the system reboots, I can power off from the GDM login screen no problem. Also, when I log in to Gnome and power off right away, it also works. So I have the suspicion it indeed is something other then kernel itself. The last message in the kernel log is

systemd-shutdown[1]: Sending SIGTERM to remaining processes...

but this is also the case when the system powers off normally, so...

Offline

#7 2021-06-10 06:25:03

seth
Member
Registered: 2012-09-03
Posts: 21,101

Re: PC doesn't power-off after shutdown. Fans keep spinning

Edit: @crazyquark

Same hardware?
Do you also see "Reached system power off"?

Windows is able to power off

3rd link below is *very* relevant here.

One could try to lie to the BIOS/UEFI - try passing

acpi_osi=! acpi_osi="Windows 2012"

to the kernel, https://wiki.archlinux.org/title/Kernel_parameters (try the bootloader commandline before adding such thing permanently)

--------

If your problems only occur when trying to shutdown from an active session, you're more likely to fall into
https://bbs.archlinux.org/viewtopic.php?pid=1976837
https://bbs.archlinux.org/viewtopic.php?pid=1976346
though they seemed plasma related.

Last edited by seth (2021-06-10 06:28:48)

Online

Board footer

Powered by FluxBB