You are not logged in.

#1 2021-06-10 11:21:26

ArchHippo
Member
Registered: 2021-06-10
Posts: 2

[SOLVED] Wi-fi not working Asus VivoBook L410MA rtw_8821ce

I downloaded and installed Arch yesterday (archlinux-2021.06.01-x86_64.iso)

5.12.9-arch1-1 #1 SMP PREEMPT Thu, 03 Jun 2021 11:36:13 +0000 x86_64 GNU/Linux

Whilst afaik the driver is loading, it doesn't appear to work, and I don't get an interface

[    3.545672] rtw_8821ce 0000:02:00.0: Firmware version 24.8.0, H2C version 12
[    3.591370] rtw_8821ce 0000:02:00.0: enabling device (0000 -> 0003)
[    3.945647] rtw_8821ce 0000:02:00.0: rfe 4 isn't supported
[    3.945870] rtw_8821ce 0000:02:00.0: failed to setup chip efuse info
[    3.945872] rtw_8821ce 0000:02:00.0: failed to setup chip information
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
    DeviceName: WLAN
    Subsystem: AzureWave Device 3040
    Flags: fast devsel, IRQ 23
    I/O ports at e000 [size=256]
    Memory at a1100000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel modules: rtw88_8821ce

lspci -s $(lspci | grep RTL88 | cut -b -7) -nk
02:00.0 0280: 10ec:c821
    DeviceName: WLAN
    Subsystem: 1a3b:3040
    Kernel modules: rtw88_8821ce

I have seen similar reports in other places.  Has anyone had any success with this laptop?  Is it just a case of waiting for support to be implemented?  If so, is there any way to know if it's being worked on? I am using a USB wi-fi for now, but obviously would much prefer to use the onboard.

Thanks for any suggestions.

Last edited by ArchHippo (2021-06-11 16:03:11)

Offline

#2 2021-06-11 11:36:27

opensorcerer
Member
From: Germany
Registered: 2021-06-05
Posts: 12

Re: [SOLVED] Wi-fi not working Asus VivoBook L410MA rtw_8821ce

Offline

#3 2021-06-11 14:37:40

ArchHippo
Member
Registered: 2021-06-10
Posts: 2

Re: [SOLVED] Wi-fi not working Asus VivoBook L410MA rtw_8821ce

Many thanks for replying.  It worked.  smile

Offline

Board footer

Powered by FluxBB