You are not logged in.

#1 2021-06-09 18:10:02

potuz
Member
Registered: 2009-10-23
Posts: 60

[SOLVED] youcompleteme hangs vim

After installing YouCompleteMe on a fresh system vim hangs on startup. It is unresponsive for minutes. I can actually type and eventually characters will come in. But it still lags for minutes. Removing the Youcompleme Bundle solves the issue. I can't really provide details since the installation was standard following the github repo and no errors were reported. top does not show any CPU hog nor memory hog. So I am puzzled. Is this some known issue?

Last edited by potuz (2021-06-15 08:55:02)

Offline

#2 2021-06-10 15:30:55

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,204

Re: [SOLVED] youcompleteme hangs vim

I do not use vim, but a short look at the wiki tells me thats this could be quite normal.

arch-Wiki article wrote:

Troubleshooting
Remember that it might take some time for YouCompleteMe to generate a list of completion strings.

The following commands are available for diagnostics:

:messages - show previous errors or messages from Vim
:YcmDiags
:YcmDebugInfo

Offline

#3 2021-06-10 15:35:47

potuz
Member
Registered: 2009-10-23
Posts: 60

Re: [SOLVED] youcompleteme hangs vim

That's not it, the hang happens on empty unnamed files where ycm should not be running

Offline

#4 2021-06-15 08:54:33

potuz
Member
Registered: 2009-10-23
Posts: 60

Re: [SOLVED] youcompleteme hangs vim

Solved this, it was that my firewall is too restrictive and was dropping the local connections to the server. It would be good to know if the port(s) that YouCompleteMe uses are stable so as to not have to punch the firewall for this user.

Offline

Board footer

Powered by FluxBB