You are not logged in.

#1 2021-06-10 21:10:10

semiletov
Member
Registered: 2021-06-10
Posts: 2

guitarix update

Good morning,
I filled the bug about this, but the bug was closed as "not a bug".
Today, during the update of the system (using yay -Syu), the process was interrupted with
":: unable to satisfy dependency 'libboost_iostreams.so=1.75.0-64' required by guitarix".
So, I removed guitarix (yay -R guitarix) and then update went ok.
But now I cannot install guitarix, it constantly reports about "unable to satisfy dependency 'libboost_iostreams.so=1.75.0-64'".
My mirrorlist is ok, and I suppose that yay/pacman uses the first line from the list (http://archlinux.thaller.ws/$repo/os/).
I am a newbie with Arch (two weeks use Arch as my main OS), and don't know how to solve this riddle...

Offline

#2 2021-06-10 21:26:03

seth
Member
Registered: 2012-09-03
Posts: 23,877

Re: guitarix update

https://archlinux.org/packages/communit … /guitarix/ depends on libboost_iostreams.so=1.76.0-64
The mirror was likely not fully synced, consider using reflector - https://wiki.archlinux.org/title/Reflector

pacman -Syu guitarix

will then likely succeed.

Online

#3 2021-06-11 09:18:21

semiletov
Member
Registered: 2021-06-10
Posts: 2

Re: guitarix update

Thank you, Reflector helped with the situation!

Offline

#4 2021-06-11 12:05:11

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,720

Re: guitarix update

Please remember to mark your thread [SOLVED] (edit the title of your first post).

Offline

Board footer

Powered by FluxBB