You are not logged in.

#1 2021-06-11 14:01:18

Sesar54
Member
Registered: 2019-10-14
Posts: 2

[SOLVED] pamixer stopped working after latest update

Looks like pamixer is lagging behind boost-libs. Running it with any arguments results in the same output:
`pamixer: error while loading shared libraries: libboost_program_options.so.1.75.0: cannot open shared object file: No such file or directory`

boost-libs has been updated to 1.76.0-1.

Here is snippets of `pacman -Q --info` from the 2 packages installed on my machine.

Name            : pamixer
Version         : 1.4-5
Depends On      : libpulse  boost-libs
Packager        : Felix Yan <felixonmars@archlinux.org>
Build Date      : Sat 12 Dec 2020 05:00:28 PM CET
Install Date    : Fri 11 Jun 2021 03:33:49 PM CEST

Name            : boost-libs
Version         : 1.76.0-1
Provides        : libboost_atomic.so=1.76.0-64  libboost_chrono.so=1.76.0-64  libboost_container.so=1.76.0-64  libboost_context.so=1.76.0-64
                  libboost_contract.so=1.76.0-64  libboost_coroutine.so=1.76.0-64  libboost_date_time.so=1.76.0-64  libboost_fiber.so=1.76.0-64
                  libboost_filesystem.so=1.76.0-64  libboost_graph.so=1.76.0-64  libboost_graph_parallel.so=1.76.0-64  libboost_iostreams.so=1.76.0-64
                  libboost_json.so=1.76.0-64  libboost_locale.so=1.76.0-64  libboost_log.so=1.76.0-64  libboost_log_setup.so=1.76.0-64
                  libboost_math_c99.so=1.76.0-64  libboost_math_c99f.so=1.76.0-64  libboost_math_c99l.so=1.76.0-64  libboost_math_tr1.so=1.76.0-64
                  libboost_math_tr1f.so=1.76.0-64  libboost_math_tr1l.so=1.76.0-64  libboost_mpi.so=1.76.0-64  libboost_numpy39.so=1.76.0-64
                  libboost_prg_exec_monitor.so=1.76.0-64  libboost_program_options.so=1.76.0-64  libboost_python39.so=1.76.0-64  libboost_random.so=1.76.0-64
                  libboost_regex.so=1.76.0-64  libboost_serialization.so=1.76.0-64  libboost_stacktrace_addr2line.so=1.76.0-64
                  libboost_stacktrace_basic.so=1.76.0-64  libboost_stacktrace_noop.so=1.76.0-64  libboost_system.so=1.76.0-64  libboost_thread.so=1.76.0-64
                  libboost_timer.so=1.76.0-64  libboost_type_erasure.so=1.76.0-64  libboost_unit_test_framework.so=1.76.0-64  libboost_wave.so=1.76.0-64
                  libboost_wserialization.so=1.76.0-64
Depends On      : bzip2  zlib  icu  zstd
Required By     : boost  ceph-libs  clucene  eclib  libcmis  libetonyek  libixion  libphonenumber  librevenge  lucene++  pamixer  source-highlight
Packager        : Evangelos Foutras <foutrelis@archlinux.org>
Build Date      : Tue 08 Jun 2021 05:17:32 PM CEST
Install Date    : Fri 11 Jun 2021 03:36:20 PM CEST

Now I don't know what the usual procedure is for reporting dependency version error is. Can someone help?

Last edited by Sesar54 (2021-06-11 15:59:47)

Offline

#2 2021-06-11 14:09:10

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,687

Re: [SOLVED] pamixer stopped working after latest update

The latest version of pamixer is 1.4-6, so it's only lagging behind on your system. Make sure your entire system is up to date and see if a different mirror fixes it.

Last edited by Scimmia (2021-06-11 14:13:52)

Offline

#3 2021-06-11 15:58:11

Sesar54
Member
Registered: 2019-10-14
Posts: 2

Re: [SOLVED] pamixer stopped working after latest update

Im closing this issue as it's seams to be an issue with my own mirrors.

Offline

Board footer

Powered by FluxBB