You are not logged in.

#1 2021-06-15 05:52:42

octokraken
Member
Registered: 2021-06-15
Posts: 2

[SOLVED] Install fails with 1 GiB RAM and 25 GiB disk with cloud-init

/run/archiso/bootmnt /run/archiso/cowspace, /run/archiso/airootfs and / are all full when cloud-init runs, and cloud-init fails with No Space Left on Device.
When I intsall the same on a VM of the same size where cloud-init doesn't get run, it works fine (though I have to install manually)

Is there a way to disable cloud-init on boot?

Last edited by octokraken (2021-06-15 14:09:06)

Offline

#2 2021-06-15 14:05:53

octokraken
Member
Registered: 2021-06-15
Posts: 2

Re: [SOLVED] Install fails with 1 GiB RAM and 25 GiB disk with cloud-init

I was able to disable cloud-init adding cloud-init=disabled to the kernel command line.  So I am going to be able to to a manual install.  I am curious to know how much RAM it takes for a successful cloud-init install.  If anyone knows this it would be good to have that documented for the system requirements on the download page for the ISO.

Offline

#3 2021-06-16 13:22:28

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,458

Re: [SOLVED] Install fails with 1 GiB RAM and 25 GiB disk with cloud-init

You're referring to the cloud image mentioned in the arch-boxes readme ?

Can't find any system requirements for cloud-init, even in their own documentation https://cloudinit.readthedocs.io/en/latest/ .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB