You are not logged in.

#1 2021-06-17 09:49:33

Hidasi Mate
Member
Registered: 2021-06-16
Posts: 3

[SOLVED]pacstrap fails during Arch install

I'm installing Arch linux on a Lenovo Thinkpad T60 I use a Lan cabel for internet  and I generated a mirrorlist with reflector (http and https protocols and sorted by download speed)
Arch is my first distro and I don't know what's important so I wrote down everything.
I ran trough the installatuon guide using Bios and after pacstrap failed several times with wifi due to the mirrors not responding I connected to the router with a Lan cabel and ran 'pacstrap /mnt base linux-zen linux-firmware' and it installed everything exept the audit-3.0.1-1-x86_64.pkg.tar.zst and gnupg-2.2.27-1-x86_64.pkg.tar.zs packages
I ran it a second time and the output after the proceed with installation question was:

::Retrieving packages...
audit-3.0.1-1-x86_64.pkg.tar.zst                                         380.3 KiB 4.64 MiB/s 00:00 [################################] 100%
gnupg-2.2.27-1-x86_64.pkg.tar.zs                                         2.4 MiB 22.7 MiB/s 00:00 [################################] 100%
Total (2/2)                                                                               2.8 MiB 10.3 MiB/s 00:00 [################################] 100%
error : failed retrieving file 'audit-3.0.1-1-x86_64.pkg.tar.zs' from mirrors.evowise.com : The requested URL returned error : 404
error : failed retrieving file 'gnupg-2.2.27-1-x86_64.pkg.tar.zs' from mirrors.evowise.com : The requested URL returned error : 404
(113/113) checking keys in keyring                                                                                  [################################] 100%
(113/113) checking package integrity                                                                               [################################] 100%
error: audit: signature from "Levente Polyak (anthraxx) <levente@levenetpolyak.net>" is invalid
:: File /mnt/var/cache/pacman/pkg/audit-3.0.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted (package signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no pacakges were upgraded.
==> Failed to install packages to new root
pacstrap /mnt base linux-zen linux-firmware 12,79s user 6.43 system 127% cpu 15.093 total

Last edited by Hidasi Mate (2021-06-23 07:20:35)

Offline

#2 2021-06-17 10:22:57

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,455
Website

Re: [SOLVED]pacstrap fails during Arch install

Please edit your post to use code tags.

https://gitlab.archlinux.org/archlinux/ … s-and-code
https://bbs.archlinux.org/help.php#bbcode

Why did you manually generate a mirrorlist with reflector, when that happens automatically anyway? What arguments did you use?


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2021-06-17 17:36:36

Rafael Castellar
Member
From: Brazil
Registered: 2017-05-11
Posts: 19

Re: [SOLVED]pacstrap fails during Arch install

I'm facing the same problem here. Need to format and reinstall my system and pacstrap is giving me this error.

corrupted (invalid or corrupted (package signature)).

I spent all the last day and today trying to fix with:

pacman-key --init
pacman-key --populate archlinux
pacman-lkey --refresh-keys

re-installing archlinux-keyring

But some of the packages generates this error. Don't know what to do.

Tks...

Rafael

Offline

#4 2021-06-17 17:56:48

Rafael Castellar
Member
From: Brazil
Registered: 2017-05-11
Posts: 19

Re: [SOLVED]pacstrap fails during Arch install

Ah, and I did not touched the mirrolist...  I tried with 2021-06-01 and 2021-05-01 imagens...both has the same situation.

Offline

#5 2021-06-18 06:41:44

Mr Victory
Member
Registered: 2021-06-10
Posts: 29

Re: [SOLVED]pacstrap fails during Arch install

Perhaps it is Evowise's fault? There are errors regarding Evowise in Hidasi Mate and Evowise is on top of the default mirrorlist so Rafael used that mirror too. Using reflector with "--country" options and ensuring that Evowise is not there may fix the issue.

Offline

#6 2021-06-19 09:04:29

Hidasi Mate
Member
Registered: 2021-06-16
Posts: 3

Re: [SOLVED]pacstrap fails during Arch install

WorMzy wrote:

Please edit your post to use code tags.

https://gitlab.archlinux.org/archlinux/ … s-and-code
https://bbs.archlinux.org/help.php#bbcode

Why did you manually generate a mirrorlist with reflector, when that happens automatically anyway? What arguments did you use?


I didn't know that it generates automatically and i used

$ reflector --country 'Hungary' --protocol http --protocol -https -sort rate -save /etc/pacman.d/mirrorlist

Offline

#7 2021-06-19 09:51:38

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,452

Re: [SOLVED]pacstrap fails during Arch install

--latest and/or --age are very useful additions when using reflector .

You have read https://wiki.archlinux.org/title/Reflector and its  manpage ?

Last edited by Lone_Wolf (2021-06-19 09:51:50)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB