You are not logged in.

#1 2021-06-28 15:12:10

toni
Member
Registered: 2011-10-15
Posts: 437

[SOLVED] grub-install: efibootmgr failed to registry the boot entry

I am trying to install Arch Linux from live iso into a virtualbox virtual machine.

My physical computer has secure boot disabled.
The configuration for my Arch Linux guest virtual machine has EFI unchecked (If I checked it then arch medium does not boot). The host is a Win 10 OS.

I have followed all the steps in the installation guide.
When I arrive at the end, trying to install a boot loader like GRUB and executing below command:

# grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB 

I get below message errors:

Installing for x86_64-efi platform
EFI variables are not supported on this system.
EFI variables are not supported on this system.
grub-install: error: efibootmgr failed to registry the boot entry: No such file or directory.

I have tried exit out from arch-chroot environment and then enable efivarfs:

exit
modprobe efivarfs

and then again arch-chrooted with arch-chroot /mnt and try again grub-install command but again the same errors.

Within arch-chroot environment I have launched:

efivar-tester

and its outputs continues being: UEFI variables are not supported on this system.

my boot partition in /dev/sda1 is formatted as FAT32 and mounted correctly.

What's happening?

Last edited by toni (2021-06-28 17:54:04)

Offline

#2 2021-06-28 15:28:45

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,671

Re: [SOLVED] grub-install: efibootmgr failed to registry the boot entry

If you have the EFI box unchecked, why are you following the UEFI instructions for installing things? You'll be using BIOS, not UEFI.

Offline

#3 2021-06-28 15:33:52

toni
Member
Registered: 2011-10-15
Posts: 437

Re: [SOLVED] grub-install: efibootmgr failed to registry the boot entry

Scimmia wrote:

If you have the EFI box unchecked, why are you following the UEFI instructions for installing things? You'll be using BIOS, not UEFI.

In fact I want to install it using UEFI not BIOS, but I do not know why but If I check EFI on virtualbox machine, arch iso is not being executed. Why?

How can I make archiso medium to be launched with EFI option checked?

In the arch linux installation guide, in section "Boot the live environment" it is said:

Tip: The installation image uses systemd-boot for booting in UEFI mode and syslinux for booting in BIOS mode.

So if I check EFI option in my virtualbox virtual machine, why arch medium is not booting?

Screenshots of virtualbox virutal machine configuration:

Motherboard settings
Storage settings

Last edited by toni (2021-06-28 15:46:50)

Offline

#4 2021-06-28 17:49:23

toni
Member
Registered: 2011-10-15
Posts: 437

Re: [SOLVED] grub-install: efibootmgr failed to registry the boot entry

This was happening because I booted arch medium in BIOS mode and I was trying to install new system as UEFI mode. My /dev/sda1 is an EFI partition and it was being mounted in /mnt/boot.
So when trying to execute below command it was failing:

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB 

and hence that below command:

efivar-tester

was outputing below result:

UEFI variables are not supported on this system

Also related to booting arch medium in UEFI mode when your new UEFI-based system has installed, see here .

Sorry, I made a mess between the both modes, BIOS and UEFI.

Last edited by toni (2021-06-28 17:51:44)

Offline

Board footer

Powered by FluxBB