You are not logged in.

#1 2021-06-20 13:56:56

7thSon
Member
Registered: 2017-05-07
Posts: 171

Bluetooth controller not available (Dell XPS 15 9500)

I have a new Dell XPS 15 9500 on which I can't seem to get the bluetooth controller to respond.
(Note that I did have the bluetooth working on this same machine on a previous installation of Arch which I had to reinstall due to other reasons)

I'm having trouble finding what's wrong with the bluetooth controller, the issue is this:

❯ bluetoothctl -- show
No default controller available

rfkill shows no problems:

❯ sudo rfkill list all
[sudo] password for user:
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

the bluetooth service also looks good to me:

❯ sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2021-06-20 15:28:56 CEST; 21min ago
       Docs: man:bluetoothd(8)
   Main PID: 1032 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38199)
     Memory: 1.9M
        CPU: 9ms
     CGroup: /system.slice/bluetooth.service
             └─1032 /usr/lib/bluetooth/bluetoothd

Jun 20 15:28:56 arch systemd[1]: Starting Bluetooth service...
Jun 20 15:28:56 arch bluetoothd[1032]: Bluetooth daemon 5.59
Jun 20 15:28:56 arch systemd[1]: Started Bluetooth service.
Jun 20 15:28:56 arch bluetoothd[1032]: Starting SDP server
Jun 20 15:28:56 arch bluetoothd[1032]: Bluetooth management interface 1.18 initialized

bluetooth packages installed:

❯ yay -Q | rg blue
blueman 2.1.4-1
bluez 5.59-2
bluez-libs 5.59-2
bluez-utils 5.59-2
pulseaudio-bluetooth 14.2-3

I'm not seeing what the actual problem is here, bluetooth service is working and rfkill is not blocking, but even then the bluetooth adapter just doesn't respond.
Am I missing a required package or something?

Perhaps unrelated but worth mentioning is that the wifi interface present in the laptop doesn't show up in the interface list:

❯ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
3: enp0s20f0u1u3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether a0:ce:c8:e7:5f:a4 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.81/24 brd 192.168.1.255 scope global dynamic noprefixroute enp0s20f0u1u3
       valid_lft 85250sec preferred_lft 74450sec
    inet6 fe80::b67a:16bb:1226:8de7/64 scope link
       valid_lft forever preferred_lft forever

The wifi interface was also available in the previous installation I had, so clearly I'm missing something now that I had then, but I'm not sure what that is.

UPDATE: I found this in the system logs:

❯ journalctl -b --grep=hci0
-- Journal begins at Fri 2021-06-18 15:42:41 CEST, ends at Sun 2021-06-20 16:18:23 CEST. --
Jun 20 16:09:52 arch kernel: Bluetooth: hci0: setting up ROME/QCA6390
Jun 20 16:09:54 arch kernel: Bluetooth: hci0: command 0xfc00 tx timeout
Jun 20 16:10:02 arch kernel: Bluetooth: hci0: Reading QCA version information failed (-110)
Jun 20 16:10:02 arch kernel: Bluetooth: hci0: Retry BT power ON:0
Jun 20 16:10:05 arch kernel: Bluetooth: hci0: command 0xfc00 tx timeout
Jun 20 16:10:13 arch kernel: Bluetooth: hci0: Reading QCA version information failed (-110)
Jun 20 16:10:13 arch kernel: Bluetooth: hci0: Retry BT power ON:1
Jun 20 16:10:15 arch kernel: Bluetooth: hci0: command 0xfc00 tx timeout
Jun 20 16:10:24 arch kernel: Bluetooth: hci0: Reading QCA version information failed (-110)
Jun 20 16:10:24 arch kernel: Bluetooth: hci0: Retry BT power ON:2
Jun 20 16:10:26 arch kernel: Bluetooth: hci0: command 0xfc00 tx timeout
Jun 20 16:10:34 arch kernel: Bluetooth: hci0: Reading QCA version information failed (-110)

Last edited by 7thSon (2021-06-20 20:14:41)

Offline

#2 2021-06-23 20:49:32

avanderbergh
Member
Registered: 2021-06-05
Posts: 3

Re: Bluetooth controller not available (Dell XPS 15 9500)

[Update] After updating to kernel 5.12.13 Bluetooth seems to be working again.

I'm having similar issues after updating to kernel 5.12.12 on a Dell XPS 17 9700.

Bluetooth service starts normally.

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; disabled; vendor preset: disabled)
     Active: active (running) since Wed 2021-06-23 22:36:26 CEST; 28s ago
       Docs: man:bluetoothd(8)
   Main PID: 1477 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38184)
     Memory: 2.3M
        CPU: 16ms
     CGroup: /system.slice/bluetooth.service
             └─1477 /usr/lib/bluetooth/bluetoothd

Jun 23 22:36:26 xps-17 systemd[1]: Starting Bluetooth service...
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Bluetooth daemon 5.59
Jun 23 22:36:26 xps-17 systemd[1]: Started Bluetooth service.
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Starting SDP server
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Bluetooth management interface 1.19 initialized
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSink/sbc
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSource/sbc

then after bluetoothctl power on, I get:

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; disabled; vendor preset: disabled)
     Active: active (running) since Wed 2021-06-23 22:36:26 CEST; 7min ago
       Docs: man:bluetoothd(8)
   Main PID: 1477 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38184)
     Memory: 2.3M
        CPU: 18ms
     CGroup: /system.slice/bluetooth.service
             └─1477 /usr/lib/bluetooth/bluetoothd

Jun 23 22:36:26 xps-17 systemd[1]: Starting Bluetooth service...
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Bluetooth daemon 5.59
Jun 23 22:36:26 xps-17 systemd[1]: Started Bluetooth service.
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Starting SDP server
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Bluetooth management interface 1.19 initialized
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSink/sbc
Jun 23 22:36:26 xps-17 bluetoothd[1477]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSource/sbc
Jun 23 22:44:12 xps-17 bluetoothd[1477]: Failed to set mode: Failed (0x03)

Here's the output of dmesg

[   18.765123] Bluetooth: hci0: setting up ROME/QCA6390
[   19.086786] Bluetooth: hci0: QCA Product ID   :0x00000010
[   19.086789] Bluetooth: hci0: QCA SOC Version  :0x400a0200
[   19.086790] Bluetooth: hci0: QCA ROM Version  :0x00000200
[   19.086791] Bluetooth: hci0: QCA Patch Version:0x00000d2b
[   19.086792] Bluetooth: hci0: QCA controller version 0x02000200
[   19.086793] Bluetooth: hci0: QCA Downloading qca/htbtfw20.tlv
[   19.962941] Bluetooth: hci0: QCA Downloading qca/htnv20.bin
[   20.166642] Bluetooth: hci0: QCA setup on UART is completed
[   47.758466] Bluetooth: hci0: QCA collecting dump of size:458752
[   47.811698] Bluetooth: hci0: QCA memdump unexpected packet 51
[   47.811707] Bluetooth: hci0: QCA memdump unexpected packet 36
[   48.039581] Bluetooth: hci0: QCA memdump unexpected packet 263
[   48.039592] Bluetooth: hci0: QCA memdump unexpected packet 248
[   48.325879] Bluetooth: hci0: QCA memdump unexpected packet 518
[   48.325889] Bluetooth: hci0: QCA memdump unexpected packet 503
[   48.577414] Bluetooth: hci0: QCA memdump unexpected packet 756
[   48.577424] Bluetooth: hci0: QCA memdump unexpected packet 741
[   48.761994] Bluetooth: hci0: QCA memdump unexpected packet 933
[   48.762004] Bluetooth: hci0: QCA memdump unexpected packet 918
[   49.378910] Bluetooth: hci0: QCA memdump unexpected packet 1506
[   49.378920] Bluetooth: hci0: QCA memdump unexpected packet 1491
[   49.399782] Bluetooth: hci0: QCA memdump unexpected packet 1522
[   49.399791] Bluetooth: hci0: QCA memdump unexpected packet 1507
[   49.540163] Bluetooth: hci0: QCA memdump unexpected packet 1650
[   49.540173] Bluetooth: hci0: QCA memdump unexpected packet 1635
[   49.750645] Bluetooth: hci0: QCA memdump Done, received 458752, total 458752

Last edited by avanderbergh (2021-06-26 14:00:44)

Offline

#3 2021-06-30 08:19:08

7thSon
Member
Registered: 2017-05-07
Posts: 171

Re: Bluetooth controller not available (Dell XPS 15 9500)

I also got the bluetooth device and service to work after updating to 5.12.13, but I couldn't switch over from the Headset profile to High Fidelity audio.
The audio in the headset mode was also broken, I started a youtube video and the audio was just chopping and lagging immensely, so I'm thinking there are still some bugs to iron out.

Offline

Board footer

Powered by FluxBB