You are not logged in.

#1 2021-07-01 17:10:35

xjwellsx
Member
From: Ohio
Registered: 2011-07-06
Posts: 9

Error when installing YAY

I get the following error when trying to install YAY:

go: github.com/Jguer/go-alpm/v2@v2.0.5: Get "https://proxy.golang.org/github.com/%21 … v2.0.5.mod": x509: certificate signed by unknown authority

I also had to add the flag --insecure to makepkg.conf while building another package from the AUR that used curl.

I have tried reinstalling the ca-certificate packages and that did not help.

Last edited by xjwellsx (2021-07-02 16:51:30)

Offline

#2 2021-07-02 16:45:27

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,266

Re: Error when installing YAY

I get the following error when trying to install YAY

Are you installing via the PKGBUILD? If so can you post the output of your makepkg?

Offline

#3 2021-07-02 16:50:44

xjwellsx
Member
From: Ohio
Registered: 2011-07-06
Posts: 9

Re: Error when installing YAY

makepkg -si

==> Making package: yay 10.2.3-1 (Fri 02 Jul 2021 10:20:39 AM EDT)

==> Checking runtime dependencies...

==> Checking buildtime dependencies...

==> Retrieving sources...

  -> Found yay-10.2.3.tar.gz

==> Validating source files with sha256sums...

    yay-10.2.3.tar.gz ... Passed

==> Extracting sources...

  -> Extracting yay-10.2.3.tar.gz with bsdtar

==> Removing existing $pkgdir/ directory...

==> Starting build()...

go build -trimpath -mod=readonly -modcacherw -tags six -ldflags '-X "main.yayVersion=10.2.3" -X "main.localePath=/usr/share/locale/" -linkmode=external' -buildmode=pie -o yay

go: github.com/Jguer/go-alpm/v2@v2.0.5: Get "https://proxy.golang.org/github.com/%21 … v2.0.5.mod": x509: certificate signed by unknown authority

make: *** [Makefile:112: yay] Error 1

==> ERROR: A failure occurred in build().

    Aborting...

Offline

Board footer

Powered by FluxBB