You are not logged in.

#1 2021-07-02 19:45:27

Pcornat
Member
Registered: 2021-07-02
Posts: 4

Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

Hello everyone,

Sorry for my english in advance if I make mistakes, I am french.

So, I bought a new headphone, the Sennheiser Momentum Wireless 3. It connects correctly in bluetooth with my laptop. Problem : no A2DP profile is available neither with pulseaudio or pipewire-pulse, only HSF/HDF.
I tried everything on the arch wiki and looking for issues on the pipwire's gitlab… Nothing. So if you need anything, just ask me.

I think the main problem is that the headset has a microphone and it would need to be disabled to perhaps make it work. But I do not know how to disable it, or that it is possible.

Thank you in advance.

Last edited by Pcornat (2021-07-02 19:46:16)

Offline

#2 2021-07-04 06:04:43

zyaku
Member
Registered: 2013-11-09
Posts: 5

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

Can confirm I'm having the same problem. This is the only other mention of it I could find online.

The Bluetooth device is a FiiO BTR5 amp. I got the classic "a2dp unavailable" bug with pulseaudio, and on pipewire the ad2p sink wasn't even an option (i.e. pactl only shows hsp/hfp sinks). This is on a desktop computer, using the onboard radio from an MSI motherboard. This radio appears to have an Intel chip. I tried all the troubleshooting steps from the wiki pages for pulseaudio, pipewire, and bluetooth audio, and I experimented with a couple of other pipewire settings as well. Might come down to doing a clean reinstall and seeing what happens.

The amp works with both my Pixel 3 phone and my Dell laptop running Arch Linux. The laptop is using pulseaudio and hasn't been updated in a week, but otherwise is configured essentially the same way as the desktop. On this laptop, it worked perfectly out of the box.

It's late here so I won't write more tonight, but I'll try to come back tomorrow and better document the things I've tried. I think I also have a usb dongle with the realtek chipset that the pipewire devs support, so I'll try that out as well.

I have to say, it's very frustrating putting up with these on and off Bluetooth problems. I've used Linux as my desktop OS for about 10 years now, and Bluetooth is one instance where I haven't seen much improvement in my user experience over the years. Not that there's much that can be done about it. Developing software for Bluetooth seems like a nightmare.

Offline

#3 2021-07-04 10:09:20

Alad
Wiki Admin/IRC Op
From: Bagelstan
Registered: 2014-05-04
Posts: 2,215
Website

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

Downgrade bluez to 5.58


Mods are just community members who have the occasionally necessary option to move threads around and edit posts. -- Trilby

Offline

#4 2021-07-04 16:01:44

Pcornat
Member
Registered: 2021-07-02
Posts: 4

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

I just downgraded bluez to 5.58 and it changed absolutely nothing. I am going to change back to pulseaudio to see if it works, on the contrary of pipewire…

Offline

#5 2021-07-04 16:10:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,805

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

After downgrading bluez remove /var/lib/bluetooth and re-pair your device. This is solely a bluez issue that swapping between pipewire and pulse will not have a relevant effect.

Offline

#6 2021-07-04 16:21:48

Pcornat
Member
Registered: 2021-07-02
Posts: 4

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

I already re-paired my device smile. Now, I tried with pulseaudio aaaand the profiles are marked as available in blueman applet, try switching : failed. Profiles in pavucontrol are marked as unavailable.
pactl show me all codecs but none available… I really do not know what to do anymore :'(

Offline

#7 2021-07-04 16:29:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,805

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

Did you remove the folder I mentioned before pairing again?

Offline

#8 2021-07-04 16:35:43

Pcornat
Member
Registered: 2021-07-02
Posts: 4

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

In the folder, there was not my headphones' mac address.
Now, in the journal, there is one error : Error opening PCM device front:0: device or resource busy.

EDIT : It refuses to change profiles by saying it is not connected… Profiles are available in blueman, pulseaudio, and it just does not want to change it for no f***ing reason ! >< If at least it would say why or getting a real error not just refusing, OK, but no, it's not, not all.

Last edited by Pcornat (2021-07-04 16:58:25)

Offline

#9 2021-07-05 09:15:40

zyaku
Member
Registered: 2013-11-09
Posts: 5

Re: Bluetooth headphones no A2DP on Pipewire-pulse/Pulseaudio

V1del wrote:

After downgrading bluez remove /var/lib/bluetooth and re-pair your device. This is solely a bluez issue that swapping between pipewire and pulse will not have a relevant effect.

Cheers, it worked! I could've sworn I tried these steps the other day, but guess not smile. I also confirmed that the regression is fixed in bluez-git (retrieved from the AUR), and works with both pipewire and pulseaudio. Thanks very much for the help.

Pcornat wrote:

I tried everything on the arch wiki and looking for issues on the pipwire's gitlab… Nothing. So if you need anything, just ask me.

When you downgraded bluez, did you downgrade bluez-utils and bluez-libs as well? Unless you're having a different issue than me, that's my only guess what might be wrong. In the interest of documentation, this is the precise series of steps that resolved my problem:

1. I ran these exact commands to stop bluetooth and remove the /var hierarchy.

$ sudo systemctl stop bluetooth.service
$ sudo rm -r /var/lib/bluetooth

2. Downgraded to bluez-5.58. I had to downgrade three packages: bluez, bluez-utils, and bluez-libs. This was the command to get them from my cache, although obviously this depends on having the same package versions in your cache:

$ sudo pacman -U /var/cache/pacman/pkg/bluez-5.58-1-x86_64.pkg.tar.zst  /var/cache/pacman/pkg/bluez-utils-5.58-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/bluez-libs-5.58-1-x86_64.pkg.tar.zst

Alternatively, you can install bluez-git from the AUR, which replaces all three packages.

3. Reboot and pair my device again.

It might be good to add something to the wiki about deleting /var/lib/bluetooth as a general troubleshooting step, but I've never edited the wiki before.

Offline

Board footer

Powered by FluxBB