You are not logged in.

#1 2021-07-11 03:04:01

themusicalduck
Member
Registered: 2011-07-04
Posts: 112

[SOLVED] Loud pops when nothing plays for a few seconds, pipewire.

EDIT:

For anyone finding this, the fix was to change session.suspend-timeout-seconds to be 0 in /etc/pipewire/media-session.d/alsa-monitor.conf

---------------

I'm using pipewire 1:0.3.31-1 with pipewire-pulse and Gnome. When I first switched to pipewire I had the problem described in the title where unpleasant clicks and pops would be happening all the time. I was able to fix it by uncommenting the line:

node.pause-on-idle      = false

in /etc/pipewire/media-session.d/alsa-monitor.conf

however recently the pops have come back again. I tried to disable powersaving on the kernel level by setting /sys/module/snd_hda_intel/parameters/power_save to 0 and adding a file in modprobe.d to make it permanent (I can verify the setting is made on boot). I also tried setting power_save_controller to N but neither of these settings have made a difference.

The pops only happen when my headphones are plugged in.

The soundcard I have is 00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20).

It happens regardless if I am on AC power or battery.

I tried to downgrade pipewire to 1:0.3.28 to see if it was something introduced in a newer version, but then I had no sound at all.

Is there anything else to try?

Thanks.

Last edited by themusicalduck (2021-07-14 16:59:13)

Offline

Board footer

Powered by FluxBB