You are not logged in.

#1 2021-06-04 23:07:10

Registered: 2012-04-21
Posts: 36

No suspend (s2idle only) on XP13 9310 ?

EDIT: I see that this is a common problem for new laptops, and that this may have something to do with a design decision by Microsoft. Anyway the questions stands if anyone has some additional information on this - I will add it to the arch XPS13 9310 wiki

Hello all,

I have a new Dell XPS 13 (9310) and I can't get the suspend to RAM working - systemd sends the laptop into an idle state. From what I gather here is the relevant information from the kernel suspend interface:

% cat /sys/power/state 
freeze mem disk
 % cat /sys/power/mem_sleep

From what I understand I should have "deep" in mem_sleep to indicate that the kernel supports suspend to RAM. Why is this option not present? I have checked the BIOS for any relevant options, but only found an option to block S3 suspend (which is toggled off by default - ie, permissive state).

Thank you for reading!

Additional info:

% uname -r

% inxi -G
Graphics:  Device-1: Intel Iris Xe Graphics driver: i915 v: kernel 
           Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: vesa 
           resolution: 3840x2400~60Hz 
           OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.1.1 

% sudo dmesg | grep -i acpi | grep supports
[    0.230566] ACPI: (supports S0 S4 S5)

Last edited by htedrom (2021-06-05 20:37:39)


#2 2021-07-12 16:23:07

Registered: 2012-09-06
Posts: 10

Re: No suspend (s2idle only) on XP13 9310 ?

I hope that Dell will update the firmware with the option to bring back S3 like Lenovo did.

I guess that's our only hope, other wise you could setup a swapfile and use hibernate..

I'm currently testing out how s2idle is doing for me.


#3 2021-11-11 08:03:01

From: Thane, Maharashtra, India
Registered: 2018-10-06
Posts: 14

Re: No suspend (s2idle only) on XP13 9310 ?

On exactly the same page as @htedrom with an option to "Block S3" in the BIOS but no "deep" sleep with that disabled. My /sys/power/mem_sleep reads the same as yours and I'm on an Alienware M15 R6, if that helps.

While hibernation looks like the only way to go, IRST (Intel Rapid Start Technology) looks pretty lucrative. Nonetheless, I infer from the Arch Wiki that it's left to the firmware to decide. All I see in the BIOS is an option to "Block S3" which, apparently, will also "block Intel Rapid start" as it reads. That is, there's no such option so as to change the IRST timer or specifically enable it.

Since I haven't touched the OEM Windows installation, which I presume uses IRST by default, why isn't my Arch Linux installation moving from s2idle to hibernation with IRST's help? Is there anything additional I need to do?


Board footer

Powered by FluxBB