You are not logged in.

#1 2021-07-12 20:12:00

Registered: 2021-07-12
Posts: 2

Asus Zenbook UX533fn - Laptop fan does not spin

I have recently installed arch on this laptop and everything is fine but the laptop fan. It does not spin at all. I have consulted the arch wiki on but have encountered difficulties at some stages where the outputs do not match anything from the guide or the troubleshooting part. I will detail my steps taken below.

# Fancontrol (lm-sensors)
- I ran "sensors-detect" and this was the summary

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `coretemp':
  * Chip `Intel digital thermal sensor' (confidence: 9)

Do you want to overwrite /etc/conf.d/lm_sensors? (YES/no): YES
Unloading i2c-dev... OK

- "sensors" show that the cpu_fan is running at 0 RPM

- "pwmconfig" gives an error stating:

/usr/bin/pwmconfig: There are no pwm-capable sensor modules installed

- I do not know how to proceed from this point on so I tried the NBFC section


- install was fine, however to use it from a new terminal I always have to "systemctl enable --now" which is strange. "nbfc config -r" recommended these laptop models:

Asus Zenbook UX530U
Asus Zenbook Pro UX550VE
Asus Vivobook S400CA
HP OMEN Notebook PC 15

- I tried applying each of these and the fans did not turn on even under load.

# ASUS Laptops

## asus-nb-wmi

- viewing the commands I tried changing to the directory .../hwmonX and viewing the contents, pwm1 is missing from the ls command, I tried echoing numbers to the pwm1_enable file since it is present but no difference was made

## asus_fan

- installing was fine but "modprobe asus_fan" returns this

modprobe: ERROR: could not insert 'asus_fan': No such device

- I have installed the package from the AUR so it should work if it is installed successfully, so I have no idea how to continue on with the guide.

Another thing I tried is to boot into windows first (dual boot) then reboot into arch, and the fan works perfectly fine by this. So the fan hardware should not be the problem here.

This is my first install of arch on a laptop so a lot of things here are kind of new to me. I tried my best to follow the arch guide but some of the parts just don't work on the laptop. Am I doing something wrong, how should I solve this issue?

Last edited by hugoksp (2021-07-13 06:31:35)


#2 2021-07-12 21:04:01

Registered: 2021-07-12
Posts: 2

Re: Asus Zenbook UX533fn - Laptop fan does not spin

I should have used code blocks, my bad


Board footer

Powered by FluxBB