You are not logged in.

#1 2021-07-13 06:23:48

Daedalus24
Member
From: Bucharest, Romania
Registered: 2015-03-27
Posts: 9

startx does not launch the DE after linux-zen install [SOLVED]

I have installed the linux-zen kernel and I was not able to launch the desktop environment any more (I normally use cinnamon, but the situation is the same for all other DE such as gnome, lxde, etc).
I use xinit and launch the DE via startx.

The Xorg.0.log file looks like

[  1021.806] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[  1021.806] 
X.Org X Server 1.20.12
X Protocol Version 11, Revision 0
[  1021.806] Build Operating System: Linux Archlinux
[  1021.807] Current Operating System: Linux archclock 5.12.15-zen1-1-zen #1 ZEN SMP PREEMPT Wed, 07 Jul 2021 23:35:33 +0000 x86_64
[  1021.807] Kernel command line: ro root=UUID=166a19ac-45bc-4809-b07f-b6d02ca21f1e archisobasedir=arch archisolabel=ARCH_202107 initrd=\initramfs-linux-zen.img
[  1021.807] Build Date: 08 July 2021  08:00:40PM
[  1021.808]  
[  1021.808] Current version of pixman: 0.40.0
[  1021.808] 	Before reporting problems, check [url]http://wiki.x.org[/url]
	to make sure that you have the latest version.
[  1021.808] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1021.810] (==) Log file: "/home/unicornis65/.local/share/xorg/Xorg.0.log", Time: Tue Jul 13 08:58:29 2021
[  1021.810] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1021.811] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1021.811] (==) No Layout section.  Using the first Screen section.
[  1021.811] (==) No screen section available. Using defaults.
[  1021.811] (**) |-->Screen "Default Screen Section" (0)
[  1021.811] (**) |   |-->Monitor "<default monitor>"
[  1021.811] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[  1021.811] (**) |   |-->Device "Nvidia Card"
[  1021.811] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[  1021.811] (==) Automatically adding devices
[  1021.811] (==) Automatically enabling devices
[  1021.811] (==) Automatically adding GPU devices
[  1021.811] (==) Automatically binding GPU devices
[  1021.811] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1021.811] (WW) The directory "/usr/share/fonts/misc" does not exist.
[  1021.811] 	Entry deleted from font path.
[  1021.811] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[  1021.811] 	Entry deleted from font path.
[  1021.811] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[  1021.811] 	Entry deleted from font path.
[  1021.811] (==) FontPath set to:
	/usr/share/fonts/TTF,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[  1021.811] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1021.811] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1021.811] (II) Module ABI versions:
[  1021.811] 	X.Org ANSI C Emulation: 0.4
[  1021.811] 	X.Org Video Driver: 24.1
[  1021.811] 	X.Org XInput driver : 24.1
[  1021.811] 	X.Org Server Extension : 10.0
[  1021.812] (++) using VT number 1[/ins]

[ins][  1021.816] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[  1021.816] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1021.817] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[  1021.822] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules"
[  1021.826] (--) PCI:*(5@0:0:0) 10de:0ffa:103c:094b rev 161, Mem @ 0xee000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000c000/128, BIOS @ 0x????????/131072
[  1021.826] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1021.826] (II) LoadModule: "glx"
[  1021.826] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1021.828] (II) Module glx: vendor="X.Org Foundation"
[  1021.828] 	compiled for 1.20.12, module version = 1.0.0
[  1021.828] 	ABI class: X.Org Server Extension, version 10.0
[  1021.828] (II) LoadModule: "nvidia"
[  1021.828] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1021.828] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1021.828] 	compiled for 1.6.99.901, module version = 1.0.0
[  1021.828] 	Module class: X.Org Video Driver
[  1021.828] (II) NVIDIA dlloader X Driver  465.31  Thu May 13 22:19:15 UTC 2021
[  1021.828] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1021.828] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[  1021.828] (II) systemd-logind: releasing fd for 226:0
[  1021.829] (II) Loading sub module "fb"
[  1021.829] (II) LoadModule: "fb"
[  1021.829] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1021.829] (II) Module fb: vendor="X.Org Foundation"
[  1021.829] 	compiled for 1.20.12, module version = 1.0.0
[  1021.829] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1021.829] (II) Loading sub module "wfb"
[  1021.829] (II) LoadModule: "wfb"
[  1021.830] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1021.830] (II) Module wfb: vendor="X.Org Foundation"
[  1021.830] 	compiled for 1.20.12, module version = 1.0.0
[  1021.830] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  1021.830] (II) Loading sub module "ramdac"
[  1021.830] (II) LoadModule: "ramdac"
[  1021.830] (II) Module "ramdac" already built-in
[  1021.830] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  1021.830] (II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[  1021.830] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  1021.830] (==) NVIDIA(0): RGB weight 888
[  1021.830] (==) NVIDIA(0): Default visual is TrueColor
[  1021.830] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1021.830] (II) Applying OutputClass "nvidia" options to /dev/dri/card0
[  1021.830] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[  1021.830] (**) NVIDIA(0): Enabling 2D acceleration
[  1021.830] (II) Loading sub module "glxserver_nvidia"
[  1021.830] (II) LoadModule: "glxserver_nvidia"
[  1021.830] (II) Loading /usr/lib/nvidia/xorg/libglxserver_nvidia.so
[  1021.837] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[  1021.837] 	compiled for 1.6.99.901, module version = 1.0.0
[  1021.837] 	Module class: X.Org Server Extension
[  1021.837] (II) NVIDIA GLX Module  465.31  Thu May 13 22:16:59 UTC 2021
[  1021.837] (II) NVIDIA: The X server supports PRIME Render Offload.
[  1022.158] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:5:0:0
[  1022.158] (--) NVIDIA(0):     CRT-0
[  1022.158] (--) NVIDIA(0):     DFP-0 (boot)
[  1022.158] (--) NVIDIA(0):     DFP-1
[  1022.158] (--) NVIDIA(0):     DFP-2
[  1022.159] (II) NVIDIA(0): NVIDIA GPU NVIDIA Quadro K600 (GK107GL) at PCI:5:0:0 (GPU-0)
[  1022.159] (--) NVIDIA(0): Memory: 1048576 kBytes
[  1022.159] (--) NVIDIA(0): VideoBIOS: 80.07.77.00.0a
[  1022.159] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  1022.175] (--) NVIDIA(GPU-0): CRT-0: disconnected
[  1022.175] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[  1022.175] (--) NVIDIA(GPU-0): 
[  1022.205] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): connected
[  1022.205] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): Internal TMDS
[  1022.205] (--) NVIDIA(GPU-0): DELL U2412M (DFP-0): 330.0 MHz maximum pixel clock
[  1022.205] (--) NVIDIA(GPU-0): 
[  1022.205] (--) NVIDIA(GPU-0): DFP-1: disconnected
[  1022.206] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[  1022.206] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[  1022.206] (--) NVIDIA(GPU-0): 
[  1022.206] (--) NVIDIA(GPU-0): DFP-2: disconnected
[  1022.206] (--) NVIDIA(GPU-0): DFP-2: Internal DisplayPort
[  1022.206] (--) NVIDIA(GPU-0): DFP-2: 960.0 MHz maximum pixel clock
[  1022.206] (--) NVIDIA(GPU-0): 
[  1022.208] (==) NVIDIA(0): 
[  1022.208] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1022.208] (==) NVIDIA(0):     will be used as the requested mode.
[  1022.208] (==) NVIDIA(0): 
[  1022.208] (II) NVIDIA(0): Validated MetaModes:
[  1022.208] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[  1022.208] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[  1022.211] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
[  1022.211] (--) NVIDIA(0):     option
[  1022.211] (WW) NVIDIA: Failed to bind sideband socket to
[  1022.211] (WW) NVIDIA:     '/var/run/nvidia-xdriver-b8b2b879' Permission denied
[  1022.211] (II) NVIDIA: Reserving 6144.00 MB of virtual memory for indirect memory
[  1022.211] (II) NVIDIA:     access.
[  1022.213] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  1022.213] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  1022.213] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  1022.213] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  1022.213] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  1022.213] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  1022.213] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  1022.213] (II) NVIDIA(0):     Config Options in the README.
[  1022.239] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[  1022.298] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1022.298] (==) NVIDIA(0): Backing store enabled
[  1022.298] (==) NVIDIA(0): Silken mouse disabled
[  1022.298] (==) NVIDIA(0): DPMS enabled
[  1022.298] (II) Loading sub module "dri2"
[  1022.298] (II) LoadModule: "dri2"
[  1022.298] (II) Module "dri2" already built-in
[  1022.298] (II) NVIDIA(0): [DRI2] Setup complete
[  1022.298] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  1022.299] (II) Initializing extension Generic Event Extension
[  1022.299] (II) Initializing extension SHAPE
[  1022.299] (II) Initializing extension MIT-SHM
[  1022.299] (II) Initializing extension XInputExtension
[  1022.299] (II) Initializing extension XTEST
[  1022.299] (II) Initializing extension BIG-REQUESTS
[  1022.299] (II) Initializing extension SYNC
[  1022.299] (II) Initializing extension XKEYBOARD
[  1022.299] (II) Initializing extension XC-MISC
[  1022.299] (II) Initializing extension SECURITY
[  1022.299] (II) Initializing extension XFIXES
[  1022.299] (II) Initializing extension RENDER
[  1022.299] (II) Initializing extension RANDR
[  1022.299] (II) Initializing extension COMPOSITE
[  1022.299] (II) Initializing extension DAMAGE
[  1022.299] (II) Initializing extension MIT-SCREEN-SAVER
[  1022.299] (II) Initializing extension DOUBLE-BUFFER
[  1022.299] (II) Initializing extension RECORD
[  1022.299] (II) Initializing extension DPMS
[  1022.299] (II) Initializing extension Present
[  1022.299] (II) Initializing extension DRI3
[  1022.299] (II) Initializing extension X-Resource
[  1022.299] (II) Initializing extension XVideo
[  1022.299] (II) Initializing extension XVideo-MotionCompensation
[  1022.299] (II) Initializing extension GLX
[  1022.299] (II) Initializing extension GLX
[  1022.299] (II) Indirect GLX disabled.
[  1022.299] (II) GLX: Another vendor is already registered for screen 0
[  1022.299] (II) Initializing extension XFree86-VidModeExtension
[  1022.299] (II) Initializing extension XFree86-DGA
[  1022.299] (II) Initializing extension XFree86-DRI
[  1022.299] (II) Initializing extension DRI2
[  1022.299] (II) Initializing extension NV-GLX
[  1022.299] (II) Initializing extension NV-CONTROL
[  1022.299] (II) Initializing extension XINERAMA
[  1022.379] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  1022.379] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1022.379] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[  1022.379] (II) LoadModule: "libinput"
[  1022.379] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1022.381] (II) Module libinput: vendor="X.Org Foundation"
[  1022.381] 	compiled for 1.20.11, module version = 1.1.0
[  1022.381] 	Module class: X.Org XInput Driver
[  1022.381] 	ABI class: X.Org XInput driver, version 24.1
[  1022.381] (II) Using input driver 'libinput' for 'Power Button'
[  1022.382] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 29 paused 0
[  1022.382] (**) Power Button: always reports core events
[  1022.382] (**) Option "Device" "/dev/input/event1"
[  1022.382] (**) Option "_source" "server/udev"
[  1022.384] (II) event1  - Power Button: is tagged by udev as: Keyboard
[  1022.384] (II) event1  - Power Button: device is a keyboard
[  1022.384] (II) event1  - Power Button: device removed
[  1022.384] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[  1022.384] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  1022.385] (II) event1  - Power Button: is tagged by udev as: Keyboard
[  1022.385] (II) event1  - Power Button: device is a keyboard
[  1022.386] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  1022.386] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1022.386] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[  1022.386] (II) Using input driver 'libinput' for 'Power Button'
[  1022.387] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 32 paused 0
[  1022.387] (**) Power Button: always reports core events
[  1022.387] (**) Option "Device" "/dev/input/event0"
[  1022.387] (**) Option "_source" "server/udev"
[  1022.388] (II) event0  - Power Button: is tagged by udev as: Keyboard
[  1022.388] (II) event0  - Power Button: device is a keyboard
[  1022.388] (II) event0  - Power Button: device removed
[  1022.388] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[  1022.388] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[  1022.389] (II) event0  - Power Button: is tagged by udev as: Keyboard
[  1022.389] (II) event0  - Power Button: device is a keyboard
[  1022.389] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event9)
[  1022.389] (II) No input driver specified, ignoring this device.
[  1022.389] (II) This device may have been added with another device file.
[  1022.390] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event10)
[  1022.390] (II) No input driver specified, ignoring this device.
[  1022.390] (II) This device may have been added with another device file.
[  1022.390] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event11)
[  1022.390] (II) No input driver specified, ignoring this device.
[  1022.390] (II) This device may have been added with another device file.
[  1022.391] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event12)
[  1022.391] (II) No input driver specified, ignoring this device.
[  1022.391] (II) This device may have been added with another device file.
[  1022.391] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event13)
[  1022.391] (II) No input driver specified, ignoring this device.
[  1022.391] (II) This device may have been added with another device file.
[  1022.391] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event14)
[  1022.391] (II) No input driver specified, ignoring this device.
[  1022.391] (II) This device may have been added with another device file.
[  1022.392] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event15)
[  1022.392] (II) No input driver specified, ignoring this device.
[  1022.392] (II) This device may have been added with another device file.
[  1022.392] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event16)
[  1022.392] (II) No input driver specified, ignoring this device.
[  1022.392] (II) This device may have been added with another device file.
[  1022.393] (II) config/udev: Adding input device Microsoft Microsoft® 2.4GHz Transceiver v7.0 (/dev/input/event2)
[  1022.393] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0: Applying InputClass "evdev keyboard catchall"
[  1022.393] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0: Applying InputClass "libinput keyboard catchall"
[  1022.393] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0'
[  1022.394] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 33 paused 0
[  1022.394] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0: always reports core events
[  1022.394] (**) Option "Device" "/dev/input/event2"
[  1022.394] (**) Option "_source" "server/udev"
[  1022.396] (II) event2  - Microsoft Microsoft® 2.4GHz Transceiver v7.0: is tagged by udev as: Keyboard
[  1022.396] (II) event2  - Microsoft Microsoft® 2.4GHz Transceiver v7.0: device is a keyboard
[  1022.396] (II) event2  - Microsoft Microsoft® 2.4GHz Transceiver v7.0: device removed
[  1022.396] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/0003:045E:07B2.0001/input/input4/event2"
[  1022.396] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0" (type: KEYBOARD, id 8)
[  1022.397] (II) event2  - Microsoft Microsoft® 2.4GHz Transceiver v7.0: is tagged by udev as: Keyboard
[  1022.397] (II) event2  - Microsoft Microsoft® 2.4GHz Transceiver v7.0: device is a keyboard
[  1022.398] (II) config/udev: Adding input device Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse (/dev/input/event3)
[  1022.398] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: Applying InputClass "evdev pointer catchall"
[  1022.398] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: Applying InputClass "libinput pointer catchall"
[  1022.398] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse'
[  1022.451] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 34 paused 0
[  1022.451] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: always reports core events
[  1022.451] (**) Option "Device" "/dev/input/event3"
[  1022.451] (**) Option "_source" "server/udev"
[  1022.453] (II) event3  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: is tagged by udev as: Mouse
[  1022.453] (II) event3  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: device is a pointer
[  1022.453] (II) event3  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: device removed
[  1022.453] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/0003:045E:07B2.0002/input/input5/event3"
[  1022.453] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse" (type: MOUSE, id 9)
[  1022.453] (**) Option "AccelerationScheme" "none"
[  1022.453] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: (accel) selected scheme none/0
[  1022.453] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: (accel) acceleration factor: 2.000
[  1022.453] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: (accel) acceleration threshold: 4
[  1022.454] (II) event3  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: is tagged by udev as: Mouse
[  1022.455] (II) event3  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: device is a pointer
[  1022.455] (II) config/udev: Adding input device Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse (/dev/input/mouse0)
[  1022.455] (II) No input driver specified, ignoring this device.
[  1022.455] (II) This device may have been added with another device file.
[  1022.456] (II) config/udev: Adding input device Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control (/dev/input/event4)
[  1022.456] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "evdev keyboard catchall"
[  1022.456] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "libinput keyboard catchall"
[  1022.456] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control'
[  1022.457] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 35 paused 0
[  1022.457] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: always reports core events
[  1022.457] (**) Option "Device" "/dev/input/event4"
[  1022.457] (**) Option "_source" "server/udev"
[  1022.459] (II) event4  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: is tagged by udev as: Keyboard
[  1022.459] (II) event4  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device is a keyboard
[  1022.459] (II) event4  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device removed
[  1022.459] (II) libinput: Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: needs a virtual subdevice
[  1022.459] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/0003:045E:07B2.0002/input/input6/event4"
[  1022.459] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control" (type: MOUSE, id 10)
[  1022.459] (**) Option "AccelerationScheme" "none"
[  1022.459] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: (accel) selected scheme none/0
[  1022.459] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: (accel) acceleration factor: 2.000
[  1022.459] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: (accel) acceleration threshold: 4
[  1022.460] (II) event4  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: is tagged by udev as: Keyboard
[  1022.461] (II) event4  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device is a keyboard
[  1022.461] (II) config/udev: Adding input device Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control (/dev/input/event5)
[  1022.461] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "evdev keyboard catchall"
[  1022.461] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "libinput keyboard catchall"
[  1022.461] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control'
[  1022.463] (II) systemd-logind: got fd for /dev/input/event5 13:69 fd 36 paused 0
[  1022.463] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: always reports core events
[  1022.463] (**) Option "Device" "/dev/input/event5"
[  1022.463] (**) Option "_source" "server/udev"
[  1022.464] (II) event5  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: is tagged by udev as: Keyboard
[  1022.464] (II) event5  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device is a keyboard
[  1022.465] (II) event5  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device removed
[  1022.465] (II) libinput: Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: needs a virtual subdevice
[  1022.465] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:045E:07B2.0003/input/input7/event5"
[  1022.465] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control" (type: MOUSE, id 11)
[  1022.465] (**) Option "AccelerationScheme" "none"
[  1022.465] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: (accel) selected scheme none/0
[  1022.465] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: (accel) acceleration factor: 2.000
[  1022.465] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: (accel) acceleration threshold: 4
[  1022.466] (II) event5  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: is tagged by udev as: Keyboard
[  1022.466] (II) event5  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device is a keyboard
[  1022.467] (II) config/udev: Adding input device Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control (/dev/input/event6)
[  1022.467] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: Applying InputClass "evdev keyboard catchall"
[  1022.467] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: Applying InputClass "libinput keyboard catchall"
[  1022.467] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control'
[  1022.469] (II) systemd-logind: got fd for /dev/input/event6 13:70 fd 37 paused 0
[  1022.469] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: always reports core events
[  1022.469] (**) Option "Device" "/dev/input/event6"
[  1022.469] (**) Option "_source" "server/udev"
[  1022.470] (II) event6  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: is tagged by udev as: Keyboard
[  1022.470] (II) event6  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: device is a keyboard
[  1022.471] (II) event6  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: device removed
[  1022.471] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:045E:07B2.0003/input/input9/event6"
[  1022.471] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control" (type: KEYBOARD, id 12)
[  1022.472] (II) event6  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: is tagged by udev as: Keyboard
[  1022.472] (II) event6  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: device is a keyboard
[  1022.473] (II) config/udev: Adding input device PC Speaker (/dev/input/event7)
[  1022.473] (II) No input driver specified, ignoring this device.
[  1022.473] (II) This device may have been added with another device file.
[  1022.476] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event8)
[  1022.476] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[  1022.476] (**) HP WMI hotkeys: Applying InputClass "libinput keyboard catchall"
[  1022.476] (II) Using input driver 'libinput' for 'HP WMI hotkeys'
[  1022.477] (II) systemd-logind: got fd for /dev/input/event8 13:72 fd 38 paused 0
[  1022.477] (**) HP WMI hotkeys: always reports core events
[  1022.477] (**) Option "Device" "/dev/input/event8"
[  1022.477] (**) Option "_source" "server/udev"
[  1022.478] (II) event8  - HP WMI hotkeys: is tagged by udev as: Keyboard Switch
[  1022.478] (II) event8  - HP WMI hotkeys: device is a keyboard
[  1022.478] (II) event8  - HP WMI hotkeys: device removed
[  1022.478] (**) Option "config_info" "udev:/sys/devices/virtual/input/input12/event8"
[  1022.478] (II) XINPUT: Adding extended input device "HP WMI hotkeys" (type: KEYBOARD, id 13)
[  1022.479] (II) event8  - HP WMI hotkeys: is tagged by udev as: Keyboard Switch
[  1022.479] (II) event8  - HP WMI hotkeys: device is a keyboard
[  1022.483] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "evdev keyboard catchall"
[  1022.483] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "libinput keyboard catchall"
[  1022.483] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control'
[  1022.483] (II) systemd-logind: returning pre-existing fd for /dev/input/event4 13:68
[  1022.483] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: always reports core events
[  1022.483] (**) Option "Device" "/dev/input/event4"
[  1022.483] (**) Option "_source" "_driver/libinput"
[  1022.483] (II) libinput: Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: is a virtual subdevice
[  1022.483] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/0003:045E:07B2.0002/input/input6/event4"
[  1022.484] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control" (type: KEYBOARD, id 14)
[  1022.484] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "evdev keyboard catchall"
[  1022.484] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: Applying InputClass "libinput keyboard catchall"
[  1022.484] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control'
[  1022.484] (II) systemd-logind: returning pre-existing fd for /dev/input/event5 13:69
[  1022.484] (**) Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: always reports core events
[  1022.484] (**) Option "Device" "/dev/input/event5"
[  1022.484] (**) Option "_source" "_driver/libinput"
[  1022.484] (II) libinput: Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: is a virtual subdevice
[  1022.484] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:045E:07B2.0003/input/input7/event5"
[  1022.484] (II) XINPUT: Adding extended input device "Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control" (type: KEYBOARD, id 15)
[  1022.500] (**) Option "fd" "29"
[  1022.500] (II) event1  - Power Button: device removed
[  1022.500] (**) Option "fd" "32"
[  1022.500] (II) event0  - Power Button: device removed
[  1022.500] (**) Option "fd" "33"
[  1022.500] (II) event2  - Microsoft Microsoft® 2.4GHz Transceiver v7.0: device removed
[  1022.500] (**) Option "fd" "34"
[  1022.500] (II) event3  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Mouse: device removed
[  1022.500] (**) Option "fd" "35"
[  1022.500] (**) Option "fd" "36"
[  1022.500] (**) Option "fd" "37"
[  1022.501] (II) event6  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 System Control: device removed
[  1022.501] (**) Option "fd" "38"
[  1022.501] (II) event8  - HP WMI hotkeys: device removed
[  1022.501] (**) Option "fd" "35"
[  1022.501] (II) event4  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device removed
[  1022.501] (**) Option "fd" "36"
[  1022.501] (II) event5  - Microsoft Microsoft® 2.4GHz Transceiver v7.0 Consumer Control: device removed
[  1022.502] (II) UnloadModule: "libinput"
[  1022.502] (II) systemd-logind: not releasing fd for 13:69, still in use
[  1022.502] (II) UnloadModule: "libinput"
[  1022.502] (II) systemd-logind: not releasing fd for 13:68, still in use
[  1022.502] (II) UnloadModule: "libinput"
[  1022.502] (II) systemd-logind: releasing fd for 13:72
[  1022.530] (II) UnloadModule: "libinput"
[  1022.530] (II) systemd-logind: releasing fd for 13:70
[  1022.550] (II) UnloadModule: "libinput"
[  1022.550] (II) systemd-logind: releasing fd for 13:69
[  1022.570] (II) UnloadModule: "libinput"
[  1022.570] (II) systemd-logind: releasing fd for 13:68
[  1022.602] (II) UnloadModule: "libinput"
[  1022.602] (II) systemd-logind: releasing fd for 13:67
[  1022.638] (II) UnloadModule: "libinput"
[  1022.638] (II) systemd-logind: releasing fd for 13:66
[  1022.658] (II) UnloadModule: "libinput"
[  1022.658] (II) systemd-logind: releasing fd for 13:64
[  1022.671] (II) UnloadModule: "libinput"
[  1022.671] (II) systemd-logind: releasing fd for 13:65
[  1023.281] (II) NVIDIA(GPU-0): Deleting GPU-0
[  1023.284] (II) Server terminated successfully (0). Closing log file.

I installed xf86-video-nouveau, because it complained about it. I also have nvidia, nvidia-utils and nvidia-settings installed. I also had an error message:
open /dev/fb0 : Permission denied
which I get rid off by creating the /etc/X11/Xwrapper.config file

needs_root_rights=no

.

The motherboard is an Intel Server Xeon one, bought in 2017 (refurbished) and the graphical card is an NVIDIA Quadro K600. I also created the /etc/X11/xorg.conf.d/20-nvidia.conf file

Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName "GeForce K600"
EndSection

Please give me a hint, I don't know what to do next. Thank you.

One more thing, I dual boot Win10 and Arch using refind. After the last cumulative update of Win10 last week, the boot loader simply dissapears (I even lost the / partition from Arch and had to reinstall) and one has to boot into rescue mode, mount the / and /boot partitions, and then reinstall refind. This step has to be performed every time you boot into Win10. As the office desktop computer has a 256 GB SSD disk and a 2 TB HDD, would it be a better approach to completely separate Win and Arch (Win on SSD and Arch on the HDD)  and boot by selecting the disk from BIOS?

All the best from here ;)
Bogdan

Last edited by Daedalus24 (2021-07-13 08:20:30)

Offline

#2 2021-07-13 06:48:48

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,621
Website

Re: startx does not launch the DE after linux-zen install [SOLVED]

X is working fine. Post your .xinitrc.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2021-07-13 07:14:52

Daedalus24
Member
From: Bucharest, Romania
Registered: 2015-03-27
Posts: 9

Re: startx does not launch the DE after linux-zen install [SOLVED]

.xinitrc looks like

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then

    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then

    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

#twm &
#xclock -geometry 50x50-1+1 &
#xterm -geometry 80x50+494+51 &
#xterm -geometry 80x20+494-0 &
#exec xterm -geometry 80x66+0+0 -name login
#exec lxqt-session
exec cinnamon-session
#exec startxfce4

and

 lspci -k | grep -A 2 -E "(VGA|3D)"

returns

 05:00.0 VGA compatible controller: NVIDIA Corporation GK107GL [Quandro K600] (rev a1)
Subsystem: Hewlett Packard Company Device 094b
Kernel driver in use: nvidia 

Last edited by Daedalus24 (2021-07-13 07:15:24)

Offline

#4 2021-07-13 07:30:30

loqs
Member
Registered: 2014-03-06
Posts: 13,871

Re: startx does not launch the DE after linux-zen install [SOLVED]

If you uncomment from ~/.xinitrc

#exec xterm -geometry 80x66+0+0 -name login

Assuming xterm is installed does xterm start when you run startx?

Offline

#5 2021-07-13 08:05:23

Daedalus24
Member
From: Bucharest, Romania
Registered: 2015-03-27
Posts: 9

Re: startx does not launch the DE after linux-zen install [SOLVED]

Dear loqs,

Uncommenting worked. I uncommented then all the section

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login

and have been able to enter the twm Window manager. I then tried to launch gnome-session and startxfce4 from .xinitrc. Both of them worked! Cinnamon is not yet operational which probably means I have to reinstall something.

I do not understand which was the reason for this disrupture.

Please spread the word about Win10 cumulative update disrupting any of the boot loaders (grub, refind, etc).

Thank you very much loqs and jasonwryan  smile  cool

Last edited by Daedalus24 (2021-07-13 08:19:34)

Offline

Board footer

Powered by FluxBB