You are not logged in.

#1 2021-07-16 01:41:19

jorgeperez
Member
Registered: 2021-07-16
Posts: 2

Yandex-browser does not work

The current version of yandex-browser-beta (21.5.3) worked until a few days ago. I think it is because of the kernel update. I have re-installed arch linux and it still doesn't work yandex-browser-beta, I have even removed the current linux kernel (5.12) and instead use the lts kernel and yandex doesn't work. When launching yandex-browser-beta from the terminal I get the following errors:

Found ffmpeg: /opt/yandex/browser-beta/libffmpeg.so
avcodec: 3830630
avformat: 3817828
avutil: 3685988
Ffmpeg version is OK! Let's use it.
[5428: 5428: 0715 / 203506.178239: ERROR: isolated_origin_util.cc (73)] Ignoring port number in isolated origin: chrome: // custo
[5428: 5450: 0715 / 203506.288532: ERROR: simple_index_file.cc (331)] Failed to write the temporary index file
libva error: vaGetDriverNameByIndex () failed with unknown libva error, driver_name = (null)
[5467: 5467: 0715 / 203506.551770: ERROR: sandbox_linux.cc (374)] InitializeSandbox () called with multiple threads in process gpu-process.
--2021-07-15 20: 35: 07-- https://crash-reports.browser.yandex.net/submit
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving crash-reports.browser.yandex.net (crash-reports.browser.yandex.net) ... 213.180.204.237, 2a02: 6b8 :: 2: 237
Connecting to crash-reports.browser.yandex.net (crash-reports.browser.yandex.net) [213.180.204.237]: 443 ... connected.
HTTP request sent, waiting for response ... 200 OK
Length: not specified
Recording to: "/ dev / fd / 4"


     0K Crash dump id: bp-bf76a516-5716-4975-87e0-0d88b2210716
                                            12.4M = 0s

[5428: 5428: 0715 / 203509.741740: ERROR: network_service_instance_impl.cc (342)] Network service crashed, restarting service.
[5428: 5428: 0715 / 203509.847159: ERROR: web_app_service.cc (900)] Install failed with code
--2021-07-15 20: 35: 10-- https://crash-reports.browser.yandex.net/submit
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving crash-reports.browser.yandex.net (crash-reports.browser.yandex.net) ... 213.180.204.237, 2a02: 6b8 :: 2: 237
Connecting to crash-reports.browser.yandex.net (crash-reports.browser.yandex.net) [213.180.204.237]: 443 ... connected.
HTTP request sent, waiting for response ... [5428: 5428: 0715 / 203511.784738: ERROR: network_service_instance_impl.cc (342)] Network service crashed, restarting service.
[5467: 5467: 0715 / 203511.919367: ERROR: gl_surface_presentation_helper.cc (259)] GetVSyncParametersIfAvailable () failed for 1 times!
200 OK
Length: not specified
Recording to: "/ dev / fd / 4"

.
.
.
Repeats indefinitely

Offline

#2 2021-07-16 01:43:05

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,736
Website

Re: Yandex-browser does not work

It's your job to rebuild AUR packages against updated shared libraries.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2021-07-19 22:13:38

jorgeperez
Member
Registered: 2021-07-16
Posts: 2

Re: Yandex-browser does not work

Indeed, I have investigated and it is true. However, I have a question:
Any user can rebuild the AUR package or is it the person in charge who should rebuild the AUR package? I did not find clear information on this.
If it is the person in charge who must rebuild the package, I will leave your email: mastersoft24@yandex.ru
If any user can rebuild the AUR package, does anyone know how to do it?

Offline

#4 2021-07-19 22:55:13

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,734

Re: Yandex-browser does not work

Moving to AUR issues.

Offline

#5 2021-07-19 23:09:58

loqs
Member
Registered: 2014-03-06
Posts: 14,230

Re: Yandex-browser does not work

jorgeperez wrote:

Indeed, I have investigated and it is true. However, I have a question:
Any user can rebuild the AUR package or is it the person in charge who should rebuild the AUR package? I did not find clear information on this.
If it is the person in charge who must rebuild the package, I will leave your email: mastersoft24@yandex.ru
If any user can rebuild the AUR package, does anyone know how to do it?

As jasonwryan already wrote you are responsible for rebuilding AUR packages you have on your system.
You rebuild a package the same way you initially built it. Arch_User_Repository#Build_the_package.
The AUR package maintainer can increment the pkgver when it needs rebuilding for a dependency but it is not required.  You would still need to check if the package has been updated and rebuild it yourself.
Edit:
https://aur.archlinux.org/packages/yandex-browser-beta/ is a binary package meaning it contains prebuilt binaries.  Rebuilding the package does not apply to binary packages as the building is not done by makepkg but by the supplier of the binaries.
A library problem with such a package needs an upstream update or you need to find which library caused the issue and create a special package for the old version of that library.
Edit2:
A webs earch for 'libva error: vaGetDriverNameByIndex () failed with unknown libva error, driver_name = (null)' has lots of results such as https://bbs.archlinux.org/viewtopic.php?id=266595 all sugessting the issue is related to configuration for video acceleration.

Last edited by loqs (2021-07-19 23:54:32)

Offline

#6 2021-07-30 10:06:48

moghaazi
Member
From: Egypt
Registered: 2021-03-02
Posts: 5

Re: Yandex-browser does not work

For a  temporary solution you can launch the browser from the terminal with this line

yandex-browser-beta --disable-features=AbtFeature

I talked to the development team and they are working on this issue, it may be fixed in the next update.

Offline

Board footer

Powered by FluxBB