You are not logged in.

#1 2021-05-09 09:01:49

RobinDM
Member
Registered: 2021-05-09
Posts: 3

[SOLVED] Black screen on boot after update

Hi everyone,

I have been running arch on an hp zbook 15u G5 without issues the last year until this morning. Since running pacman -Syu, I get a black screen after selecting Arch from the grub boot menu. It might be relevant to know that I also have fedora workstation 34 and windows 10 on other partitions (and my home folder on yet another partition, shared between fedora and arch).

I've been searching and trying things and have had some success, but am failing to fully resolve my issue. Here's what I've gathered so far:

Appending "nomodeset" to the kernel line solves the black screen issue, but then I can't start X after logging in. I've tried adding i915 (the laptop has an intel GPU) to the modules array in my mkinitcpio.conf and regenerating initramfs, but to no avail. I've also tried adding i915.modeset=0 and some other tips found on the wiki, but I always get a black screen without nomodeset (so, I need to choose between X and nomodeset).

I've noticed an external (HDMI) monitor works without problems. If I plug in my external display and then reboot (without nomodeset), the laptop screen stays black, but the login prompt appears on the external monitor, allowing me to log in and run X. However, even then I still can't use the laptop monitor (e.g. when trying to use the laptop as second monitor with xrandr).

I feel like I'm stuck. I saw some information on the wiki regarding EDID and forcing modes, but I don't really understand any of it. What puzzles me most of all is that everything was working fine until I ran the update.

My current plan is to just wait a bit until there are new patches through pacman -Syu, hoping it will magically fix the problems.
Meanwhile, I thought I'd post my story here, hoping that someone reading it has an "aha, you should try this" experience smile

Thanks in advance

Last edited by RobinDM (2021-05-09 12:58:11)

Offline

#2 2021-05-09 10:38:32

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 189

Re: [SOLVED] Black screen on boot after update

What packages were updated? Check in /var/log/pacman.log

Offline

#3 2021-05-09 10:50:16

RobinDM
Member
Registered: 2021-05-09
Posts: 3

Re: [SOLVED] Black screen on boot after update

Hi @icar, I ran

 cat /var/log/pacman.log | grep 2021-05-09 

The results are:

[2021-05-09T08:04:05+0200] [PACMAN] Running 'pacman -Syu'
[2021-05-09T08:04:05+0200] [PACMAN] synchronizing package lists
[2021-05-09T08:04:07+0200] [PACMAN] starting full system upgrade
[2021-05-09T08:07:46+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2021-05-09T08:07:46+0200] [ALPM] transaction started
[2021-05-09T08:07:46+0200] [ALPM] upgraded ncurses (6.2-1 -> 6.2-2)
[2021-05-09T08:07:46+0200] [ALPM] upgraded harfbuzz (2.8.0-3 -> 2.8.1-1)
[2021-05-09T08:07:46+0200] [ALPM] upgraded xorgproto (2021.3-1 -> 2021.4-1)
[2021-05-09T08:07:46+0200] [ALPM] upgraded librsvg (2:2.50.4-1 -> 2:2.50.5-1)
[2021-05-09T08:07:46+0200] [ALPM] upgraded gtk-update-icon-cache (1:4.2.0-5 -> 1:4.2.1-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded adwaita-icon-theme (40.0-1 -> 40.1.1-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded alsa-card-profiles (1:0.3.26-1 -> 1:0.3.27-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded aom (3.0.0-2 -> 3.1.0-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libxcrypt (4.4.19-1 -> 4.4.20-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libldap (2.4.58-1 -> 2.4.58-2)
[2021-05-09T08:07:47+0200] [ALPM] upgraded at-spi2-core (2.40.0-1 -> 2.40.1-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded bubblewrap (0.4.1-1 -> 0.4.1-2)
[2021-05-09T08:07:47+0200] [ALPM] upgraded ttf-liberation (2.1.3-1 -> 2.1.4-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded flac (1.3.3-2 -> 1.3.3-3)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libass (0.15.0-2 -> 0.15.1-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded srt (1.4.2-1 -> 1.4.3-1)
[2021-05-09T08:07:47+0200] [ALPM] installed svt-av1 (0.8.6-3)
[2021-05-09T08:07:47+0200] [ALPM] upgraded vulkan-icd-loader (1.2.174-2 -> 1.2.176-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded mesa (21.0.3-2 -> 21.0.3-3)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libglvnd (1.3.2-2 -> 1.3.3-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded ffmpeg (2:4.3.2-6 -> 2:4.4-3)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libepoxy (1.5.5-1 -> 1.5.7-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libxkbcommon (1.2.1-1 -> 1.3.0-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded wayland-protocols (1.20-1 -> 1.21-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded js78 (78.10.0-1 -> 78.10.1-1)
[2021-05-09T08:07:47+0200] [ALPM] upgraded libtool (2.4.6+42+gb88cebd5-14 -> 2.4.6+42+gb88cebd5-15)
[2021-05-09T08:07:48+0200] [ALPM] upgraded chromium (90.0.4430.85-1 -> 90.0.4430.93-1)
[2021-05-09T08:07:48+0200] [ALPM] upgraded cmake (3.20.1-1 -> 3.20.2-1)
[2021-05-09T08:07:49+0200] [ALPM] upgraded containerd (1.4.4-1 -> 1.5.0-1)
[2021-05-09T08:07:49+0200] [ALPM] upgraded dunst (1.5.0-1 -> 1.6.1-2)
[2021-05-09T08:07:50+0200] [ALPM] upgraded electron (12.0.5-1 -> 12.0.6-1)
[2021-05-09T08:07:50+0200] [ALPM] upgraded electron11 (11.4.3-2 -> 11.4.5-1)
[2021-05-09T08:07:50+0200] [ALPM] upgraded geoip-database (20210323-1 -> 20210427-1)
[2021-05-09T08:07:52+0200] [ALPM] upgraded go (2:1.16.3-1 -> 2:1.16.4-1)
[2021-05-09T08:07:52+0200] [ALPM] upgraded harfbuzz-icu (2.8.0-3 -> 2.8.1-1)
[2021-05-09T08:07:52+0200] [ALPM] upgraded imagemagick (7.0.11.9-1 -> 7.0.11.11-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded intellij-idea-community-edition (4:2021.1-1 -> 4:2021.1.1-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded iproute2 (5.11.0-1 -> 5.12.0-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded iputils (20200821-1 -> 20210202-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded less (1:581-1 -> 1:581.2-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libfdk-aac (2.0.1-2 -> 2.0.2-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libwacom (1.9-1 -> 1.10-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libinput (1.17.1-1 -> 1.17.2-2)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libmanette (0.2.6-1 -> 0.2.6-2)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libmicrohttpd (0.9.72-1 -> 0.9.73-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libnm (1.30.4-1 -> 1.30.4-3)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libsidplayfp (2.1.1-1 -> 2.1.2-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libsynctex (2020.54586-13 -> 2020.54586-14)
[2021-05-09T08:07:55+0200] [ALPM] upgraded libxkbcommon-x11 (1.2.1-1 -> 1.3.0-1)
[2021-05-09T08:07:55+0200] [ALPM] upgraded mpfr (4.1.0-1 -> 4.1.0-2)
[2021-05-09T08:07:56+0200] [ALPM] upgraded linux (5.11.16.arch1-1 -> 5.12.1.arch1-1)
[2021-05-09T08:07:57+0200] [ALPM] upgraded linux-firmware (20210315.3568f96-2 -> 20210426.fa0efef-1)
[2021-05-09T08:07:57+0200] [ALPM] upgraded mailcap (2.1.49-1 -> 2.1.53-1)
[2021-05-09T08:07:57+0200] [ALPM] upgraded mpg123 (1.26.5-1 -> 1.27.0-1)
[2021-05-09T08:07:57+0200] [ALPM] upgraded networkmanager (1.30.4-1 -> 1.30.4-3)
[2021-05-09T08:07:58+0200] [ALPM] upgraded nodejs (16.0.0-1 -> 16.1.0-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded node-gyp (7.1.2-1 -> 8.0.0-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded npm (7.11.1-1 -> 7.12.0-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded pipewire (1:0.3.26-1 -> 1:0.3.27-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded pipewire-media-session (1:0.3.26-1 -> 1:0.3.27-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded pipewire-pulse (1:0.3.26-1 -> 1:0.3.27-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded poppler (21.04.0-2 -> 21.05.0-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded qt5-base (5.15.2+kde+r180-1 -> 5.15.2+kde+r192-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded poppler-qt5 (21.04.0-2 -> 21.05.0-1)
[2021-05-09T08:07:58+0200] [ALPM] upgraded python-chardet (4.0.0-1 -> 4.0.0-2)
[2021-05-09T08:07:58+0200] [ALPM] upgraded python-decorator (4.4.2-4 -> 5.0.7-1)
[2021-05-09T08:07:59+0200] [ALPM] upgraded python-pygments (2.8.1-1 -> 2.9.0-1)
[2021-05-09T08:07:59+0200] [ALPM] upgraded qt5-webengine (5.15.3-4 -> 5.15.3-5)
[2021-05-09T08:07:59+0200] [ALPM] upgraded qutebrowser (2.2.0-1 -> 2.2.1-1)
[2021-05-09T08:07:59+0200] [ALPM] upgraded smbclient (4.14.3-1 -> 4.14.4-1)
[2021-05-09T08:07:59+0200] [ALPM] upgraded telegram-desktop (2.7.2-1 -> 2.7.4-1)
[2021-05-09T08:07:59+0200] [ALPM] upgraded vte-common (0.64.0-2 -> 0.64.1-1)
[2021-05-09T08:07:59+0200] [ALPM] upgraded termite-terminfo (15-3 -> 15-4)
[2021-05-09T08:07:59+0200] [ALPM-SCRIPTLET] termite is now obsolete, see https://github.com/thestinger/termite#termite-is-obsoleted-by-alacritty
[2021-05-09T08:07:59+0200] [ALPM] upgraded termite (15-3 -> 15-4)
[2021-05-09T08:07:59+0200] [ALPM-SCRIPTLET] termite is now obsolete, see https://github.com/thestinger/termite#termite-is-obsoleted-by-alacritty
[2021-05-09T08:07:59+0200] [ALPM] upgraded tldr (1.2.0-1 -> 1.2.1-1)
[2021-05-09T08:08:00+0200] [ALPM] upgraded vim-runtime (8.2.2814-1 -> 8.2.2815-1)
[2021-05-09T08:08:00+0200] [ALPM] upgraded vim (8.2.2814-1 -> 8.2.2815-1)
[2021-05-09T08:08:00+0200] [ALPM] transaction completed
[2021-05-09T08:08:00+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2021-05-09T08:08:01+0200] [ALPM] running '30-systemd-hwdb.hook'...
[2021-05-09T08:08:01+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2021-05-09T08:08:01+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2021-05-09T08:08:01+0200] [ALPM] running '30-systemd-update.hook'...
[2021-05-09T08:08:01+0200] [ALPM] running '60-depmod.hook'...
[2021-05-09T08:08:10+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.12.1-arch1-1
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-05-09T08:08:10+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.12.1-arch1-1
[2021-05-09T08:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-05-09T08:08:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-05-09T08:08:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-05-09T08:08:12+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-05-09T08:08:12+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2021-05-09T08:08:13+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2021-05-09T08:08:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-05-09T08:08:15+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-05-09T08:08:16+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-05-09T08:08:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-05-09T08:08:19+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-05-09T08:08:19+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2021-05-09T08:08:20+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-05-09T08:08:20+0200] [ALPM] running 'dbus-reload.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'detect-old-perl-modules.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'fontconfig.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'texinfo-install.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-05-09T08:08:20+0200] [ALPM] running 'update-mime-database.hook'...
[2021-05-09T08:08:21+0200] [ALPM] running 'xorg-mkfontscale.hook'...

Offline

#4 2021-05-09 11:33:25

gallicism
Member
Registered: 2019-06-09
Posts: 1

Re: [SOLVED] Black screen on boot after update

Hi @RobinDM,

I'm running a similar setup as you (arch & windows 10 dual boot) on a dell xps 15. After performing a system upgrade with

yay -Syyu

booting into arch resulted in a black screen.

I had a suspicion that the kernel upgrade might be causing the issue so I downgraded the linux & linux-headers packages with

pacman -U /var/cache/pacman/pkg/linux-$version
pacman -U /var/cache/pacman/pkg/linux-headers-$version

and was able to boot into arch again. (replace $version with the previous version of the package you have in cache 5.11.16 in my case)

I'm uncertain of what is causing the black screen on boot for 5.12.1, I plan on waiting for the 5.12.2 release to upgrade the kernel again.

I hope this helps.

Last edited by gallicism (2021-05-09 13:03:11)

Offline

#5 2021-05-09 12:57:54

RobinDM
Member
Registered: 2021-05-09
Posts: 3

Re: [SOLVED] Black screen on boot after update

Hi @gallicism,

I took your advice and downgraded to the version of Linux I had previously (in my case 5.11.16), and indeed I am now able to use my laptop screen again. Thanks a lot!

Offline

#6 2021-05-11 16:56:08

pixelou
Member
Registered: 2011-03-30
Posts: 17

Re: [SOLVED] Black screen on boot after update

Thanks a lot, nothing showed up in the kernel logs to help with troubleshooting by the way.
For anyone else having the same issue: you can append "nomodeset" to the kernel command line at boot to prevent graphics driver to load and downgrade the kernel or switch to lts from the console.

Offline

#7 2021-05-17 19:02:14

ispeaknousa
Member
Registered: 2017-05-25
Posts: 2

Re: [SOLVED] Black screen on boot after update

Does by any change everyone who is facing this issue have an Intel GPU?
The kernel 5.12.3.arch1-1 presented the same issue. I'm wondering if the culprit isn't the GPU driver instead.

Offline

#8 2021-05-19 08:44:36

krnlpk
Member
Registered: 2010-01-03
Posts: 25

Re: [SOLVED] Black screen on boot after update

I've had a few reports of people on linux-lts 5.10.37-1-lts having the same problem (i.e. KMS broke), which they solved by booting with nomodeset and then downgrading back to 5.10.36. They also had Optimus laptops.

Could it be due to some bugfix on Intel drivers in both the LTS and stable kernel?

Last edited by krnlpk (2021-05-19 08:44:54)

Offline

#9 2021-07-17 18:04:09

ispeaknousa
Member
Registered: 2017-05-25
Posts: 2

Re: [SOLVED] Black screen on boot after update

For anyone else who stumbles upon this thread, this issue is also discussed here: https://bbs.archlinux.org/viewtopic.php?id=266141
And actually reported here: https://gitlab.freedesktop.org/drm/intel/-/issues/3440
With a regression test failing here: https://gitlab.freedesktop.org/drm/intel/-/issues/3452

Offline

Board footer

Powered by FluxBB