You are not logged in.

#1 2021-07-22 02:57:30

juanma0599
Member
Registered: 2021-07-22
Posts: 2

[SOLUCIONADO]Error al actualizar o instalar aplicaciones en mi sistema

Hola buenas a todos, hace dos semanas que tengo archlinux sin ningún problema pero hoy al momento de tratar de actualizar o instalar alguna aplicación me sale el siguiente error:

:: Iniciando actualización completa del sistema...
error: no se pudo abrir el archivo /var/lib/pacman/sync/core.db: Unrecognized archive format
error: no se pudo abrir el archivo /var/lib/pacman/sync/extra.db: Unrecognized archive format
error: no se pudo abrir el archivo /var/lib/pacman/sync/community.db: Unrecognized archive format
error: no se pudo abrir el archivo /var/lib/pacman/sync/multilib.db: Unrecognized archive format

Agradezco de antemano la ayuda que me puedan brindar, quedo atento smile

Last edited by juanma0599 (2021-07-22 16:03:40)

Offline

#2 2021-07-22 08:49:51

philo
Member
Registered: 2015-01-26
Posts: 155

Re: [SOLUCIONADO]Error al actualizar o instalar aplicaciones en mi sistema

sudo rm -R /var/lib/pacman/sync
sudo pacman -Syu 

Edit -
Es posible que deba cambiar su 'mirror' principal.

Last edited by philo (2021-07-22 13:07:59)

Offline

#3 2021-07-22 09:17:33

a821
Member
Registered: 2012-10-31
Posts: 277

Re: [SOLUCIONADO]Error al actualizar o instalar aplicaciones en mi sistema

Offline

#4 2021-07-22 15:52:12

juanma0599
Member
Registered: 2021-07-22
Posts: 2

Re: [SOLUCIONADO]Error al actualizar o instalar aplicaciones en mi sistema

philo wrote:
sudo rm -R /var/lib/pacman/sync
sudo pacman -Syu 

Edit -
Es posible que deba cambiar su 'mirror' principal.

Muchas gracias, si funcionó, también tuve que cambiar el mirror. Gracias a todos por la colaboración big_smile

Offline

Board footer

Powered by FluxBB