You are not logged in.

#1 2021-07-21 10:45:02

Registered: 2021-07-21
Posts: 1

Virtual Box encrypted Btrfs and swap stuck at uefi shell after reboot

Hey dear people,

I installed Arch in Virtual Box 6.1 with an encrypted btrfs system-partition and encrypted swap partition.
After following the wiki installation guide I rebooted and was able to decrypt the disk select arch in the grub menu and log into the system.
But when I reboot again or shutdown and boot again I'm stuck at the uefi shell.

So I started from scratch - same result, I don't know where I made a mistake an would appreciate if someone has an idea. I'm not quite sure which information I could provide to help solve the case, please let me know smile

Edit: I forgot to mention I used the linux-hardened kernel. I don't know if that plays a role, but I saw there were issues with uefi in virtualbox < 6.1. As I wrote I'm using 6.1 and the suggested solutions didn't work for me either.

Edit2: Tried the standard kernel, same problem. Would be nice to know, if this is a virtualbox issue or if I made a mistake, because I wanted to try the setup and then put it on my Laptop.

Last edited by mymynameis (2021-07-21 14:47:07)


#2 2021-07-28 21:53:36

Registered: 2020-12-21
Posts: 29

Re: Virtual Box encrypted Btrfs and swap stuck at uefi shell after reboot

What do you mean by UEFI shell?

Grub worked for you on first reboot, but not the second. Is that correct?

How did you edit your /etc/default/grub file? Could you post it in a pastebin or something?


Board footer

Powered by FluxBB