You are not logged in.

#1 2021-07-21 10:15:12

a_manthey
Member
Registered: 2017-08-21
Posts: 34

[SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

after upgrade of nextcloud to 22.0.0-2 and mariadb to 10.6.3-1 i got an internal server error.
In nextcloud.log i found:

General error: 4047 InnoDB refuses to write tables with ROW_FORMAT=COMPRESSED or KEY_BLOCK_SIZE.

Background and solution here

Offline

#2 2021-07-21 10:30:39

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,270
Website

Re: [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

Since links rot, the workaround is to add

innodb_read_only_compressed=0

to the section [mariadb] in /etc/my.cnf.d/server.cnf.

Offline

#3 2021-08-05 12:28:25

smirky
Member
From: Bulgaria
Registered: 2013-02-23
Posts: 272
Website

Re: [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

I have no luck with this workarond.
I've tried adding it to the [mariadb], [mariadb-10.6] and [mysqld] sections of /etc/my.cnf.d/server.cnf
After restarting the mariadb service, I still get an internal server error.
However, running:

SET GLOBAL innodb_read_only_compressed=OFF;

in the mariadb SQL client, it seems to make this problem go away until the next service restart.
I tried using "0", "off", "OFF" for values in the config. For some reason they all get accepted just fine, but they don't seem to do anything.
What I haven't tried yet is to add it as a command-line argument for starting the service: "--innodb_read_only_compressed=OFF".
The reason is because I haven't found a way to do it without modifying the package systemd service file, which will be overwritten upon the next update.

Last edited by smirky (2021-08-05 12:29:21)


Personal spot  ::  https://www.smirky.net/  ::  Try not to get lost!

Offline

#4 2021-09-18 22:02:36

hedonist
Member
Registered: 2021-09-18
Posts: 2

Re: [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

I put a separate file in /etc/mysql/conf.d/ , which is included in /etc/mysql/my.cnf with the following contents:

[mariadbd]
innodb_read_only_compressed=0

mind the "d" after mariadb in the brackets! This helped me to update nextcloud in docker container in a synology device.

Offline

#5 2021-09-18 22:04:19

hedonist
Member
Registered: 2021-09-18
Posts: 2

Re: [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

forgot to be e-mailed regarding this thread.

Offline

#6 2021-09-27 12:42:13

knille
Member
Registered: 2014-02-24
Posts: 22

Re: [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

unless stated in the arch wiki of mariadb (https://wiki.archlinux.org/title/MariaD … tion_files) on my system mariadb does not take config files from /etc/my.cnf.d/. thus the fix in /etc/my.cnf.d/server.cnf does not work (as it is documented in the wiki, https://wiki.archlinux.org/title/Nextcl … %3E=_10.6). so i had to put

innodb_read_only_compressed = 0

into the [mysqld] section of /etc/my.cnf for fixing the issue.

i don't know whether this is just an issue of my system or whether it is a package problem. you can check what config files your mariadbd takes by:

user@device:~$ mysqld --help --verbose | less
mysqld  Ver 10.6.4-MariaDB-log for Linux on x86_64 (Arch Linux)
Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Starts the MariaDB database server.

Usage: mysqld [OPTIONS]

Default options are read from the following files in the given order:
/etc/my.cnf ~/.my.cnf 

Offline

#7 2021-09-27 14:59:17

knille
Member
Registered: 2014-02-24
Posts: 22

Re: [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

i opened a new thread in the networking section about the mariadb config directory issue:

https://bbs.archlinux.org/viewtopic.php?id=269972

Offline

Board footer

Powered by FluxBB