You are not logged in.

#1 2021-07-31 15:23:28

ObaniGarage
Member
Registered: 2021-07-31
Posts: 1
Website

Can't update packages with pacman -Syu

Hi,

A recent update of fluidsynth is shown in pacman to break depencies with libfluidsynth which breaks every depencies with my music software.

This blocks all the updates I can do. Is this conflict normal ?
I kinda don't want to uninstall all these programs because it might not solve the conflict

résolution des dépendances…
recherche des conflits entre paquets…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de fluidsynth (2.2.2-1) casse la dépendance « libfluidsynth.so=2-64 » requise par ardour
:: l’installation de fluidsynth (2.2.2-1) casse la dépendance « libfluidsynth.so=2-64 » requise par avldrums.lv2
:: l’installation de fluidsynth (2.2.2-1) casse la dépendance « libfluidsynth.so=2-64 » requise par carla
:: l’installation de fluidsynth (2.2.2-1) casse la dépendance « libfluidsynth.so=2-64 » requise par freewheeling
:: l’installation de fluidsynth (2.2.2-1) casse la dépendance « libfluidsynth.so=2-64 » requise par gmsynth.lv2
:: l’installation de fluidsynth (2.2.2-1) casse la dépendance « libfluidsynth.so=2-64 » requise par qsynth


Anyone knows some black magic that could solve this ?


Obani

Offline

#2 2021-07-31 15:25:16

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 14,089

Re: Can't update packages with pacman -Syu

Are you aware that you are running testing?

This problem happens because you have testing enabled but not community-testing as well which would be a precondition of doing that.

If you don't want to do that see: https://wiki.archlinux.org/title/Offici … positories

Moving to the testing subsection.

Last edited by V1del (2021-07-31 15:29:10)

Online

#3 2021-08-15 16:02:13

stefano
Member
Registered: 2011-04-09
Posts: 206

Re: Can't update packages with pacman -Syu

I am having exactly the same problem, and I am NOT running testing. Suggestions not involving removing/reinstalling the affected packages would be appreciated.

Edit: didn't see this is the testing forum (got here from the bbs search page). Will repost in more appropriate forums.

Last edited by stefano (2021-08-15 16:03:42)

Offline

Board footer

Powered by FluxBB