You are not logged in.

#1 2021-08-17 21:03:19

esonn
Member
From: Austria
Registered: 2015-10-01
Posts: 61

How to disable bluetooth auto-connect to devices

Hi everyone,

aside from permanently used/connected bluetooth devices (eg mouse), how can I specifically disable auto-connect for any particular device? The trust setting doesn't seem to help (not trusting the devices leads to notification spamming whether or not to authorize it, followed by an indefinite connect/disconnect loop every ~30 seconds).

Use case: Sometimes I connect to my A/V amp via bluetooth to play music/videos, but most of the time I don't want that to happen. Same with headset. I didn't find any setting in blueman-manager nor bluetoothctl regarding that issue.

Edit: I can block the device using bluetoothctl, which prevents autoconnect. After unblocking, however, bluetooth gets stuck in a connected-disconnected loop, the device won't stay connected until newly paired.

Best,
Erik

PS: Is it just me, or is bluetooth on Linux a major mess? Among other things, I'm completely lost finding a way to get various high-quality headsets working with reasonable duplex audio quality, since it always falls back to HSP/HFP which is catastrophic. Sorry, off-topic.

Last edited by esonn (2021-08-17 21:17:02)


Anyone who quotes me in their sig is an idiot. -- Rusty Russell

Offline

#2 2021-09-10 00:05:13

dharmabm
Member
From: Bangkok, Thailand
Registered: 2010-02-25
Posts: 11

Re: How to disable bluetooth auto-connect to devices

I just came across this while searching for a solution as I am having the same issue, I want some devices to autoconnect but others I only want to do manually. If I find a solution I will post it here.

Offline

#3 2023-02-15 00:40:58

HarryArchibald
Member
Registered: 2023-02-14
Posts: 2

Re: How to disable bluetooth auto-connect to devices

Hey guys.  Has anyone found out how to do this? I'm also after this. With my Bluetooth headphones, I use it on a few machines, and my desktop keeps reconnecting once it loses connection, stealing my connection from my Laptop or Phone.

What I've found is, if I manually disconnect it on my desktop, it won't reconnect.  But if I have it connected to my Desktop, and then connect to them using my laptop, the desktop keeps stealing the connection back.  This is also annoying for when I connect, then sleep my desktop, and it LAAAATER wakes up and reconnects again.  Then I have to first go to my desktop and disconnect it manually.

Cheers,

Offline

#4 2023-02-15 10:23:49

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,326

Re: How to disable bluetooth auto-connect to devices

Offline

#5 2023-11-18 16:48:57

yoline
Member
Registered: 2023-11-18
Posts: 1

Re: How to disable bluetooth auto-connect to devices

I am having the same issue. Anyone find a solution?

Offline

Board footer

Powered by FluxBB