You are not logged in.

#1 2021-09-10 15:27:48

MonitorRuntimeAccess
Member
Registered: 2021-09-10
Posts: 3

Arctis 5 not working on PulseAudio...

Hello,

When I connect my SteelSeries Arctis 5 to my computer, PulseAudio detects the correct profiles (Game and Chat) for the device, but no sound is outputted to these profiles.

I'm unsure what the problem is, but I'm guessing it has something to do with the 'ChatMix Dial' on the headset. I've heard about it from here but that post mentions that the configuration has been merged with the official branch of PulseAudio. I've tried installing 'pulseaudio-alsa' and 'alsa-utils', playing around with 'alsamixer' to no avail.

I'd be grateful if anyone could tell me what the issue is here. smile

Here's some command-line output (if you need more, tell me):

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]  Subdevices: 1/1  Subdevice #0: subdevice #0
card 1: S5 [SteelSeries Arctis 5], device 0: USB Audio [USB Audio]  Subdevices: 1/1  Subdevice #0: subdevice #0
card 1: S5 [SteelSeries Arctis 5], device 1: USB Audio [USB Audio #1]  Subdevices: 1/1  Subdevice #0: subdevice #0

Offline

#2 2021-09-10 15:38:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,996

Re: Arctis 5 not working on PulseAudio...

alsamixer doesn't properly manipulate your pulse state, use pavucontrol.

What's your output of

pacmd list-cards
pacmd list-sinks
pacmd list-sink-inputs

wiht something running that you expect audio out of?

Offline

#3 2021-09-10 16:26:55

MonitorRuntimeAccess
Member
Registered: 2021-09-10
Posts: 3

Re: Arctis 5 not working on PulseAudio...

$ pacmd list-cards

2 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xfe500000 irq 31"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1c20"
		device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 65, available: no)
		output:analog-stereo: Analog Stereo Output (priority 39268, available: unknown)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Built-in Audio Analog Stereo
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
			properties:
				
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
    index: 1
	name: <alsa_card.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00>
	driver: <module-alsa-card.c>
	owner module: 22
	properties:
		alsa.card = "1"
		alsa.card_name = "SteelSeries Arctis 5"
		alsa.long_card_name = "SteelSeries SteelSeries Arctis 5 at usb-0000:00:1d.0-1.2, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.0-usb-0:1.2:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/sound/card1"
		udev.id = "usb-SteelSeries_SteelSeries_Arctis_5_00000000-00"
		device.bus = "usb"
		device.vendor.id = "1038"
		device.vendor.name = "SteelSeries ApS"
		device.product.id = "12aa"
		device.product.name = "SteelSeries Arctis 5"
		device.serial = "SteelSeries_SteelSeries_Arctis_5_00000000"
		device.string = "1"
		device.description = "SteelSeries Arctis 5"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	profiles:
		output:analog-chat+output:analog-game+input:analog-chat: Chat Output + Game Output + Chat Input (priority 5100, available: unknown)
		input:analog-chat: Chat Input (priority 50, available: unknown)
		output:analog-chat: Chat Output (priority 5000, available: unknown)
		output:analog-chat+input:analog-chat: Chat Output + Chat Input (priority 5050, available: unknown)
		output:analog-game: Game Output (priority 5000, available: unknown)
		output:analog-game+input:analog-chat: Game Output + Chat Input (priority 5050, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-chat+output:analog-game+input:analog-chat>
	sinks:
		alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-chat/#1: SteelSeries Arctis 5 Chat
		alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-game/#2: SteelSeries Arctis 5 Game
	sources:
		alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-chat.monitor/#1: Monitor of SteelSeries Arctis 5 Chat
		alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-game.monitor/#2: Monitor of SteelSeries Arctis 5 Game
		alsa_input.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-chat/#3: SteelSeries Arctis 5 Chat
	ports:
		steelseries-arctis-output-chat-common: Chat Output (priority 5000, latency offset 0 usec, available: unknown)
			properties:
				
		steelseries-arctis-output-game-common: Game Output (priority 9900, latency offset 0 usec, available: unknown)
			properties:
				
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"

$ pacmd list-sinks

3 sink(s) available.
    index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9039
	volume: front-left: 32643 /  50% / -18.16 dB,   front-right: 32643 /  50% / -18.16 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	card: 0 <alsa_card.pci-0000_00_1b.0>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC662 rev1 Analog"
		alsa.id = "ALC662 rev1 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xfe500000 irq 31"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1c20"
		device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
			properties:
				
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>
    index: 1
	name: <alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-chat>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9048
	volume: front-left: 45959 /  70% / -9.25 dB,   front-right: 45959 /  70% / -9.25 dB
	        balance 0.00
	base volume: 54094 /  83% / -5.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 1
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	card: 1 <alsa_card.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00>
	module: 22
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "SteelSeries Arctis 5"
		alsa.long_card_name = "SteelSeries SteelSeries Arctis 5 at usb-0000:00:1d.0-1.2, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.0-usb-0:1.2:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/sound/card1"
		udev.id = "usb-SteelSeries_SteelSeries_Arctis_5_00000000-00"
		device.bus = "usb"
		device.vendor.id = "1038"
		device.vendor.name = "SteelSeries ApS"
		device.product.id = "12aa"
		device.product.name = "SteelSeries Arctis 5"
		device.serial = "SteelSeries_SteelSeries_Arctis_5_00000000"
		device.string = "hw:1,0,0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-chat"
		device.profile.description = "Chat"
		device.intended_roles = "phone"
		device.description = "SteelSeries Arctis 5 Chat"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	ports:
		steelseries-arctis-output-chat-common: Chat Output (priority 5000, latency offset 0 usec, available: unknown)
			properties:
				
	active port: <steelseries-arctis-output-chat-common>
  * index: 2
	name: <alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-game>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9049
	volume: front-left: 46074 /  70% / -9.18 dB,   front-right: 46074 /  70% / -9.18 dB
	        balance 0.00
	base volume: 54094 /  83% / -5.00 dB
	volume steps: 65537
	muted: no
	current latency: 62.79 ms
	max request: 12 KiB
	max rewind: 12 KiB
	monitor source: 2
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 75.01 ms; range is 0.50 .. 2000.00 ms
	card: 1 <alsa_card.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00>
	module: 22
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio #1"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "1"
		alsa.card = "1"
		alsa.card_name = "SteelSeries Arctis 5"
		alsa.long_card_name = "SteelSeries SteelSeries Arctis 5 at usb-0000:00:1d.0-1.2, full speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:1d.0-usb-0:1.2:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/sound/card1"
		udev.id = "usb-SteelSeries_SteelSeries_Arctis_5_00000000-00"
		device.bus = "usb"
		device.vendor.id = "1038"
		device.vendor.name = "SteelSeries ApS"
		device.product.id = "12aa"
		device.product.name = "SteelSeries Arctis 5"
		device.serial = "SteelSeries_SteelSeries_Arctis_5_00000000"
		device.string = "hw:1,1,0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-game"
		device.profile.description = "Game"
		device.description = "SteelSeries Arctis 5 Game"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-usb"
	ports:
		steelseries-arctis-output-game-common: Game Output (priority 9900, latency offset 0 usec, available: unknown)
			properties:
				
	active port: <steelseries-arctis-output-game-common>

$ pacmd list-sink-inputs

1 sink input(s) available.
    index: 20
	driver: <protocol-native.c>
	flags: START_CORKED 
	state: RUNNING
	sink: 2 <alsa_output.usb-SteelSeries_SteelSeries_Arctis_5_00000000-00.analog-game>
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 124.99 ms
	requested latency: 75.01 ms
	sample spec: float32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	resample method: copy
	module: 8
	client: 21 <Firefox>
	properties:
		media.name = "AudioStream"
		application.name = "Firefox"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "35"
		application.process.id = "32728"
		application.process.user = "lk"
		application.process.host = "Link"
		application.process.binary = "firefox"
		application.language = "C"
		window.x11.display = ":0.0"
		application.process.machine_id = "b5e28999d2d04420875a329a7047781d"
		application.process.session_id = "2"
		application.icon_name = "firefox"
		module-stream-restore.id = "sink-input-by-application-name:Firefox"

Offline

#4 2021-09-11 22:25:13

MonitorRuntimeAccess
Member
Registered: 2021-09-10
Posts: 3

Re: Arctis 5 not working on PulseAudio...

Don't worry; this topic can be closed. Was due to a defective headset, not software.

Offline

Board footer

Powered by FluxBB