You are not logged in.

#1 2021-09-14 22:30:04

parsilofon
Member
Registered: 2020-06-21
Posts: 9

nvidia-340-xx driver, libglx.so module, glxinfo error [SOLVED]

Well this isn't a help request but the solution I found to a problem I had today. For all those that still use this legacy driver and are having problems with 3d acceleration, and glxinfo is throwing an error saying "X Error of failed request: BadWindow (invalid Window parameter)", I found this solution for me:
For some reason the libglx module that is being loaded belongs to xorg (you can see it in the xorg log where it says the vendor from that module is xorg), so after renaming  /usr/lib/xorg/module/extension/libglx.so to libglx.so.back and copying the one from nvidia to that folder fixed the issue. I hope this can help somebody between the other 10 or 12 people in the world that are still using this driver.

1) mv /usr/lib/xorg/modules/extensions/libglx.so /usr/lib/xorg/modules/extensions/libglx.so.back

2) cp /usr/lib/nvidia/xorg/libglx.so /usr/lib/xorg/modules/extensions/libglx.so

Last edited by parsilofon (2021-09-14 22:30:22)

Offline

#2 2021-09-15 06:28:29

seth
Member
Registered: 2012-09-03
Posts: 23,309

Re: nvidia-340-xx driver, libglx.so module, glxinfo error [SOLVED]

This kind of stuff would belong into the wiki, but it's not so much a solution, but a live-action meme: https://www.youtube.com/watch?v=ddPQAJSm2cQ

The reason why this happens is that the module path isn't extended or extended to the wrong™ path.
https://aur.archlinux.org/cgit/aur.git/ … idia-340xx

ls /usr/lib64/nvidia/xorg /usr/lib64/xorg/modules
pacman -Qi libglvnd

and please post your xorg log.

Possible cause is https://wiki.archlinux.org/title/NVIDIA#Early_loading (though there's probably no nvidia-drm module) or alternatively you wrote a static server config that shadows the configlet and doesn't extend the module path.
In any event: moving around libraries is always a bad idea and you need to pause and rethink whenever you arrive at that point.

Offline

Board footer

Powered by FluxBB