You are not logged in.

#1 2021-09-17 01:26:19

8knight
Member
Registered: 2021-09-17
Posts: 4

Yay and nvm causing compatibility issues

Hi! This is my first post on the archwiki so please excuse me for any mistakes. I have the yay aur helper installed on my laptop, with archlinux working perfectly for ~ a year. I use node version manager (nvm) to manage my node version due to me doing lots of work with javascript & clients. When typing yay, a package is requesting for "[Repo Make:4]  nodejs-nopt-5.0.0-2  semver-7.3.5-2  node-gyp-8.1.0-2  npm-7.23.0-1" which is installing nodejs and npm. The issue is, I already have nodejs (v16.9.1) and npm (v7.24.0) installed. Not sure what to do or if this is some kind of issue with nvm. I included a list of what is trying to be downloaded with yay. (https://pastebin.com/90pWzjMB) Thanks for any help whatsoever!

Offline

#2 2021-09-17 01:38:09

8knight
Member
Registered: 2021-09-17
Posts: 4

Re: Yay and nvm causing compatibility issues

If this is in the wrong category let me know! While what I have to update is mostly IDEs and other games, its not important. Tysm yall r amazing!

Offline

#3 2021-09-17 01:43:02

HalosGhost
Forum Moderator
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,927
Website

Re: Yay and nvm causing compatibility issues

Moving to AUR Issues. smile

All the best,

-HG

Offline

#4 2021-09-17 01:52:10

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,739
Website

Re: Yay and nvm causing compatibility issues

All those node packages are in [community], so why are you using an AUR helper to manage official repositories?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2021-09-17 01:54:40

8knight
Member
Registered: 2021-09-17
Posts: 4

Re: Yay and nvm causing compatibility issues

I'm not 100% sure what you mean, but it seems like the node packages are a build dependency for something. The issue being and seen my the error message, the files already exist. Should I try to download the packages with pacman? Edit: Just tried downloading the packages from the official repo, they all worked except npm, which gave the same files already exist error.

Last edited by 8knight (2021-09-17 01:56:58)

Offline

#6 2021-09-17 02:00:23

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,739
Website

Re: Yay and nvm causing compatibility issues


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#7 2021-09-17 02:01:53

8knight
Member
Registered: 2021-09-17
Posts: 4

Re: Yay and nvm causing compatibility issues

Thanks! So I should uninstall npm from nvm then install it with the official repo?

Offline

#8 2021-09-17 02:06:20

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,739
Website

Re: Yay and nvm causing compatibility issues

You can use either approach, but if you use a language's package manager, the advice is to install to $HOME and use a virtual environment, so packages do not conflict.

You should really also learn to use pacman to manage your packages, and only use an AUR helper for specific AUR tasks. Blurring the line between the two encourages a reliance on an unecessary tool, and prevents a thorough understanding of how an Arch system actually works.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB