You are not logged in.

#1 2021-09-22 07:06:01

jishuo1213
Member
Registered: 2021-09-22
Posts: 3

[Solved]navicat report error after update system

navicat report error:

/tmp/.mount_Navicanoo32t/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

  after updae glib2 library to version 2.70.The navicat is one appimage file and download from navicat website.

Last edited by jishuo1213 (2021-09-26 01:03:35)

Offline

#2 2021-09-22 14:20:52

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,871

Re: [Solved]navicat report error after update system

If the output of

pacman -Qkk glib2

doesn't show any problem, then some unofficial libgmodule-2.0.so.0 library on your system is overriding the official one. You can preprend

LD_DEBUG=libs

to find out where it is.

Offline

#3 2021-09-22 14:38:35

useless.spoiler
Member
Registered: 2021-05-04
Posts: 5

Re: [Solved]navicat report error after update system

I'm having the exact same issue.

Offline

#4 2021-09-22 16:48:23

maoxuner
Member
From: Hangzhou
Registered: 2021-09-22
Posts: 3
Website

Re: [Solved]navicat report error after update system

Solution: Patch glib2 version 2.68.4 into appimage

Steps:

1. Extract appimage file. All files will be in a directory called `squashfs-root`
   ```bash
   your-path/navicat15-premium-en.AppImage --appimage-extract
   ```
   **Tips:** When extracting ends in error as follow, you can try to mount appimage file then copy app source to directory squashfs-root.
   > ./navicat15-premium-en.AppImage --appimage-extract
   > qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 471, resource id: 12928710, major code: 40 (TranslateCoords), minor code: 0
   > /tmp/.mount_whnQrp/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full
   ```bash
   # create app source mount point
   mkdir src
   # mount appimage file(read only)
   sudo mount -o loop your-path/navicat15-premium-en.AppImage src
   # copy all source file(writable)
   cp -r src squashfs-root
   # umount appimage file
   sudo umount src
   rmdir src
   ```

2. Find your `glib2-2.68.4-1-x86_64.pkg.tar.zst` package file.
If you are lucky enough, there will be one in path `/var/cache/pacman/pkg/glib2-2.68.4-1-x86_64.pkg.tar.zst`. Or download it from package repository. Or anywhere.
   ```bash
   https://archive.archlinux.org/packages/ … kg.tar.zst
   ```

3. Extract `glib2-2.68.4-1-x86_64.pkg.tar.zst` to `squashfs-root`
   ```bash
   tar xvf glib2-2.68.4-1-x86_64.pkg.tar.zst -C squashfs-root
   ```

4. Repack squashfs-root into appimage file
   ```bash
   appimagetool squashfs-root navicat15-premium-en-patched.AppImage
   ```

5. no more steps, just run it

---

Here is my article https://www.maoxuner.cn/post/2021/09/na … -glib2-70/

Last edited by maoxuner (2021-10-17 07:42:00)

Offline

#5 2021-09-23 06:59:53

useless.spoiler
Member
Registered: 2021-05-04
Posts: 5

Re: [Solved]navicat report error after update system

maoxuner wrote:

Solution: Patch glib2 version 2.68.4 into appimage

Steps:

1. Extract appimage file. All files will be in a directory called `squashfs-root`

```
your-path/navicat15-premium-en.AppImage --appimage-extract
```

2. Find your `glib2-2.68.4-1-x86_64.pkg.tar.zst` package file.
If you are lucky enough, there will be one in path `/var/cache/pacman/pkg/glib2-2.68.4-1-x86_64.pkg.tar.zst`. Or download it from package repository. Or anywhere.
```
https://archive.archlinux.org/packages/ … kg.tar.zst
```

3. Extract `glib2-2.68.4-1-x86_64.pkg.tar.zst` to `squashfs-root`

```
tar xvf glib2-2.68.4-1-x86_64.pkg.tar.zst -C squashfs-root
```

4. Repack squashfs-root into appimage file

```
appimagetool squashfs-root navicat15-premium-en-patched.AppImage
```

5. no more steps, just run it

---

Here is my article https://www.maoxuner.cn/post/2021/09/na … -glib2-70/

Thanks, works perfectly!

Offline

#6 2021-09-26 01:02:43

jishuo1213
Member
Registered: 2021-09-22
Posts: 3

Re: [Solved]navicat report error after update system

maoxuner wrote:

Solution: Patch glib2 version 2.68.4 into appimage

Steps:

1. Extract appimage file. All files will be in a directory called `squashfs-root`

```
your-path/navicat15-premium-en.AppImage --appimage-extract
```

2. Find your `glib2-2.68.4-1-x86_64.pkg.tar.zst` package file.
If you are lucky enough, there will be one in path `/var/cache/pacman/pkg/glib2-2.68.4-1-x86_64.pkg.tar.zst`. Or download it from package repository. Or anywhere.
```
https://archive.archlinux.org/packages/ … kg.tar.zst
```

3. Extract `glib2-2.68.4-1-x86_64.pkg.tar.zst` to `squashfs-root`

```
tar xvf glib2-2.68.4-1-x86_64.pkg.tar.zst -C squashfs-root
```

4. Repack squashfs-root into appimage file

```
appimagetool squashfs-root navicat15-premium-en-patched.AppImage
```

5. no more steps, just run it

---

Here is my article https://www.maoxuner.cn/post/2021/09/na … -glib2-70/

Thanks, works for me!

Offline

#7 2021-09-29 01:46:24

jhmarryme
Member
Registered: 2021-09-29
Posts: 1

Re: [Solved]navicat report error after update system

May I ask this error when unzipping, how can I solve it?

❯ ./navicat15-premium-en.AppImage --appimage-extract
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
/tmp/.mount_mr2YeK/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

Offline

#8 2021-09-30 02:33:10

sting
Member
Registered: 2021-09-30
Posts: 2

Re: [Solved]navicat report error after update system

I have the same problem

jhmarryme wrote:

May I ask this error when unzipping, how can I solve it?

❯ ./navicat15-premium-en.AppImage --appimage-extract
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
/tmp/.mount_mr2YeK/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

Offline

#9 2021-10-11 09:48:26

maoxuner
Member
From: Hangzhou
Registered: 2021-09-22
Posts: 3
Website

Re: [Solved]navicat report error after update system

Anyone else has the save issue when extract? It seems extract param not working.

Could you post more details?
What is your linux distro? What is your desktop environment? Is your appimage downloaded from navicat official site?

Offline

#10 2021-10-15 02:17:26

fengz
Member
Registered: 2021-10-15
Posts: 1

Re: [Solved]navicat report error after update system

run command:./navicat15-premium-en.AppImage --appimage-extract
errorMsg:/tmp/.mount_Ln3pnt/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

Operating System: Arch Linux                       
Kernel: Linux 5.14.7-arch1-1
Architecture: x86-64
Hardware Vendor: Micro-Star International Co., Ltd.
Hardware Model: MS-7C88
desktop:xfce
xfce-version:4.16

Offline

#11 2021-10-17 07:40:29

maoxuner
Member
From: Hangzhou
Registered: 2021-09-22
Posts: 3
Website

Re: [Solved]navicat report error after update system

fengz wrote:

run command:./navicat15-premium-en.AppImage --appimage-extract
errorMsg:/tmp/.mount_Ln3pnt/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

Operating System: Arch Linux                       
Kernel: Linux 5.14.7-arch1-1
Architecture: x86-64
Hardware Vendor: Micro-Star International Co., Ltd.
Hardware Model: MS-7C88
desktop:xfce
xfce-version:4.16

I don't know why it ends in error when extract.But there's a solution.

   ```
   **Tips:** When extracting ends in error as follow, you can try to mount appimage file then copy app source to directory squashfs-root.
   > ./navicat15-premium-en.AppImage --appimage-extract
   > qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 471, resource id: 12928710, major code: 40 (TranslateCoords), minor code: 0
   > /tmp/.mount_whnQrp/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full
   ```bash
   # create app source mount point
   mkdir src
   # mount appimage file(read only)
   sudo mount -o loop your-path/navicat15-premium-en.AppImage src
   # copy all source file(writable)
   cp -r src squashfs-root
   # umount appimage file
   sudo umount src
   rmdir src
   ```

BBCode sucks! I like markdown.

Offline

#12 2021-10-29 06:01:36

sting
Member
Registered: 2021-09-30
Posts: 2

Re: [Solved]navicat report error after update system

This is very useful to me. Thank you very much

maoxuner wrote:
fengz wrote:

run command:./navicat15-premium-en.AppImage --appimage-extract
errorMsg:/tmp/.mount_Ln3pnt/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

Operating System: Arch Linux                       
Kernel: Linux 5.14.7-arch1-1
Architecture: x86-64
Hardware Vendor: Micro-Star International Co., Ltd.
Hardware Model: MS-7C88
desktop:xfce
xfce-version:4.16

I don't know why it ends in error when extract.But there's a solution.

   ```
   **Tips:** When extracting ends in error as follow, you can try to mount appimage file then copy app source to directory squashfs-root.
   > ./navicat15-premium-en.AppImage --appimage-extract
   > qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 471, resource id: 12928710, major code: 40 (TranslateCoords), minor code: 0
   > /tmp/.mount_whnQrp/AppRun: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full
   ```bash
   # create app source mount point
   mkdir src
   # mount appimage file(read only)
   sudo mount -o loop your-path/navicat15-premium-en.AppImage src
   # copy all source file(writable)
   cp -r src squashfs-root
   # umount appimage file
   sudo umount src
   rmdir src
   ```

BBCode sucks! I like markdown.

Offline

Board footer

Powered by FluxBB